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1.1 Wprowadzenie. 
Aby pobrać najnowszą wersję instalacyjną programu GstarCAD 2016 dla komuptera PC lub serwera odwiedź stronę www.gstarcad.pl/download/.  Środowisko GstarCAD 2016 pozwala na przyspieszenie prac projektowych oraz nanoszenia zmian dzięki nieustannie ulepszanym możliwością rysowania, jeszcze bardziej elastycznym metodom pracy oraz  doskonałej optymalizacji!  Rozdział ten pomoże Ci rozpocząć pracę w programie GstarCAD 2016, znajdziesz w nim podstawowe informacje o programie oraz o procesie jego instalacji.   
1.2 Wymagania sprzętowe 
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1.3 Instalacja programu GstarCAD 2016 
 Intuicyjny kreator instalacji programu GstarCAD przeprowadzi Cię przez proces instalacji.    Aby zainstalować program GstarCAD 2016 ostępuj zgodnie z poniższymi krokami:   1.-Dwukrotnie kliknij lewym przyciskiem myszy na plik instalatora programu, spowoduje to uruchomienie kreatora instalacji programu. W oknie kreatora kliknij przycisk "Browse" (wer. PL: "Przeglądaj"), aby wybrać gdzie program ma zostać zainstalowany. Następnie kliknij przycisk "Options" (wer. PL: "Opcje"). Patrz Rys. 1-1.   2.-W kolejnym oknie możesz zdecydować czy mają zostać zainstalowane dodatkowe funkcje. Zaznacz lub odznacz opcje a następnie kliknij przycisk "Next" (wer. PL: "Dalej"). Patrz Rys. 1-2.  
 
 

 
 
 
  Rys. 1-1                                                                   Rys. 1-2    3.-Po powrocie do pierwszego okna sprawdź poprawność ścieżki do instalacji i kliknij przycisk "Install" (wer. PL: "Instaluj". Patrz Rys. 1-3.   4.-Zapoznaj się z treścią umowy licencyjnej oraz zaznacz opcję “Accept the terms of the license agreement” (wer. PL: "Akceptuję warunki licencji") aby ją zaakceptować.  Kliknij przycisk "Next" (wer. PL: "Dalej"). Patrz Rys. 1-4.               Rys. 1-3                                                                   Rys. 1-4  
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5.-Kreator instalacji programu GstarCAD jest gotowy. Jeżeli chcesz przeglądnąć lub edytować wybrane opcje kliknij przycisk "Back" (wer. PL: "Wstecz"). Aby uruchomić proces instalacji kliknij przycisk "Install" (wer. PL: "Instaluj"). Patrz Rys. 1-5. 
 6.-Po zakończeniu procesu instalacji zostaniesz poproszony o wybranie wyglądu interfejsu (można go również zmienić w czasie pracy programu). Aby zamknąć okno kreatora kliknij przycisk "Finish" (wer. PL: "Zakończ"). Patrz Rys. 1-6.              Rys. 1-5                                                                   Rys. 1-6  Pamiętaj: AutoXlsTable wymaga oddzielnej instalacji, należy je zainstalować w przypadku problemów zgodności pakietu MS Office z opcją AutoXlsTable w zakładce Express.   Aby zainstalować AutoXlsTable wykonaj poniższe czynności: 
1.-Kliknij dwukrotnie na ikonę instalatora "AutoXlsTable_InstallShield Wizard"  aby uruchomić kreator instalacji. W wyświetlonym oknie dialogowym kliknij przycisk 'Next" aby kontynuować. Patrz Rys. 2-1.    

   Rys. 2-1  
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2.-Z menu rozwijalnego wybierz wersję posiadanego pakietu MS Office i kliknij przycisk "Next". Patrz Rys. 2-2. 

  Rys. 2-2   
3.-Kliknij przycisk "Install" aby rozpocząć proces instalacji. Jeżeli chcesz przeglądnąć lub zmienić wybrane opcje kliknij przycisk "Back". Patrz Rys. 2-3. 

 
Rys. 2-3  
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4.-Gdy proces instalacji zostanie zakończony poprawnie kliknij przycisk "Finish", aby zamknąć kreator instalacji. Patrz Rys. 2-4.  

  Rys. 2-3    
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2. Rozpoczęcie pracy w programie GstarCAD 2016 
 
2.1. Interfejs użytkownika 
Możliwości personalizacji wyglądu interfejsu pozwalają na korzystanie z programu GstarCAD na wiele sposobów. Możesz modyfikować takie elementy jak paski narzędzi, wyświetlanie wiersza poleceń, przełączanie pomiędzy obszarami roboczymi, zmiana schematów (tematów) kolorystycznych oraz wyświetlanie paska stanu. Dodatkowo paski narzędzi mogą być dowolnie przesuwane na ekranie oraz dokowane. 

   

 

2.1.1. Pasek szybkiego dostępu: Wyświetla często używane narzędzia, takie jak: New"(wer. PL: Nowy...), Open (wer. PL: Otwórz), Save (wer. PL Zapisz...),  Undo (wer. PL: Cofnij), Redo (wer. PL: Odtwórz), Save As (wer. PL: Zapisz jako), Plot (wer. PL: Drukuj...), Plot Preview (wer. PL:  Podgląd wydruku) i Help (wer. PL: Pomoc). Możesz również spersonalizować ten pasek (dodać więcej poleceń metodą "przeciągnij i upuść") lub wybrać miejsce wyświetlania (nad lub pod wstążką).    
2.1.2. Zmiana wyglądu interfejsu: Pozwala na zmianę wyglądu interfejsu pomiędzy widokiem 2D Drafting (wer. PL: Wstążkowy) i GstarCAD Classic (wer. PL: Klasyczny).  
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2.1.3. Pasek menu: Pozwala on na wywoływanie poleceń zamiast uruchamiania ich za pomocą wiersza poleceń. Znajdziesz na nim następujące zakładki: File (wer. PL: Plik), Edit (wer. PL: Edytuj), View (wer. PL: Widok), Insert (wer. PL: Wstaw), Format (wer. PL: Format), Tools (wer. PL: Narzędzia) Draw (wer. PL: Rysuj), Text (wer. PL: Tekst), Dimension (wer. PL: Wymiar), Modify (wer. PL: Modyfikuj), Window (wer. PL: Okno), Help (wer. PL: Pomoc) i Express (wer. PL: Express).           
2.1.3.1. Menu oraz Menu Skrótów  Możesz użyć każdą z opcji z paska menu znajdującego się w górnej części obszaru rysunku. Wybierz jedną z poniższych metod korzystania z menu: -Kliknij nazwę wybranego menu znajdującej się na pasku menu aby ją wybrać, lub rozwinąć listę dostępnych opcji. -Wciśnij przycisk Alt oraz literę podkreśloną w nazwie menu, aby otworzyć odpowiednie okno zawierające listę dostępnych pozycji, i wybrać z niego odpowiednią opcję. Na przykład do edycji  pliku rysunku użyj kombinacji <Alt+E>, aby wyświetlić menu Edytuj.    Menu Skrótów pozwala na szybki dostęp do określonych poleceń. Menu Skrótów zostaje wyświetlone poprzez kliknięcie prawym przyciskiem myszy na obiekt, pasek stanu, zakładkę Model lub Layouy (we. PL: Układ). Jego zawartość zależy od elementu, którego dotyczy.                
2.1.3.2. Personalizacja skrótów  Najszybszą drogą wywoływania poleceń jest spersonalizowanie skrótów. Polecenie CUSTACC pozwala użytkownikowi na dostosowanie, usuwanie lub edycję istniejących skrótów. Aby uzyskać dostęp do tego polecenia rozwiń menu Narzędzia, z dostępnych opcji wybierz "Dostosuj", a następnie "Dostosowuje skróty(A)...". Spowoduje to wyświetlenie okna edycji skrótów. Zawiera ono listę zdefiniowanych skrótów, którą można łatwo zarządzać za pomocą przycisków "New..." (wer. PL: "Nowy..."), "Modify" (wer. PL: "Zmień") oraz "Delete" (wer. PL: "Usuń"). 
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Jeśli chcesz utworzyć nowy skrót, kliknij przycisk "New..." 
(wer. PL: "Nowy") aby wyświetlić okno personalizacji. 
Następnie możesz wyszukać odpowiednie polecenie lub 
wybrać je bezpośrednio z listy dostępnych poleceń. Na 
przykład, wprowadź w wyszukiwarce frazę "wiersz 
poleceń" a następnie zaznacz z listy żądane polecenie. 
Zwróć uwagę, że po zaznaczeniu wybranego polecenia 
zostają wyświetlane jego właściwości w prawej części 
okna. Po wybraniu żądanej opcji kliknij przycisk "OK". 
 Zostanie wyświetlone okno Zestawu skrótów. Możesz w nim wprowadzić wybraną przez siebie, dostępną kombinację klawiszy lub pojedynczą literę. Na przykład, możesz wprowadzić literę "Q". Jeśli chcesz usunąć utworzony skrót skorzystaj z przycisku "Delete" (wer. PL: "Usuń") z okna dostosowania skrótów.   
2.1.4. Wstążka: Składa się ona z paneli, ułożonych w zakładkach według określających funkcje etykiet. Narzędzia i elementy sterujące w każdym panelu są również dostępne w paskach narzędzi oraz odpowiednich oknach dialogowych.              Panel                       Zakładka               Panel rozwijalny               Przycisk rozwijania opcji narzędzia   Zakładka: Wstążka złożona jest z zakładek. Każda z nich wyświetla zestaw paneli zawierających określone narzędzia (polecenia lub miniatury), ułatwiając do nich dostęp.  Panel: W panelach wyświetlane są najbardziej użyteczne narzędzia. Niektóre miniatury posiadają przycisk rozszerzający, pozwalający na pokazanie pozostałych dostępnych funkcji. Dodatkowo większość paneli w zakładce "Narzędzia główne" posiada panel rozwijalny, dający możliwość pokazania pozostałych powiązanych z nimi poleceń.  Panel rozwijalny: Znajduje się on w dolnej części panelu. Po kliknięciu na niego wyświetlone zostają dodatkowe dostępne polecenia.    Przycisk rozwijania opcji narzędzia: Niektóre miniatury posiadają dodatkowy przycisk rozszerzający. Po kliknięciu na niego wyświetlone zostaną wszystkie powiązane z danym narzędziem opcje.  

   



2. Rozpoczęcie pracy w programie GstarCAD 2016

 

 
2.1.5. Wygląd: Program GstarCAD pozwala na zarządzanie schematami kolorystycznymi oraz wyświetlanymi elementami interfejsu.              
2.1.6. Obszar rysunku: Obszar, w którym wykonywane są rysunki wyświetlany jest w oknie rysunku.                 
 
2.1.7. Paski narzędzi: Paski narzędzi częściowo zawierają przyciski bezpośrednio wykonujące polecenia. Gdy najedziesz kursorem na znajdujący się na pasku narzędzi, wyświetlona zostanie nazwa polecenia jakie reprezentuje. 
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Program GstarCAD pozwala na zarządzanie schematami kolorystycznymi oraz wyświetlanymi elementami interfejsu.

Obszar, w którym wykonywane są rysunki wyświetlany jest w oknie rysunku. 

Paski narzędzi częściowo zawierają przyciski bezpośrednio wykonujące polecenia. Gdy najedziesz kursorem na znajdujący się na pasku narzędzi, wyświetlona zostanie nazwa polecenia jakie reprezentuje. 

 

Program GstarCAD pozwala na zarządzanie schematami kolorystycznymi oraz wyświetlanymi elementami interfejsu. 

Paski narzędzi częściowo zawierają przyciski bezpośrednio wykonujące polecenia. Gdy najedziesz kursorem na przycisk 



2. Rozpoczęcie pracy w programie GstarCAD 2016 
 

19  

Standardowy pasek narzędzi znajdujący się w górnej części obszaru rysunku zawiera powszechnie używane polecenia, 
takie jak: Copy (wer. PL: Kopiuj), Plot (wer. PL: Drukuj), Zoom oraz standardowe polecenia znane z innych programów 
(Nowy, Otwórz, Zapisz...). Interfejs klasyczny programu GstarCAD 2016 domyślnie wyświetla kilka domyślnie ustawionych 
pasków narzędzi: 
 
-Rysuj 
-Porządek rysowania 
-Zmiana 
-Właściwości 
-Warstwa 
-Styl 
-Standard 
 
2.1.7.1. Wyświetlanie i ukrywanie pasków narzędziowych  W programie GstarCAD 2016 znajduje się wiele pasków narzędziowych, aby interfejs był bardziej przejrzysty możesz zarządzać ich wyświetlaniem za równo podczas pracy w interfejsie Klasycznym, jak i Wstążkowym. Ponadto możesz dowolnie zmieniać ich położenie oraz dokować w wybranych miejscach. Aby określić, które paski narzędzi mają być widoczne należy: 
1.-Wykonać polecenie TOOLBAR wpisując je w wierszu poleceń, lub wybrać opcję Toolbars (wer. PL: Paski narzędzi) z menu rozwijalnego Appearance (wer. PL: Wygląd) znajdującego się w prawym górnym rogu interfejsu programu. Wyświetlone zostanie okno dialogowe. 
2.-Wybierz, które z pasków narzędzi mają być wyświetlane, a które ukryte. W tym celu zaznacz lub odznacz wybrane paski. 
 
            Aby uwolnić poziomo zadokowany pasek narzędzi, kliknij i przytrzymaj jego lewą krawędź a następnie przeciągnij w wybrane miejsce na ekranie.  Aby uwolnić pionowo zadokowany pasek, kliknij i przytrzymaj górną krawędź a następnie przeciągnij w wybrane miejsce. Aby zadokować uwolniony pasek narzędzi, kliknij dwukrotnie na jego lewą krawędź.   
2.1.7.2. Wywoływanie poleceń za pomocą pasków narzędzi  Aby wywołać polecenie kliknij na reprezentujący je przycisk na pasku narzędzi.   
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2.1.8. Lokalny układ współrzędnych (LUW): Ikona wskazuje orientację rysunku, w dwóch wymiarach.             
2.1.9. Zakładki Model i Układ: Kliknij na wybraną zakładkę, aby przełączyć widok pomiędzy obszarem roboczym a układem druku.                      
2.1.10. Okno poleceń: Pasek poleceń jest oknem, w którym możesz wprowadzać polecenia oraz przeglądać powiadomienia i inne komunikaty wyświetlane przez program. Możesz w łatwy sposób przenieść pasek poleceń za pomocą metody "złap i przeciągnij". 
Gdy pasek poleceń jest uwolniony, możesz rozciągnąć okno aby zwiększyć liczbę wyświetlanych w nim linijek. Możesz również zadokować pasek poleceń w górnej lub dolnej części okna rysunku. 
 
       



2. Rozpoczęcie pracy w programie GstarCAD 2016 
 

21  

2.1.10.1. Wprowadzanie poleceń w Wierszu Poleceń  Wprowadź polecenie wpisując je w wierszu poleceń i zatwierdź wciskając klawisz ENTER lub SPACJA ,bądź kliknij prawym przyciskiem myszy. Niektóre polecenia posiadają dodatkowo skróconą nazwę.    
2.1.10.2. Określanie Opcji poleceń  Po wywołaniu polecenia wyświetlone zostają dodatkowe opcje zawarte w poleceniu lub okno dialogowe. Aby wybrać daną opcję, wprowadź jedną z dostępnych w nawiasach nazw opcji (wielkość liter nie ma znaczenia). Następnie wciśnij klawisz ENTER lub SPACJA.   

2.1.10.3. Wykonywanie, powtarzanie i anulowania poleceń  Aby wykonać polecenie wciśnij klawisz ENTER lub SPACJA, bądź kliknij prawym przyciskiem myszy. Jeżeli chcesz powtórzyć ostatnie polecenie ponownie wciśnij klawisz ENTER lub SPACJA. Aby anulować wprowadzone polecenie użyj klawisza ESC.  
2.1.10.4. Zagnieżdżanie polecenia  Aby użyć polecenia wewnątrz wywołanego już wcześniej polecenia wprowadź apostrof przed nazwą nowego polecenia. Na przykład, aby włączyć SNAP obiektu podczas rysowania okręgu wprowadź: 
Polecenie: circle > Określ punkt środka okręgu lub [3P/2P/Ttr/Łuk(A)/Wiele(M)/Koncentrycznie(C)]: 'osnap 
(Ustaw SNAP obiektu na Center (wer. PL: Centrum) w oknie ustawień rysunkowych, następnie zamknij okno dialogowe aby rozpocząć wykonywanie polecenia circle)               
 
 
2.1.10.5. Wprowadzanie Zmiennych Systemowych w Wierszu poleceń  Zmienne systemowe mają wpływ na sposób działania niektórych poleceń. Na przykład, polecenie GRIDMODE służy do sterowania widocznością siatki (wł=1; wył=0).   
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2.1.10.6. Korzystanie z Okna Historii Powiadomień  Okno historii powiadomień zawiera historię wprowadzonych poleceń i komunikatów, wprowadzonych i wyświetlonych w czasie bieżącej sesji programu.  Aby wyświetlić okno wciśnij klawisz F2.  Możesz przewijać zawartość za pomocą strzałek Góra (↑) i  Dół (↓) na klawiaturze, lub rozciągnąć okno aby zwiększyć pole widzenia.       
2.1.10.7. Przełączanie Okien Dialogowych i Wiersza Poleceń  Jeśli wprowadzisz polecenie LINETYPE w wierszu poleceń spowoduje ono wyświetlenie okna dialogowego menadżera typów linii. Wprowadzając polecenie -LINETYPE, w wierszu poleceń zostaną wyświetlone odpowiednie opcje polecenia LINETYPE. Zmienne systemowe wyróżnione poniżej również wpływają na sposób wyświetlania okien dialogowych: 
-ATTDIA pozwala określić, czy polecenie INSERT korzysta z okna dialogowego podczas wprowadzania wartości atrybutu. 
-EXPERT określa, czy mają byś wyświetlane niektóre ostrzegawcze okna dialogowe 
-FILEDIA kontroluje wyświetlanie okna dialogowe używanych wraz z poleceniami odczytu i zapisu plików. Na przykład, jeżeli FILEDIA ma wartość 1, polecenie OPEN spowoduje wyświetlenie okno dialogowe wyboru plików. Jeżeli polecenie FILEDIA posiada wartość 0, powiadomienia dotyczące otwierania pliku zostaną wyświetlone w wierszu poleceń. Nawet gdy ustawisz wartość polecenia FILEDIA na 0, możesz otworzyć okno dialogowe wyboru plików poprzez wprowadzenie znaku tyldy (~) w pierwszym wierszu po wprowadzeniu polecenia OPEN. 
 

2.1.10.8. Wprowadzanie dynamiczne 
Okno dynamicznego wprowadzania jest niezadokowanym oknem pojawiającym się nieopodal kursora krzyża. Pozwala ono na szybki i wygodne wprowadzanie poleceń lub zmiennych systemowych w sposób dynamiczny i wyświetlić dodatkowe informacje. Gdy tryb DYN jest aktywny, nieopodal kursora wyświetlane zostaje rozwijalne menu. Podczas wpisywania polecenia wyświetlana zostaje lista wszystkich poleceń, które zbliżone są do wprowadzanej przez użytkownika nazwy. Dodatkowo wyświetlane są również ikony przypisane do poleceń, co pozwala na łatwiejsze rozpoznawanie poleceń i ich funkcji. Co więcej wprowadzanie dynamiczne wyświetla wszystkie opcje dostępne dla wprowadzonego polecenia i pozwala na wybieranie ich na kilka sposobów.  
  
2.1.11. Pasek Stanu: Wyświetla informacje takie jak bieżące współrzędne kursora, Snap, Siatka, Tryb Orto, Śledzenie biegunowe i pozostałe ustawienia. W dodatku pasek stanu pozwala na szybki dostęp do wielu funkcji. Klikając na zawartość paska możesz dokonywać zmian, kliknięcie prawym przyciskiem myszy na zawartość paska powoduje wyświetlenie krótkiego menu 
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zawierającego więcej dostępnych opcji. Domyślnie pasek stanu wygląda jak poniżej: 

   Ikony na pasku stanu mogą być wyświetlane również w formie przycisków tekstowych, aby zmienić wyświetlanie po prostu kliknij prawym przyciskiem myszy na zawartość  paska stanu i odznacz opcję "Use Icon" (wer. PL: "Użyj ikony").     
 
 
2.1.12 Paleta Właściwości: Program GstarCAD pozwala na zmianę wartości oraz właściwości obiektów. Paleta właściwości zawiera wszystkie właściwości zaznaczonego obiektu. Gdy zaznaczysz kilka obiektów jednocześnie, w palecie właściwości znajdą się główne właściwości zaznaczonych elementów. Gdy żaden element na rysunku nie jest zaznaczony, paleta właściwości wyświetla ogólne właściwości bieżącej warstwy. Właściwość View (wer. PL: "Widok") dostarcza informacji odnośnie LUW. Domyślnie podwójne kliknięcie na obiekt powoduje wyświetlenie palety właściwości, jeśli jest ukryta. Operacja ta jest niedostępna, gdy obiekt jest blokiem, kreskowaniem, wzorem kreskowania, tekstem, wielolinią, zewnętrznym odnośnikiem lub wypełnieniem gradientowym.  
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2.2. Dostosowanie środowiska pracy 
 W programie GstarCAD 2016 pozwala na spersonalizowanie wielu elementów środowiska pracy.  
2.2.1.  Ustawienia opcji interfejsu 
W oknie dialogowym opcji możesz zmienić wiele ustawień wpływających na interfejs i środowisko pracy.                        
 
2.2.2.  Ustawienia zmieniające interfejs: 
Automatic Save (wer. PL: Automatyczny zapis): Znajduje się w zakładce Open and Save (wer. PL: Otwórz i Zapisz). Pozwala na określenie czasu, po jakim ma następować automatyczne zapisanie zmian w otwartym pliku. Aby skorzystać z tej opcji, zaznacz opcję i określ czas zapisu (w minutach).                      
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  Color (wer. PL: Kolor): Znajduje się w zakładce Display 
(wer. PL: Ekran). Pozwala na określenie kolorów tła 
używanych w zakładce Model i Układ, a także kolorów 
używanych w powiadomieniach czy kursorze krzyża. 
Font (wer. PL: Czcionka): W zakładce Display (wer. PL: 
Ekran) możesz również zmienić style czcionek używane 
w oknach programu. Zmiany tekstu nie dotyczą zmian 
tekstu na rysunku. 

 

 
Search Path (wer. PL: Ścieżka wyszukiwania...): Znajduje 
się w zakładce File (wer. PL: Plik). Pozwala na określenie 
ścieżki, pod jaką mają być wyszukiwane pliki pomocnicze 
rysunku , takie jak czcionki tekstu, rysunki, typy linii czy 
wzory kreskowania.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
2.2.3. Zapisywanie i Przywracanie Profili 
Aby ułatwić pracę w programie możesz tworzyć profile dla różnych użytkowników czy projektów, a następnie udostępniać je po przez ich importowanie i eksportowanie. Domyślnie bieżące ustawienia opcji są przechowywane w profilu Default. Bieżąca nazwa profilu jest równocześnie nazwą bieżącego rysunku i wyświetlana jest w oknie dialogowym opcji.                    Program GstarCAD 2016 przechowuje informacje o profilach w rejestrze systemowym, w postaci pliku tekstowego (plik ARG). 
Jeśli chcesz zapisać zmiany w profilu podczas trwania sesji programu i chciałbyś je zapisać, musisz skorzystać z opcji eksportowania profilu. Jeżeli wyeksportowany plik będzie miał taką samą nazwę jak używany przez Ciebie profil, program GstarCAD zaktualizuje plik ARG wprowadzając  do niego zmiany ustawień z wyeksportowanego pliku. Możesz również ponownie zaimportować plik aby ręcznie dokonać aktualizacji ustawień profilu. 
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2.3. Personalizacja interfejsu użytkownika. 
 Metoda "przeciągnij i upuść": Innowacyjny sposób personalizacji interfejsu powinien być szybki i intuicyjny, na przeciw tym oczekiwaniom wychodzi możliwość personalizacji poprzez przeciąganie poszczególnych elementów interfejsu za pomocą wskaźnika myszy. Dzięki tej opcji, w oknie dialogowym Dostosowania interfejsu użytkownika możesz po prostu przeciągnąć wybrane polecenie z listy poleceń w miejsce, które będzie dla Ciebie najbardziej wygodne na przykład do jednego z paneli wstążki czy paska narzędzi widocznego w prawej górnej części okna dialogowego interfejsu użytkownika.                              Krótkie wprowadzenie do okna dialogowego Dostosowywania interfejsu użytkownika (CUI): 1. Okno dialogowe CUI: Zawartość tego okna została podzielona i umieszczona w trzech zakładkach: Elements Customization (wer. PL: Dostosowywanie elementów), Workspace Customization (wer. PL: Dostosowywanie przestrzeni roboczej) i Transfer (wer. PL: Transfer). Najbardziej interesująca jest pierwsza zakładka, w której możemy dokonywać personalizacji metodą "przeciągnij i upuść".     
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2. Menu kontekstowe:  Jest to menu dostępne dla wielu elementów interfejsu, wyświetlające się po kliknięciu prawego przycisku myszy, jak pokazano poniżej:                3. Wyszukiwanie poleceń: Występuje kilka sposobów na szybkie wyszukanie potrzebnego polecenia. Nie musisz przeglądać całej listy poleceń.                      1-Filtr poleceń ze względu na kategorię: Kliknij przycisk strzałki aby rozwinąć listę kategorii, następnie wybierz z niej żądaną kategorię. Dzięki temu wyświetlone zostaną tylko polecenia związane z wybraną kategorią.  
2-Filtrowanie za pomocą słów kluczowych: Wprowadź wybraną nazwę aby wyświetlić na liście tylko te elementy, które są z nią powiązane. Na przykład wprowadź słowo "dimension" (wer. PL: "wymiar"), spowoduje to wyświetlenie na liście tylko komend związanych z wymiarami. 
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3-Czyszczenie poleceń: Jeżeli wprowadzisz słowo kluczowe, ikona  zostanie automatycznie zmieniona na . Po kliknięciu na nią bieżący filtr zostanie anulowany. 
4-Znajdź i zamień: Jeśli zajdzie potrzeba aby dodać inne polecenia do listy poleceń, możesz ustawić elementy kierując się bieżącymi ustawieniami poleceń tak jak pokazano poniżej. 
                  Odświeżanie i resetowanie: Jeżeli wszystkie operacje związane z personalizacją zostały zakończone, ale ich efekt nie jest zgodny z oczekiwaniami, opcje Odświeżania i Przywracania pomogą przywrócić domyślne ustawienia. Restore (wer. PL: Odśwież): pozwala na przywrócenie kopii zapasowej ustawień, kliknij przycisk "Apply" (wer. PL: "Zatwierdź"), dane sprzed modyfikacji zostaną zapisane jako kopia zapasowa i zostaną wykorzystane w przypadku potrzeby przywrócenia ustawień. Reset (wer. PL: Resetuj):  powoduje przywrócenie ustawień do stanu domyślnego.       
2.4. Palety narzędzi 
Palety narzędzi są paskami podzielonymi na zakładki, umieszczone w oknie Palet narzędzi. Elementy dodane do palety narzędzi nazywane są narzędziami. Możesz dodać nowe narzędzie przeciągając obiekt do palety. W programie GstarCAD bloki oraz odnośniki zewnętrzne (XREF'y) również mogą być przeciągane do palety narzędzi. Nowe narzędzie wstawione do palety ma te same właściwości jakie obiekt miał w obszarze rysunku. Możesz również tworzyć, edytować, zmieniać nazwy oraz personalizować panele palety klikając na nią prawym przyciskiem myszy. Aby wyświetlić paletę narzędzi wciśnij klawisz CTRL+3 lub wprowadź polecenie TOOLPALETTES.       
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2.5. Centrum projektowania 
Za pomocą centrum projektowania możesz organizować dostęp do rysunków, stylów tekstu oraz innych elementów: 
-Przeglądaj zawartość rysunku bezpośrednio na swoim komputerze lub za pomocą dysku sieciowego. -Przeglądaj tabele definicji określonych obiektów, a następnie wstaw, załącz, kopiuj i wklejaj definicje w bieżącym rysunku. -Twórz skróty do rysunków oraz folderów aby mieć do nich szybki dostęp. -Dodaj zawartość taką jak pliki XREF, bloki do rysunku. -Przeciągaj rysunki, bloki do palety narzędzi aby mieć do nich wygodny dostęp. 
Zakładka Folder (wer. PL: Katalog): Pozwala na dostęp oraz przeglądanie katalogów systemu Windows. 
Zakładka Open Drawings (wer. PL: Otwórz rysunki): Wyświetla listę otwartych rysunków. Jeśli klikniesz na plik rysunku, a następnie kliknij jedną z tabel definicji, możesz załadować zawartość do obszaru zawartości. 
Zakładka History (wer. PL: Historia): Zostanie wyświetlona lista uprzednio otwartych plików. Po dwukrotnym kliknięciu pliku rysunku z listy, można załadować zawartość do obszaru zawartości. 
Favorites (wer. PL: Ulubione): Jeżeli posiadasz zawartość, do której potrzebujesz szybkiego dostępu, centrum projektowania jest rozwiązaniem pozwalające na szybkie ich wyszukiwanie. Gdy zaznaczysz jakikolwiek typ zawartości, możesz kliknąć prawym przyciskiem myszy i z menu kontekstowego wybrać "Add it to Favorites" (wer. PL: "Dodaj do ulubionych"). W folderze ulubionych możesz zapisać skróty do zawartości z lokalnego dysku twardego lub dysku sieciowego. Źródłowy plik lub folder nie zostanie przeniesiony; ale wszystkie skróty utworzone w ten sposób będą przechowywane w folderze Ulubione.   
2.6. Czyszczenie ekranu 
Teraz, jeśli chcesz zmaksymalizować przestrzeń rysunku, wystarczy nacisnąć Ctrl + 0 lub wybierz ikonę (Clean screen, wer. PL: Wyczyść ekran) znajdujący się w prawym rogu paska stanu. Po wykonaniu tego polecenia, Paski narzędzi i dokujące okna (z wyjątkiem głównego menu, wiersza poleceń oraz pasek stanu) zostaną automatycznie wyczyszczone. Ta funkcja zapewnia większą czytelność, pozwalając na większe uwydatnienie szczegółów.   
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2.7. Zablokowanie Interfejsu Użytkownika 
Blokada UI blokuje położenie i rozmiar pasków narzędzi i okien dokowalnych, takich jak palety właściwości, centrum projektowania itp Aby odblokować je tymczasowo, przytrzymaj klawisz CTRL. Ustawienia blokady zostaną zapisane jako kod bitowy, o wartościach: 0 Paski narzędzi i okna nie są zablokowane 1 Dokowalne paski narzędzi są blokowane 2 Dokowalne lub zakotwiczone okna są zablokowane 4 Pływające paski narzędzi są zablokowane 8 Pływające okna zablokowane 
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3. Tworzenie, otwieranie, Zapis, Przywracanie oraz Zarządzanie rysunkami. 
 
3.1. Tworzenie rysunku 
 
3.1.1. Tworzenie nowego rysunku korzystając z ustawień domyślnych 
Gdy zmienna systemowa polecenia FILEDIA i STARTUP ma wartość 1, wprowadzając polecenie NEW w wierszu poleceń wywołasz startowe okno dialogowe. Możesz z niego wybrać tworzenie nowego rysunku za pomocą wzorów Default Settings (wer. PL: Ustawienia domyślne), Template (wer. PL: Szablon) lub Wizard (wer. PL: Kreator).  Możesz zdecydować jakie jednostki mają zostać użyte na rysunku, imperialne lub metryczne.  Dla jednostek imperialnych domyślne wartości granicy wynoszą 12 x 9 cali.  Dla jednostek metrycznych domyślne wartości granicy wynoszą 429 x 297 milimetrów.  
3.1.2. Tworzenie nowego rysunku korzystając z kreatora. 
Ze startowego okna dialogowego wybierz ikonę "Use a Wizard" (wer. PL: "Użyj kreatora"). W zakładce dostępne są dwie opcje do wyboru.  Ustawienia zaawansowane Za pomocą tej opcji możesz ustalić jednostki miar, dokładność wyświetlania jednostek oraz granice siatki. Dodatkowo pozwala ona na określenie ustawień kąta takie jak miara, dokładność, kierunek oraz zwrot korzystając z pliku gcadiso.dwt. 
 
             
 
Ustawienia szybkie Za pomocą tej opcji możesz określić jednostki miary, dokładność wyświetlania jednostek oraz granice siatki z wykorzystaniem pliku gcadiso.dwt. 
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3.1.3. Tworzenie nowego rysunku korzystając z szablonów 
Gdy zachodzi potrzeba utworzenia kilku rysunków o tych samych ustawieniach możesz utworzyć szablon, który pozwoli na ich tworzenie bez konieczności wprowadzania ręcznie ustawień. Plik szablonu przechowuje informacje takie jak rodzaje jednostek i ich dokładność, bloki tytułowe, granice, nazwy warstw, ustawienia SNAP, GRID i ORTO, granice siatki, style wymiarowania, style tekstu oraz typy linii. 
Dodatkowo gdy zmienna systemowa polecenia FILEDIA  ma wartość 1 a polecenia STARTUP 0, wprowadzenie polecenia NEW powoduje wywołanie okna dialogowego szablonów. Możesz za jego pomocą wybrać żądany plik szablonu lub szablon domyślny klikając na przycisk strzałki obok przycisku Open (wer. PL: Otwórz). 
 
 
 
3.2. Otwieranie rysunku 
 

3.2.1. Otwieranie rysunku 
Możesz otworzyć rysunek w formacie DWG, DXF i DWT. Dodatkowo możesz sprawdzić rysunek, który może być uszkodzony. 
 
 
 
Aby otworzyć istniejący rysunek wybierz:  Wersja ENG: File > Open Wersja PL: Plik > Otwórz 
Lub wprowadź polecenie OPEN w wierszu poleceń, bądź skorzystaj ze skrótu CTRL + O 
-W oknie dialogowym wybierz format pliku, który chcesz otworzyć. 
-Wybierz folder zawierający plik. -Wybierz plik rysunku Skorzystaj z przycisku Open (wer. PL: Otwórz) lub dwukrotnie kliknij na plik lewym przyciskiem myszy aby go otworzyć.  
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3.2.2. Otwieranie wielu rysunków 
Możesz otworzyć wiele rysunków jednocześnie. Istnieje kilka metod przełączania się pomiędzy nimi. 
-Przełącz się pomiędzy rysunkami klikając na ich zakładki na pasku systemu Windows lub korzystając ze skrótu CTRL + Tab. -Możesz zmienić styl wyświetlania na Cascade (wer. PL: Kaskadowo), Title Vertical (wer. PL: Sąsiadujące pionowo), Title Horizontally (wer. PL: Sąsiadujące poziomo), z menu Window (wer. PL: Okno). Możesz również uporządkować ikony jeżeli pracujesz jednocześnie na przynajmniej kilku rysunkach.                 
3.3. Zapisywanie rysunku 
3.3.1. Zapisywanie rysunku 
Możesz zapisać nowo utworzony rysunek lub zmiany dokonane na istniejącym już rysunku. Możesz również skorzystać z opcji automatycznego zapisywania i tworzenia kopii zapasowej, lub zapisywać tylko zaznaczone obiekty. W dodatku możesz zapisać rysunek w formacie DXF, lub w formacie szablonu DWT. Jeżeli utworzyłeś nowy rysunek za pomocą pliku szablonu, nie zostanie on nadpisany ani zastąpiony. 
Aby zapisać rysunek wybierz: Wersja ENG:  File > Save Wersja PL:  Plik > Otwórz 
Lub wprowadź polecenei SAVE w wierszu poleceń, lub skorzystaj ze skrótu CTRL + S 
 
 
             Uwaga: Gdy zapisujesz rysunek po raz pierwszy, programu wywoła okno dialogowe zapisu pliku. Za jego pomocą wybierz miejsce na dysku, w którym plik ma zostać zapisany. 
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3.3.2. Automatyczne zapisywanie rysunku 
Możesz określić kiedy rysunek ma być automatycznie zapisywany. Pozwala to na zminimalizowanie ryzyka utraty danych. 
Jeżeli włączysz opcję automatycznego zapisu, twój rysunek będzie zapisywał się automatycznie w określonych odstępach czasu. Domyślnie system będzie zapisywał plik o nazwie nazwapliku.sv$, jako tymczasowy plik zapisu. Nazwa pliku zależy od nazwy bieżącego rysunku.  
        

3.3.3. Zapisywanie części rysunku 
Użyj polecenia BLOCK lub WBLOCK aby utworzyć nowy rysunek złożony z części istniejącego już rysunku. Możesz zaznaczyć elementy na rysunku lub zdefiniować blok na rysunku i zapisać jako nowy rysunek. Opis również może zostać jako nowy rysunek.         
3.3.4. Zapisywanie różnych typów rysunków 
Wybierz format pliku w oknie dialogowym zapisywania plików. Program GstarCAD pozwala na zapisanie pliku DWG we wszystkich dostępnych wersjach, w formacie wymiany DXF lub w formacie szablonu DWT. 
Aby zapisać rysunek i określić jego format, wybierz: 
Wersja ENG:  File > Save As Wersja PL: Plik > Zapisz jako 
Lub wprowadź polecenie SAVE AS w wierszu poleceń, lub użyj skrótu SHIFT + CTRL + S 
 
3.3.5. Korzystanie z kopii zapasowej 
Program GstarCAD tworzy plik kopii zapasowej o nazwie bieżącego rysunku oraz rozszerzeniu .bak zawierający poprzednią wersję bieżącego rysunku, gdy opcja automatycznego tworzenia kopii zapasowej jest włączona. 
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3.3.6. Zmniejszenie czasu wymaganego do zapisywania rysunku. 
W celu zmniejszenia czasu potrzebnego na zapis pliku możesz ustawić procentowe zapisywanie przyrostu pliku. Opcja ta znajduje się w zakładce Open and Save (wer. PL: Otwórz i zapisz) w oknie dialogowym opcji, możesz również zmienić wartość jej zmiennej systemowej za pomocą polecenia ISAVEPERCENT. 
Przyrostowe zapisywanie rysunku powoduje zapisywanie jedynie zmian wprowadzonych na rysunku. Plik rysunku będzie zawierał procentową ilość potencjalnie nieużywanej przestrzeni, gdy opcja jest w użyciu. Procentowy wzrost po każdym przyrostowym zapisie będzie następował aż do osiągnięcia maksymalnej wartości ustawionej przez użytkownika, po osiągnięciu tej wartości zostanie przeprowadzony pełny zapis pliku. 
3.4. Przywracanie rysunku 
3.4.1. Przywracanie pliku rysunku 
Możesz przywrócić część lub całość danych zapisanych w pliku kopii zapasowej lub użyć odpowiednich poleceń, aby poprawić błędy jeśli rysunek jest uszkodzony. Plik rysunku może ulec uszkodzeniu poprzez błąd dysku twardego, utraty zasilania czy przez błąd systemu. Zaleca się tworzenie kopii zapasowych ważnych plików. 
W zakładce Open and Save (wer. PL: Otwórz i zapisz) w oknie dialogowym opcji, możesz określić czy plik kopii zapasowej zostanie utworzony podczas dokonywania zapisu i automatycznie aktualizowany w określonym odstępie czasu. Gdy dokonasz zapisu pliku dodatkowo tworzony jest plik o tej samej nazwie i rozszerzeniu .bak. Jest on aktualizowane za każdym razem, gdy wykonasz polecenie SAVE lub SAVE AS.  
  
Możesz użyć polecenia RECOVER aby sprawdzić i dokonać próby otworzenia uszkodzonego pliku rysunku. Następnie wywołaj polecenie AUDIT, aby znaleźć i poprawić błędy. 
Aby otworzyć uszkodzony plik, wybierz: 
Wersja ENG:  File > Drawing Utillities > Recover Wersja PL: Plik > Narzędzia rysunkowe > Napraw 
Lub wpisz polecenie RECOVER w wierszu poleceń 

   -W oknie dialogowym wybierz typ pliku, jaki chcesz naprawić. -Wybierz folder zawierający żądany plik. -Wybierz uszkodzony plik i naciśnij przycisk Open (wer. PL: Otwórz) lub kliknij na niego dwukrotnie lewym przyciskiem myszy, aby go otworzyć. Aby sprawdzić błędy rysunku, wykonaj: 
Wersja ENG:  File > Drawing Utilities > Audit Wersja PL:  Plik > Narzędzia rysunkowe > Test 
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Lub wprowadź polecenie AUDIT w wierszu poleceń 

 
 1. Wykonaj polecenie AUDIT 2. Wprowadź Y (tak) lub N (nie), aby określić czy błędy mają być automatycznie wyszukiwane przez program GstarCAD, a następnie wciśnij klawisz Enter. 
 
 
3.4.2. Menadżer naprawy rysunku 
Jeżeli program GstarCAD zostanie zamknięty z powodu problemów sprzętowych, utraty zasilania lub problemów z systemem operacyjnym, jest zdolny do otworzenia ponownie pliku za pomocą kopii zapasowej. Przy ponownym uruchomieniu programu po nieprawidłowym zamknięciu zostanie wyświetlony menadżer naprawy rysunku, w którym znajdziesz wszystkie dostępne pliki kopii zapasowych utworzone automatycznie. Możesz otworzyć dowolny plik klikając na niego dwukrotnie lewym przyciskiem myszy. Jeżeli którykolwiek z plików jest uszkodzony, program podejmie próbę przywrócenia go przy użyciu kopii zapasowej. 
Jeżeli program zostanie niespodziewanie zamknięty, rysunek wymaga przywrócenia z następujących typów plików. 
-Pliki odzyskane po błędnym zamknięciu programu (DWG) -Tymczasowe pliki zapisu (sv$) -Pliki kopii zapasowej (BAK) -Pliki źródłowe rysunku (DWG)  
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3.5. Zarządzanie rysunkami 
Menadżer zestawu arkuszy programu GstarCAD pozwala na zarządzanie wszystkimi arkuszami projektu. Menadżer jest pomocny podczas prac projektowych pozwalając na tworzenie arkuszy, drukowanie oraz publikowanie. 
Zestaw arkuszy przedstawiony jest w postacie zestawów arkuszy z kliku plików rysunkowych, a każdy arkusz w zestawie reprezentuje Układ zawarty w pliku rysunkowym. Funkcjonalność zestawów arkuszy pozwala na łatwe importowanie Układów z rysunków. Dzięki temu masz możliwość otwierania rysunków z położenia głównego podczas edytowania ich przy użyciu tradycyjnych narzędzi.  
 
3.5.1. Kontrola ustawień arkuszy 
Wyświetl menu opcji aby utworzyć nowy zestaw arkuszy, otworzyć istniejący lub przełączać się pomiędzy otworzonymi zestawami arkuszy.                                         

Widok drzewka: Wyświetla zawartość listy 
arkuszy. 

Szczegóły i podgląd: Wyświetla opisowe 
informacje lub miniaturę bieżąco 
zaznaczonego elementu z drzewka. 
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W widoku drzewka możesz wykonać następujące czynności:  Kliknąć prawym przyciskiem myszy aby uzyskać dostęp do menu kontekstowego, zawierającego operacje powiązane z zaznaczonym elementem.    Kliknąć dwukrotnie lewym przyciskiem myszy na element. Jest to standardowy sposób otwierania rysunku z listy arkuszy. Możesz również kliknąć dwukrotnie na drzewko aby rozwinąć listę elementów.                    Kliknąć na jeden lub więcej elementów, aby je zaznaczyć w celu ich otworzenia, publikacji lub przeniesienia.                Przesunąć kursor na pojedynczy element, aby wyświetlić jego opis lub miniaturę.                Przeciągać elementy w obszarze drzewka, aby zmienić kolejność ich ułożenia. 
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3.5.2. Podstawowe informacje o menadżerze zestawu arkuszy 
W widoku wstążkowym. Wersja ENG: Zakładka View > Palettes > Sheet Set Manager Wersja PL: Zakładka Widok > Palety > Menadżer zestawów arkuszy 
Lub wprowadź polecenie SHEETSET w wierszu poleceń 
 
 
       Tworzenie zestawu arkuszy Gdy menadżer jest uruchomiony, kliknij na menu rozwijalne w górnej części okna i wybierz opcję New Sheet Set (wer. PL: Nowy zestaw arkuszy). 
 
Wyświetlone zostanie okno kreatora, pozwalające utworzyć nowy zestaw arkuszy w 4 krokach. 
Begin (wer. PL: Początek)  Krok pierwszy, zawiera dwie opcje tworzenia zestawu: An example sheet set (wer. PL: Przykładowy zestaw arkuszy) - pozwala na utworzenie zestawu arkuszy za pomocą dostępnych szablonów. Existing Drawings (wer. PL: Istniejące rysunki) - pozwala na użycie istniejących rysunków do utworzenia zestawu arkuszy. 
 Sheet Set Details (wer. PL: Szczegóły zestawu) Możesz wprowadzić tu podstawowe informacje dotyczące zestawu takie jak nazwa, opis czy położenie pliku.                      
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Choose Layouts (wer. PL: Wybierz Układy) Układy mogą zostać dodane do zestawu arkuszy poprzez pliki rysunkowe, które będą wymagane w zestawie. Po zaznaczeniu potrzebnych Układów w obszarze wybory, kliknij przycisk Next (wer. PL: Dalej) aby potwierdzić.        Confirm (wer. PL: Potwierdź) Ostatni krok, zawiera podsumowanie w postaci listy Układów, które zostały dodane do zestawu. Po kliknięciu przycisku Next (wer. PL: Dalej) nowy Układ zostanie dodany do zestawu arkuszy.       Importowanie Układów do menadżera zestawu arkuszy Aby dodać nowy arkusz z istniejącego Układu rysunku, kliknij prawym przyciskiem myszy na nazwę zestawu arkuszy i wybierz opcję Import Layouts Sheet (wer. PL: Importuj Układ jako arkusz). Zostanie wyświetlone nowe okno, pozwoli ono na wybranie pliku rysunku, z którego ma zostać zaimportowany Układ.         Wskazówka: Jeżeli w wyświetlonym oknie jeden z Układów jest odznaczona, oznacza to że jest już dodana do zestawu arkuszy lub Układ ten nie może zostać zaimportowany do zestawu.      Zarządzanie zestawem arkuszy 
Przesuwanie i usuwanie arkuszy z  zestawu Po dodaniu arkuszy do zestawu możesz zmieniać kolejność ich wyświetlania poprzez przeciąganie ich na liście. Aby usunąć arkusz z zestawu, kliknij na niego prawym przyciskiem myszy i z wyświetlonego menu kontekstowego wybierz opcję Remove Sheet (wer. PL: Usuń arkusz).       
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Zmiana nazwy oraz numeracji arkuszy 
Aby zmienić nazwę oraz numer arkusza lub podzestawu, kliknij prawym 
przyciskiem myszy na wybrany arkusz i wybierz opcję Rename & Renumber 
(wer. PL: Zmień nazwę i numeruj ponownie). 
 
W wyświetlonym oknie możesz wprowadzić numer arkusza, jego nazwę lub 
nazwę Układu. 
 
 
Dodawanie informacji o projekcie w zestawie arkuszy 
Aby dodać dodatkowe informacje do zestawu arkuszy takie jak nazwa projektu, numer i 
opis, kliknij prawym przyciskiem myszy na nazwę zestawu 
arkuszy i wybierz opcję Properties (wer. PL: Właściwości). 
W nowym oknie dialogowym możesz zaktualizować 
informacje dotyczące projektu. 
Wskazówka: Informacje o projekcie mogą zostać użyte w 
postaci obiektów, takich jak pola.   
       Tworzenie podzbioru arkuszy w menadżerze zestawu arkuszy Tworzenie podzbiorów jest dobrą metodą organizowania i wyszukiwania elementów w dużych zestawach arkuszy. Aby utworzyć podzbiór, kliknij prawym przyciskiem myszy na zestaw arkuszy i z menu kontekstowego wybierz opcję New Subset (wer. PL: Nowy Podzbiór).            W oknie dialogowym właściwości podzbioru większość właściwości jest podstawowych. Kliknij przycisk OK. Nowy podzbiór zostanie dodany do zestawu. Wskazówka: Aby przesunąć nowy podzbiór wystarczy przeciągnąć go w wybrane miejsce na liście elementów zestawu.       Publikowanie zestawów arkuszy Menadżer zestawu arkuszy umożliwia łatwe publikowanie całych zestawów lub wybranych arkuszy. Istnieją dwie metody wydruku: Przesłanie plików bezpośrednio do drukarki lub publikowanie za pomocą okna dialogowego.   
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Publikowanie i drukowanie na drukarce/do pliku Klikając prawym przyciskiem myszy na zestaw arkuszy, możesz wybrać z menu kontekstowego opcję Publish (wer. PL: Publikuj) a następnie Publish to Plotter (wer. PL: Publikuj do plotera).  
Metoda ta jest używana do drukowania i publikowania rysunków, gdy ustawienia strony są ustawione na Układ. Niestety podczas drukowania arkuszy za pomocą polecenia PLOT i zapisania ustawień Układu, Układ nie zostanie opublikowany poprawnie, Zestawy arkuszy mogą być również spakowane i udostępnione poprzez e-transmit. 
 
Możesz również użyć ustawień strony zapisanych w pliku rysunku, dla konkretnego arkusza lub całego zestawu. Aby wyświetlić okno dialogowe, kliknij prawym przyciskiem myszy na nazwę zestawu arkuszy i z menu kontekstowego wybierz opcję Publish (wer. PL: Publikuj). 
Okno dialogowe publikowania pozwala na wybranie sposobu publikacji dokumentu. Możesz wybrać publikowanie bezpośrednio do drukarki lub pliku DWF, DWFx czy PDF. Zaznaczając opcję Sheet Set Publish Options (wer. PL: Opcje publikowania zestawów arkuszy), pozwalasz na automatyczną zmianę informacji takich jak katalog zapisu oraz nazwy.        Wskazówka: Jedną z najważniejszych opcji i najczęściej modyfikowaną jest Typ. Plik wielu arkuszy zawiera pełen zestaw arkuszy w pojedynczym pliku a plik Pojedynczego arkusza zawiera tylko jeden arkusz na plik.   
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4. Kontrola ustawień widoku 
4.1. Przerysowywanie i odświeżanie rysunku 
Pod czas pracy nad rysunkiem, niektóre elementy mogą pozostać na rysunku po zakończeniu polecenia. Aby je usunąć skorzystaj z opcji odświeżania lub przerysowywania. 
Aby przerysować (odświeżyć) bieżące okno rysunku, wykonaj: Wersja ENG:  View > Redraw Wersja PL:  Widok > Przerysuj 
Lub wprowadź komendę REDRAW w wierszu poleceń 
Aby zregenerować bieżące okno, wykonaj: Wersja ENG:  View > Regen Wersja PL:   Widok > Regen 
Lub wprowadź komendę REGEN w wierszu poleceń 
 
                Informacje o elementach rysunku przechowywane są w bazie danych jako zmienne wartości, zapewniające wysoki poziom dokładności. Czasami rysunek musi zostać przeliczony ponownie, lub zregenerowany aby umożliwić bazie danych dostosowanie tych wartości do współrzędnych na rysunku. 

4.2. Widok lupy (Zoom) 
Aby powiększyć fragment rysunku wprowadź polecenie ZOOM w wierszu poleceń. Możesz zmienić stopień powiększenia w dowolnym momencie. Gdy narzędzia powiększania są aktywne, kursor spełnia rolę "szkła powiększającego". Zmniejsz stopień powiększenia aby oddalić rysunek lub zwiększ aby go powiększyć.  
 
 
 
Uwaga: Jeśli pracujesz na rzutni Układu i nie możesz wykonać przybliżenia, rzutnia może być zablokowana. Uniemożliwa to również na zmianę wyświetlanej w niej przestrzeni Model. Aby zmodyfikować widok wyświetlany w rzutni, należy ją uprzednio odblokować. 
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4.2.1. Metody przybliżania  
Istnieje klika metod zmiany zakresu widoku wyświetlanego na ekranie: 
-Utworzenie okna, określającego który fragment ma zostać powiększony. -Przybliżanie w czasie rzeczywistym, dostępne na pasku narzędziowym. -Skorzystaj z rolki myszy. 
 
4.2.2. Powiększanie zaznaczonego obszaru 
Możesz określić prostokątny obszar, który ma zostać powiększony. W tym celu określ przeciwległe wierzchołki prostokąta, w którym obraz ma zostać powiększony. 
Aby powiększyć wybrany obszar, wykonaj: Wersja ENG: View > Zoom > Window Wersja PL: Widok > Powiększ > Okno 
Lub wprowadź komendę ZOOM w wierszu poleceń. 
Następnie: -Określ pierwszy wierzchołek obszaru -Określ przeciwległy wierzchołek obszaru                   
 
4.2.3. Przybliżanie w czasie rzeczywistym 
Przybliżanie w czasie rzeczywistym pozwala na dynamiczną zmianę zakresu widoku poprzez przesuwanie myszą w górę i w dół. Klikając prawym przyciskiem myszy możesz wyświetlić menu kontekstowe zawierające dodatkowe opcje widoku. 
Aby przybliżyć widok w czasie rzeczywistym, wykonaj: Wersja ENG:  View > Zoom > Realtime Wersja PL: Widok > Powiększ > Szybki 
Lub wprowadź polecenie RTZOOM w wierszu poleceń 
Następnie: trzymając wciśnięty lewy przycisk myszy przesuń ją w górę aby powiększyć lub w dół aby pomniejszyć zakres wyświetlanego widoku.  
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4.2.4. Powrót do poprzedniego widoku rysunku 
Po zmianie zakresu wyświetlanego widoku istnieje możliwość powrotu do poprzedniego widoku. Aby wrócić do poprzedniego widoku, wykonaj: Wersja ENG: View > Zoom > Previous Wersja PL: Widok > Powiększ > Poprzedni. Program umożliwia cofnięcie się o maksymalnie 25 poprzednio wybranych zakresów  widoków. 
4.2.5. Powiększanie do określonej skali 
Możesz zwiększyć lub zmniejszyć powiększenie określając dokładną wartość skali, powiązanej z całkowitym rozmiarem rysunku lub związanej z bieżąco wyświetlanym oknem. Gdy zmienisz współczynnik przybliżenia, środek wyświetlanego fragmentu rysunku nadal pozostanie na środku ekranu. 
Aby powiększyć do określonej skali w bieżąco wyświetlanym oknie, wykonaj: Wersja ENG: View > Zoom > Scale Wersja PL: Widok > Powiększ > Skala 
Lub wprowadź komendę ZOOM w wierszu poleceń 
Następnie: -Wprowadź współczynnik przybliżenia -Zatwierdź klawiszem Enter                    
 
4.2.6. Wyświetlanie całego rysunku 
ZOOM Extents (wer. PL: Zakres) - opcja ta powoduje wyświetlenie wszystkich elementów na rysunku, w możliwie największym powiększeniu. Mogą być również wyświetlane obiekt na wyłączonych warstwach, ale nie zawartych na warstwach zamrożonych. 
ZOOM All (wer. PL: Wszystko) - opcja ta pozwala na wyświetlenie wszystkich obiektów w zakresie podanym przez użytkownika i zakresie rysunku. 
Użyj opcji "powiększ wszystko" aby wyświetlić cały rysunek, lub opcji "powiększ zakres" aby wyświetlić wszystkie elementy rysunku w jak największym powiększeniu. 
 



4. Kontrola ustawień widoku 
 

46  

 
4.3. Widok i opcja PAN 
Możesz przewinąć zakres widoku w dowolnym kierunku za pomocą polecenia PAN. Pozwala ona na przesunięcie widoku w kierunku poziomym, pionowym i po przekątnej. Zakres powiększenia oraz orientacja w przestrzeni nie ulega zmianie. Aby przesunąć widok skorzystaj z poniższych metod: 
-Do precyzyjnego określenia przesunięcia, wyznacz dwa punkty określające wielkość i kierunek przesunięcia. Pierwszy punkt jest jednocześnie początkowym punktem przesunięcia, drugi natomiast określa przemieszczenie względem punktu początkowego. -Aby przesunąć widok w czasie rzeczywistym, użyj opcji Pan realtime (wer. PL: Szybki PAN) z paska narzędziowego. -Wciśnij i przytrzymaj rolkę myszy, aby przesuwać obraz. 
Aby przesunąć widok w czasie rzeczywistym, wykonaj: Wersja ENG:  View > Pan > Realtime Wersja PL: Widok > Nowy fragment > Szybki 
Lub wykonaj komendę PAN w wierszu poleceń 
Następnie: -Przesuń kursor w wybranym kierunku aby przesunąć widok -Aby zakończyć polecenie naciśnij klawisz Enter, Esc lub wybierz Exit (wer. PL: Zakończ) z menu kontekstowego. 
Przesuwanie widoku używając rolki myszy: 
-Wciśnij i przytrzymaj rolkę myszy, a następnie przesuń kursor w wybranym kierunku. Za kontrole tej cechy odpowiada zmienna systemowa MBUTTONPAN.  
 
4.4. Wyświetlanie wielu widoków w obszarze Modelu 
Gdy rozpoczynasz nowy rysunek, wyświetlany jest  w pojedynczym oknie. Możesz wyświetlić go w drugim oknie lub zamienić jedno okno na kilka okien z różnymi widokami. Ponadto możesz otworzyć i wyświetlać wiele rysunków niezależnie. 
4.4.1. Ustawienia rzutni w obszarze Modelu 
Rzutnie utworzone w obszarze Modelu całkowicie wypełniają obszar i nie nakładają się na siebie. Gdy dokonasz zmiany w jednej z nich, pozostałe zostaną zaktualizowane automatycznie. Możesz wykonywać następujące operacje na rzutniach w obszarze Modelu: 
-Ustawić pocje SNAP, Siatka, LUW, PAN, Powiększenie i przywracać nazwane widoki. -Zapisać  orientację LUW indywidualnie dla każdej rzutni. -Gdy polecenie jest wykonywane, możesz rysować z jednej rzutni do drugiej. -Nazwać przygotowaną rzutnię, aby użyć jej ponownie później lub wstawić do zakładki Układu. -Podczas pracy w środowisku 3D, ustawić rzutnie pozwalające na wyświetlanie określonych widoków modeli 3D.     
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4.4.2. Praca z wieloma widokami jednego rysunku 
Program GstarCAD pozwala na otworzenie i pracę z wieloma widokami jednego rysunku, w tym samym czasie. Po podzieleniu pojedynczego okna widoku na kilka okien widoku, możesz sterować wyświetlanym obrazem każdego z okien osobno. Na przykład, powiększyć lub przesunąć fragment rysunku w jednym oknie widoku, bez zmian w pozostałych. Podczas rysowania w jednym oknie widoku, wszystkie zmiany natychmiast są widoczne w pozostałych. Oczywiście możesz przełączać się między oknami w dowolnym czasie. 
Aby utworzyć wiele widoków, wykonaj: Wersja ENG: View > Viewports Wersja PL:  Widok > Rzutnie 
Lub wykonaj komendę VPORTS w wierszu poleceń 
Następnie: -W menu rzutni wybierz ich liczbę: 1, 2, 3 lub 4. -Wprowadź opcję "h" jeśli chcesz ustawić orientację poziomą, lub "v" jeżeli chcesz ustawić orientację pionową. 
Aby połączyć dwie rzutnie, wykonaj: Wersja ENG: View > Viewports > Join Wersja PL: Widok > Rzutnie > Dołącz 
Lub wywołaj komendę VPORTS w wierszu poleceń 
Następnie: -Kliknij na okno widoku który chcesz zachować, aby je zaznaczyć. -Kliknij na okno widoku, które ma zostać połączone z poprzednio zaznaczonym. 
Aby przywrócić nazwaną konfigurację okna, wykonaj: -Wprowadź polecenie -VPORTS. -Następnie wprowadź RESTORE -Wprowadź nazwę widoku, który ma zostać przywrócony.                             
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4.4.3. Praca na wielu rysunkach 
Za pomocą wielo dokumentowego interfejsu, możesz otworzyć i pracować na wielu plikach rysunkowych jednocześnie. Możesz kopiować, wklejać lub wycinać zawartości jednego z rysunku do drugiego. Każdy z rysunków wyświetlany jest w niezależnym oknie rysunkowym. Dzięki temu możesz wyświetlać dwa lub więcej rysunków obok siebie, łatwo kopiować zawartość poszczególnych rysunków. Ponadto w menu Window (wer. PL: Okno) możesz wybrać jeden z kilku sposobów określenia jak rysunki mają być wyświetlane:     -Cascade  (wer. PL: Kaskadowo)  -Tile Horizontally  (wer. PL: Sąsiadujące poziomo)  -Tile Vertically  (wer. PL: Sąsiadujące pionowo)       

4.4.4. Menadżer widoku 
Za pomocą menadżera widoku możesz utworzyć, ustawić jako domyślny, zaktualizować warstwy, edytować granice lub usuwać nazwane widoki, i szybko przełączać się pomiędzy widokami. Jest również pomocny w uniknięciu wykonywania niepotrzebnych operacji dopasowywania widoków.     
4.5. Określanie widoku 3D 
Możesz ustawić widok 3D, który pozwoli na łatwiejsze sprawdzenie efektów pracy nad tworzonym modelem 3D. W tym celu określ nowy punkt obserwacji.  
4.5.1. Ustawienia kierunku widoku 
W trójwymiarowym rysunku możesz ustalić dokładny kierunek widoku. Kierunek widoku ustala pozycję, z której widoczny będzie rysunek. Gdy przeglądasz rysunek z położenia domyślnego, punkt obserwacji ma współrzędne (0, 0, 1), wyświetlany jest widok z góry. Możesz zmienić kierunek widoku, aby otrzymać obraz rysunku z innej perspektywy.     Aby ustawić nowy kierunek widoku, wykonaj: Wersja ENG:  View > 3D Views > Viewpoint Presets Wersja PL: Widok > Widoki 3D > Wstępnie ustawione punkty obserwacji 
Lub wprowadź komendę DDVPOINT w wierszu poleceń 
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Następnie: -Ustaw kąt obserwacji, bezwzględny dla GUW, i powiązany z LUW. Zatwierdź klikając przycisk OK. 
Aby wyświetlić widok z góry dla bieżącego rysunku, wybierz: Wersja ENG: View > 3D Views > Plan View Wersja PL: Widok > Widoki 3D > Plan 
Lub wykonaj komendę PLAN w wierszu poleceń 
Następnie: -Wybierz jedną z trzech opcji: Current UCS (wer. PL: Bieżący LUW), World UCS (wer. PL: Globalny LUW) lub Named UCS (wer. PL: Nazwany LUW).                                           
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4.5.2. Widok izometryczny 
Aby uzyskać realistyczny efekt możesz określić perspektywę widoku swojego modelu. Po prostu wybierz jeden z predefiniowanych widoków. Widoki te reprezentują powszechnie używane ustawienia, takie jak rzuty i rzuty izometryczne.             
4.5.3. Widok izometryczny w rysunku 2D 
Korzystając z izometrycznego skoku możesz narysować obiekt 2D, wyglądający  jak bryła 3D. 
Ustawiając izometryczny skok w oknie dialogowym ustawień rysunkowych możesz łatwo wyrównać obiekty wzdłuż jednego z trzech rzutów izometrycznych. 
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4.5.4. Ustawienia siatki i skoku 
Przez wyrównanie wzdłuż trzech podstawowych osi, rysunek izometryczny wygląda pozornie jak obraz 3D. Gdy kąt skoku ustawiony jest na 0, osie rzutu izometrycznego mają odpowiednio 30, 90 i 150 stopni. Możesz pracować na każdym z trzech podstawowych rzutów, z których każdy ogranicza para powiązanych osi. 
-Lewa. Lewy rzut izometryczny określony jest przez parę osi o 90 i 150 stopniach. Skok i uchwyty wyrównują do linii pod kątem 90 i 150 stopni. -Góra. Górny rzut izometryczny określony jest przez parę osi o 30 i 150 stopniach. Skok i uchwyty wyrównują do linii pod kątem 30 i 150 stopni. -Prawa. Prawy  rzut izometryczny określony jest przez parę osi o 90 i 30 stopniach. Skok i uchwyty wyrównują do linii pod kątem 90 i 30 stopni.                     Dodatkowo za pomocą polecenia ISOPLANE możesz przełączać rzuty izometryczne. Ponadto wciskając klawisz F5 lub używając skrótu CTRL+E możesz określić jeden z trzech rzutów izometrycznych, wynikających z działania trybu ORTO powodującego wyrównanie kursora do odpowiedniej osi izometrycznej. 
Na przykład, gdy tryb ORTO jest włączony, możesz wyrównać określone punkty wzdłuż płaszczyzny na której pracujesz. Dlatego, możesz rysować na górnym rzucie a następnie przełączyć się na rzut z lewej aby rysować z innej strony, a następnie przełączyć się na rzut z prawej aby zakończyć rysowanie. 
 
               



4. Kontrola ustawień widoku 

 

4.5.5. Dynamiczna zmiana widoku 3D 
Możesz dowolnie zmieniać wyświetlany aktywne możesz również przesuwać i przybliżać zakres widoku oraz kontynuować prace nad projektem. Program GstarCAD wspiera szereg opcji widoku orbitowego.                    
4.5.6. Ukrywanie linii lub cieniowania obiektów 3D
Ukrywanie linii w rysunkach 3D pozwala na wyłzlokalizowanych "z tyłu", lub wygenerowanie odpowiedniego ich cieniowania.celu sprawdzenia wyświetlanych powierzchni. Dzięki ukryciu linii z tła rysunek staje się bardziej czytelny. Nie można modyfikować ukrytych linii ani renderować widoku.                            
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żesz dowolnie zmieniać wyświetlany widok za pomocą myszy, korzystając z polecenia 3DORBIT. Gdy polecenie jest aktywne możesz również przesuwać i przybliżać zakres widoku oraz kontynuować prace nad projektem. Program GstarCAD wspiera szereg opcji widoku orbitowego. 

4.5.6. Ukrywanie linii lub cieniowania obiektów 3D 
Ukrywanie linii w rysunkach 3D pozwala na wyłączenie wyświetlania (częściowego lub całkowitego) elementów zlokalizowanych "z tyłu", lub wygenerowanie odpowiedniego ich cieniowania. Użyj polecenia HIDE aby usunąć ukryte linie w celu sprawdzenia wyświetlanych powierzchni. Dzięki ukryciu linii z tła rysunek staje się bardziej czytelny. Nie można modyfikować ukrytych linii ani renderować widoku. 

 

widok za pomocą myszy, korzystając z polecenia 3DORBIT. Gdy polecenie jest aktywne możesz również przesuwać i przybliżać zakres widoku oraz kontynuować prace nad projektem. Program GstarCAD 

ączenie wyświetlania (częściowego lub całkowitego) elementów Użyj polecenia HIDE aby usunąć ukryte linie w celu sprawdzenia wyświetlanych powierzchni. Dzięki ukryciu linii z tła rysunek staje się bardziej czytelny. Nie można 
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4.5.7. Dodawanie prostego cieniowania do obiektów 3D 
Mimo, że ukryte linie pomagają zwiększyć czytelność wyświetlanego projektu, dając bardziej realistyczny obraz modelu, możesz modyfikować zacieniowanie obiektów. Gdy zacieniowany obiekt zostaje zaznaczony szkielet i uchwyty pojawiają się w górnej części zacieniowania.                      

4.6. Renderowanie 
Rendering polega na wygenerowaniu obrazu 2D, bazującego na scenie 3D. Powoduje zacieniowanie geometrii sceny zgodnie z określonymi ustawieniami światła, rodzajem materiałów przypisanych do obiektów czy ustawień środowiska. Na podstawowym poziomie, możesz wykonać polecenie renderingu aby wyrenderować stworzony model bez określania materiałów, ustawień światła czy sceny.     

4.6.1. Renderowanie otoczenia 
Możesz również określić cechy otoczenia, takie jak warunki atmosferyczne czy obraz tła. Możesz rozszerzyć renderowany obraz dodając efekty, głębię, czy poprzez dodawanie obrazów z plików bitmapowych.          
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4.6.2. Światło 
Możesz dodać punkty światła, reflektory lub światło odległe, i ustawić położenie oraz właściwości fotometryczne każdego z nich. Punkt światła: Daje efekt promieniowania we wszystkich kierunkach, nie pozwala na nakierowanie padającego światła na konkretny obiekt. Reflektor: Pozwala na stworzenie światła kierunkowego, padającego na określone obiekty w scenie. Światło odległe: Symuluje efekt światła słonecznego, może być wykorzystane w celu pokazania w jaki sposób padają cienie poszczególnych obiektów na otoczenie. Lista światła: Wyświetla listę rodzajów oraz nazw efektów świetlnych, używanych w obszarze Modelu. Światła odległe nie pojawiają się w obszarze Modelu jako obiekty.  
 
4.6.3. Materiały 
Aby otrzymać bardziej realistyczny efekt, możesz określić materiały dla każdego ze stworzonych obiektów. W procesie renderowania rodzaj materiału dostarcza informacje w jaki sposób dany obiekt odbija lub przepuszcza światło. Dodatkowo rodzaj materiału może symulować odpowiednią teksturę, nierówności, odbicia czy załamania.        

 
5. Narzędzia precyzyjne i właściwości rysunków 
5.1. Ustawienia jednostek, kątów i skali 
Określ jednostki miary, z których chcesz korzystać na rysunku, oraz ich format. 
5.1.1. Ustawienia formatu jednostek 
Możesz wybrać jeden z formatów, w jakim będą wyświetlane jednostki: naukowy, dziesiętny, inżynierski, architektoniczny i zapis ułamkowy. Aby ustawić format architektoniczny dla jednostek calowych możesz oznaczyć jednostkę stopy poprzez symbol ('), na przykład 7,2'3. Nie ma konieczności określania cali znakiem ("). Możesz ustawić typ oraz dokładność jednostek za pomocą kreatora szybkich ustawień, zaawansowanego kreatora lub za pomocą okna dialogowego ustawień jednostek. Ustawienia jednostek wpływają na współrzędne, odsunięcie oraz odległości na rysunku, oraz sposób ich wyświetlania.   Aby wyświetlić okno dialogowe ustawień jednostek, wykonaj: Wersja ENG: Format > Units Wersja PL: Format > Jednostki 
Lub wprowadź komendę UNITS w wierszu poleceń 
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5.1.2. Ustawienia kątów 
Możesz określić położenia kąta 0, oraz kierunek dodatni dla miary kąta: zgodny lub przeciwny do ruchu wskazówek zegara. Ponadto możesz wybrać format wyświetlania miary kąta.  
 
-Określanie jednostek miary kąta i dokładności: Wybierz jedną z następujących jednostek: grad, radian, jednostka geodezyjna lub stponie, minuty, sekundy. 
-Określ początek miary kąta:  Wschód, zachód, północ, południe. Na przykład aby wprowadzić współrzędne w odniesieniu do bieżących współrzędnych dla właściwości linii o wartości 54 stop, długości 7 cali z orientacją 60 stopni na północ, 12 minut i 6 sekund na wschód, wprowadź @54’7”<n60d12’6”e. 
-Określ kierunek dodatni: Zgodny lub przeciwny do ruchu wskazówek zegara. Kąt 0 może zostać ustawiony w dowolnym miejscu. 
 
 
 
5.1.3. Ustawienia współczynnika skali 
Program pozwala na wykonywanie rysunku w pełnej skali, bez określania specjalnej skali w trakcie pracy. Wartość skali możesz dowolnie określić podczas wydruku. Wartość skali wpływa bezpośrednio na niektóre elementy drukowanego rysunku, takie jak tekst, strzałki czy typy linii. Na przykład, drukując tekst, należy określić jego wielkość w odniesieniu do skali w jakiej następnie będzie drukowany rysunek aby jego wielkość była poprawna. 
Po określeniu skali zakończonego rysunku, możesz obliczyć wskaźnik skali dla tego rysunku jako stosunek jednostki na rysunku do aktualnej jednostki skali reprezentowany przez obie jednostki na rysunku. 
Tabela obok, reprezentuje niektóre ze standardowych skal architektonicznych i inżynierskich i odpowiadające im wysokości tekstu wymagane do stworzenia tekstu o wysokości 1/8 cala na wydrukowanym rysunku. 
Możesz wykorzystać wymienione współczynniki skal do założenia wielkości rysunku, tak aby pasował do określonego formatu papieru, na którym będzie drukowany rysunek. Wielkość rysunku jest kontrolowana przez określone granice rysunku. Aby je dla określonego formatu papieru, należy pomnożyć wymiary papieru przez wskaźnik skali. 
  

Standard scale ratios and equivalent text heights 
Scale Scale factor Text height 
1/16" = 1'-0"  192 24" 
1/8" = 1'-0"  96 12" 
3/16" = 1'-0"  64 8" 
1/4" = 1'-0" 48 6" 
3/8" = 1'-0" 32 4" 
1/2" = 1'-0" 24 3" 
3/4" = 1'-0" 16 2" 
1" = 1'-0" 12 1.5" 
1 1/2" = 1'-0" 8 1" 
3" = 1'-0" 4 0.5" 
1" = 10' 120 15" 
1" = 20' 240 30" 
1" = 30' 360 45" 
1" = 40' 480 60" 
1" = 50' 600 75" 
1" = 60' 720 90" 
1" = 100' 1200 150" 
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5.2. Granice rysunku 
Możesz określić granice rysunku, które będą niewidoczne na rysunku. Granice rysunku stosowane są aby nie przekroczyć rozmiaru papieru na jakim później będzie drukowany rysunek w określonej skali. 
Na przykład, aby wydrukować rysunek w skali 1/8” = 1’-0” (o wskaźniku skali 96) na arkuszu papieru o wymiarach 36 x 24 cali, należy ustawić granice rysunku jako 3,264 jednostki szerokości i 2,112 jednostki wysokości, które pozwolą na dodanie marginesów w odległości 1 cal od krawędzi papieru. 
Aby określić granice rysunku, wykonaj:  Wersja ENG:  Format > Drawing limits Wersja PL: Format > Granice rysunku 
Lub wykonaj komendę LIMITS w wierszu poleceń 
Następnie: -Określ współrzędne x i y prawy górny i lewy dolny narożnik granicy rysunku. Możesz również określić granice rysunku poprzez zaznaczenie punktów na rysunku.  
 
 

5.3. Siatka i skok siatki 
Siatka w programie GstarCAD 2016 jest prostokątną płaszczyzną, złożoną z małych i głównych linii rozciągniętą na obszarze rysunku. Wyświetlana siatka i używanie skoku siatki poprawia wydajność odświeżania. Gdy skok jest włączony, kursor przylega i przeskakuje pomiędzy niewidzialnymi kratkami siatki. Ustawienia siatki i skoku są efektywnymi narzędziami, poprawiającymi dokładność pracy. Dodatkowo ruch kursora można ograniczyć do poruszania się wyłącznie po kierunkach prostopadłych lub automatycznie wyświetlać na ekranie przewodnik o określonym przyroście kąta biegunowego. 
 
 
5.3.1. Zmiana odstępu siatki i skoku 
Możesz określić odstępy siatki i skoku w zakładce Siatka i skok w oknie dialogowym ustawień rysunkowych.  Rozstaw siatki nie musi odpowiadać odstępom skoku. Szeroki rozstaw siatki może być używana jako odniesienie przy bliskim rozstawie siatki, co pomaga dokładniej określać punkty.        
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5.4. Używanie trybu skoku 
Tryb skok pozwala na szybkie wybranie szczególnych punktów geometrycznych narysowanych obiektów bez konieczności znania ich dokładnych współrzędnych. Możesz zaznaczyć punkt końcowy linii lub łuku, środek okręgu, punkt przecięcia dwóch dowolnych elementów lub jakikolwiek szczególny punkt figury geometrycznej. Tryb snap jest też pomocny w tworzeniu obiektów takich jak styczne czy prostopadłe do już istniejących elementów.  
 
 
 

5.4.1. Ustawienia lokalizacji 
Możesz ustawić opcje lokalizacji względem obiektu za pomocą następujących metod: -Wybierz Narzędzia > Ustawienia rysunkowe, w zakładce Lokalizacja zaznacz żądane opcje lokalizacji. -Na pasku narzędziowym lokalizacji, kliknij jedną z opcji. -Na pasku stanu, kliknij prawym przyciskiem myszy na przycisk trybu Skoku i z menu rozwijalnego wybierz Ustawienia. -Naciśnij i przytrzymaj klawisz SHIFT podczas klikania prawym przyciskiem myszy w dowolnym miejscu , w obrębie okna rysunku aby wyświetlić menu skrótów lokalizacji i wybrać żądaną opcję.  
 
Dodatkowo, możesz skorzystać z opcji Distance form Endpoint. Pozwala ona na skok o pewną odległość od każdego z punktów końcowych obietków, takich jak: linie, łuki, elipsy oraz inne wielonie. Dopóki kursor znajduje się nad punktem końcowym danego obiektu, dopóty wyświetlany jest zielony uchwyt wraz z informacją o dokładnej odległości.  
          Inną z przydatnych opcji jest Divide Segments. Dzięki niej obiekty, takie jak: linie, łuki, elipsy oraz inne wielonie mogą zostać podzielone na segmenty. Najpierw musisz wygenerować punkty podziału obiektów. Teraz, tak dlugo jak kursor będzie znajdował się nad obiektem, wyświetlane będą zielone uchwyty wraz z informacją o dokładnej odległości.            
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5.4.2. Narzędzia AutoSnap AutoSnap to narzędzie umożliwiające wizualną pomoc w lokalizacji, aby ułatwić użytkownikami lokalizowanie podstawowych punktów geometrycznych obiektów. Gdy opcja Skoku dowolnego obiektu jest włączony, program wyświetla znacznik i podpowiedź, gdy kursor znajduje się nad znacznikiem. AutoSnap włącza się automatycznie gdy Skok obiektu jest włączony. Domyślnie, znacznik AutoSnap, podpowiedzi i przyciąganie są włączone. Możesz zmienić ustawienia opcji AutoSnap w oknie dialogowym "Opcje". AutoSnap zawiera następujące narzędzia: 
-Marker (wer. PL: Znacznik). Uchwyty obiektu wyświetlane są gdy kursor jest w bliskiej odległości obiektu. Kształt znacznika zależy od rodzaju uchwytu. 
-Tooltip (wer. PL: Podpowiedzi). Wyświetla informacje, która część obiektu jest lokalizowana. 
-Magnet (wer. PL: Przyciąganie). Przyciąga i blokuje kursor na najbliższym wykrytym uchwycie. Efekt jest zbliżony do skoku siatki. 
-Aperture box (wer. PL: Celownik Auto Snap). otacza standardowy celownik kursora i określa przestrzeń, w której kursor automatycznie wykrywa uchwyty obiektów. Możesz włączyć, wyłączyć lub określić powierzchnię wyświetlanego obszaru celownika.  
5.5. Używanie śledzenia biegunowego i śledzenia uchwytów 
Automatyczne śledzenie zawiera śledzenie biegunowe oraz śledzenie uchwytów. Możesz je włączyć lub wyłączyć klikając na przyciski im odpowiadające zlokalizowane na pasku stanu. Gdy biegunowe śledzenie jest włączone, kursor porusza się wzdłuż określonego kąta. Gdy śledzenie uchwytów jest włączone, kursor porusza się wzdłuż ścieżki opartej na punkcie, w którym znajduje się uchwyt. 
 
5.5.1. Śledzenie biegunowe 
Gdy śledzenie biegunowe jest włączone, prowadnice wyświetlane są na ekranie automatycznie zgodnie z przyrostem kąt, jaki został określony. Na przykład, gdy narysowana zostanie linia z włączonym śledzenie biegunowym, którego wartość kąta ustawiona jest na 65 stopni, elastyczne linie zostaną wyświetlone z przyrostem 65 stopni. 
Aby umożliwić śledzenie biegunowe i określić przyrost kąta: 1. Wykonaj jedna z poniższych możliwości: -Wybierz Narzędzia > Ustawienia rysunkowe z menu głównego. -Na pasku narzędziowym Lokalizacja, kliknij przycisk ustawień lokalizacji. -Wprowadź DSETTINGS w wierszu poleceń i zatwierdź klawiszem Enter.  
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2. Przejdź do zakładki Śledzenie biegunowe. 3. Zaznacz pole wyboru opcji Śledzenie biegunowe. 4. Wykonaj jedną z poniższych czynności aby określić przyrost kąta biegunowego: -Zaznacz kąt z listy rozwijalnej Przyrost kąta. -Zaznacz pole wybory Dodatkowe kąty i kliknij New (wer. PL: Nowy), aby zdefiniować spersonalizowany przyrost kąta. 5. Kliknij OK. 
 
Uwaga: Aby szybko włączyć lub wyłączyć śledzenie biegunowe, naciśnij ikonę Śledzenie biegunowe na pasku stanu lub wciśnij klawisz F10. 
 
Aby rysować obiekty korzystając ze śledzenia biegunowego: -Włącz opcję Śledzenie biegunowe i wywołaj jedno z poleceń rysowania, takich jak ARC, CIRCLE lub LINE aby narysować łuk, okrąg lub linie. Możesz równie skorzystać ze śledzenia biegunowego przy stosowaniu poleceń edycyjnych, takich jak COPY i MOVE aby skopiować lub przesunąć element.  -Przesuwanie kursora określającego kolejne punkty elementu, powoduje wyświetlanie przerywanej linii pomocniczej, pojawiającej się przy określonych przez użytkownika kątach. Określone punkty, widoczne podczas wyświetlania linii potwierdzają kąt śledzenia biegunowego.  
 
 
 
5.5.2. Śledzenie uchwytów 
Śledzenie uchwytów może się odbywać po wyznaczonych ścieżkach, opartych na punktach uchwytow i wyświetlanych podpowiedziach dotyczących nowozdefiniowanych punktów. Po zdefiniowaniu nowego punktu, pozioma, pionowa i biegunowa ścieżka powiązana z punktem zostanie wyświetlona, gdy najedzie na nią kursor. Na przykład, określony punkt wzdłuż ścieżki bazujący na punkcie końcowym obiektu, punkcie środkowym lub punkcie przecięcia się obiektów. 
Możesz również użyć zmiennej systemowej TRACKPATH aby kontrolować wyświetlanie śledzenia biegunowego i śledzenia uchwytów po wyznaczonych ścieżkach.               
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5.6. Tryb ORTO 
Możesz ograniczyć ruch kursor do bieżących osi poziomej i pionowej, dzięki temu w łatwy sposób możesz rysować linie prostopadłe. Na przykład, gdy tryb ORTO jest aktywny, rysowanie linii jest ograniczone do rysowania pod kątem 0, 90, 180 lub 270 stopni. Podczas rysowania, elastyczna linia podąża wzdłuż osi poziomej lub pionowej, zależnie od tego która oś jest bardziej oddalona od kursora. Gdy włączysz opcję izometrycznego skoku i siatkę, ruch kursora zostanie ograniczony do ruchów prostopadłych w obrębie bieżącej izometrycznej płaszczyzny. 
Aby szybko włączyć rysowanie prostopadłe: - Naciśnij klawisz F8 lub ikonę trybu ORTO na pasku stanu.  
 
 
 
5.7. Stosowanie typów linii 
Typ linii to powtarzalny wzór kresek, punktów oraz pustej przestrzeni wyświetlane na linii lub krzywizny. Możesz przydzielić typy linii do danego obiektu lub przydzielić określony typ linii. Możesz również określić skalę, wczytać więcej typów linii z biblioteki zawartej w programie lub tworzyć własne typy linii. 
Domyślnie, każdy rysunek posiada przynajmniej trzy typy linii: ciągły, po warstwie, po bloku. Nie można zmienić nazwy ani usunąć tych typów. 
Uwaga: Nie należy mylić tych typów linii z liniami nanoszonymi przez niektóre drukarki. Wyglądają podobnie, lecz gdy zostaną użyte w tym samym czasie, skutek może być trudny do przewidzenia.  
 
5.7.1. Wczytywanie typów linii 
Program GstarCAD zawiera pliki definiujący typy linii o nazwach Gaca.lin oraz gcadiso.lin. Jeżeli zaznaczysz plik gcadiso.lin, możesz korzystać ze znormalizowanych szerokości linii podczas wydruku. Aby dowiedzieć się jakie typy linii są obecnie dostępne, możesz wyświetlić listę typów linii, wczytanych do rysunku lub przechowywanych w pliku o rozszerzeniu LIN. Obydwa pliki definiujące typy linii zawierają kilka złożonych typów linii.   
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5.7.2. Zmiana typu linii dla obiektu 
Możesz zmienić typ linii obiektu poprzez zmianę typu linii warstwy, na której znajduje się obiekt, przenosząc obiekt na inną warstwę lub określając typ linii bezpośrednio dla danego obiektu.  
 
 
 
5.7.3. Ustawienia bieżącego typu linii 
Domyślnie, wszystkie obiekty tworzone są przy użyciu bieżącego typu linii, którego nazwa wyświetlana jest na pasku narzędzi Właściwości. Aby zmodyfikować bieżący typ linii, wybierz typ linii z menu rozwijalnego Rodzaj linii, zlokalizowanego w oknie dialogowym menadżera typów linii. Jeżeli bieżący typ linii ustawiony jest jako po warstwie (BYLAYER), obiekty zostaną utworzone z wykorzystaniem typu linii określonego dla bieżącej warstwy. 
Jeżeli bieżący typ linii ustawiony jest jako po bloku (BYBLOCK), obiekty będą tworzone z wykorzystaniem linii ciągłej (CONTINOUS), dopóki są pogrupowane w bloki. Gdy wstawisz blok na warstwę, automatycznie przyjmie on bież bieżący typ linii. 
Określenie typu linii jako bieżący: Wybierz z listy rozwijalnej Rodzaj linii z paska narzędziowego Właściwości typ linii, ktory chcesz ustawić jako bieżący.  
5.7.4. Zarządzanie skalą typu linii 
Możesz określić globalną lub indywidualną skalę dla obiektów aby regulować wyświetlanie typów linii. Wskaźnik skali globalnej i Skala bieżącego obiektu są wyświetlane w menadżerze typów linii. Wartość wskaźnika globalnego skali jest przechowywana w zmiennej systemowej LTSCALE, która zmienia skalę typu linii dla wszystkich istniejących na rysunku obiektów. 
Skala bieżącego obiektu jest przechowywana w zmiennej systemowej CELTSCALE, która określa skalę typu linii dla nowych obiektów. Możesz wykorzystać zmienną systemową PSLTSCALE aby dopasować skalę typu linii na rożnych rzutniach. 
Uwaga: Ustawienie zbyt dużej lub zbyt małej skali może spowodować, że linie przerywane mogą wyglądać jak linie ciągłe, w zależności od skali ustawionej dla bieżącego widoku lub skali ustawionej dla wydruku. 
 Aby ustawić bieżącą skalę indywidualną typu linii, wykonaj: Wersja ENG: Format > Linetype Wersja PL:  Format  > Rodzaj linii  
Lub wykonaj komendę LINETYPE w wierszu poleceń 
Następnie: 
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-Kliknij przycisk Show details (wer. PL: Pokaż szczegóły). -W polu Bieżący rodzaj linii, wprowadź skalę typu linii, którą chcesz określić jako bieżącą. -Kliknij OK. 
Aby zmienić globalną skalę typu linii: -Wybierz : Wersja ENG: Format > Linetype Wersja PL: Format > Rodzaj linii - Kliknij przycisk Show details (wer. PL: Pokaż szczegóły). -W polu Global Scale Factor (wer. PL: Globalny wsp. skali) wprowadź wartość skali. -Kliknij OK. 
 
 
5.8. Praca na warstwach 
Warstwy spełniają funkcję transparentnych nakładek, stosowanych w czasie rysowania na desce kreślarskiej. Warstwy stosowane są do zarządzania rożnymi typami informacji związanych z wykonywanym rysunkiem. Każdy obiekt na rysunku zawarty jest na warstwie. Gdy rysujesz obiekt, zostaje on dodany na bieżącą warstwę. 
5.8.1. Tworzenie warstw 
Możesz stworzyć nieograniczoną liczbę warstw na każdym rysunku i wykorzystać je do uporządkowania informacji. Podczas tworzenia nowej warstwy, program automatycznie ustali kolor jej elementów na biały lub czarny (w zależności od ustawień programu) oraz ciągły typ linii. Domyślnie, nowa warstwa jest widoczna. Po pomyślnym utworzeniu nowej warstwy możesz dowolnie edytować jej właściwości takie jak między innymi: kolor, typ linii, widoczność. 
Aby utworzyć nową warstwę, wykonaj:  Wersja ENG: Format > Layer Wersja PL:  Format > Warstwa 
Lub wykonaj komendę LAYER w wierszu poleceń. 
Następnie:  -Kliknij przycisk New Layer ( wer. PL: Nowa warstwa). -Wprowadź nazwę dla nowej warstwy i kliknij przycisk OK.  
Aby zmienić nazwę warstwy w bieżącym rysunku, wykonaj: -Wybierz: Wersja ENG: Format > Layer Wersja PL: Format > Warstwa -W oknie dialogowym właściwości warstwy, kliknij nazwę warstwy, którą chcesz zmienić. -Wprowadź nową nazwę i zatwierdź przyciskiem OK. 

5.8.2. Ustawienia bieżącej warstwy 
Gdy zaczynasz rysować, obiekty są tworzone na bieżącej warstwie. Warstwa 0 jest ustawiona jako domyślna ale możesz też utworzyć nową warstwę i ustawić ją jako bieżącą. Każdy kolejny obiekt zostanie powiązany z bieżącą warstwę. 
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Aby ustawić warstwę jako bieżącą, wykonaj: Wersja ENG:  Format > Layer Wersja PL:  Format > Warstwa -W oknie dialogowym menadżera właściwości, wybierz warstwę i kliknij przycisk Set Current (wer. PL: Ustaw bieżącą). -Kliknij OK. 
 
5.8.3. Usuwanie warstw 
Możesz usunąć warstwy, których nie używasz w rysunku za pomocą polecenia PURGE lub usunięcie warstwy z listy w menadżerze warstw. 
 
5.8.4. Ustawienia widoczności warstwy 
Każda warstwa może być widoczna lub ukryta. Ukrycie warstwy powoduje ukrycie wszystkich obiektów z nią powiązanych na ekranie oraz przy wydruku. Aby rysunek stał się bardziej czytelny możesz ukryć warstwy, na których znajdują się nieistotne elementy i informacje. 
Aby włączyć lub wyłączyć warstwy, wykonaj:  Wersja ENG:  Format > Layer Wersja PL:  Format > Warstwa  
Wykonaj komendę LAYER w wierszu poleceń 
Następnie: -Kliknij na ikonę żarówki, w kolumnie On (wer. PL: Włącz), przy odpowiedniej warstwie. -Kliknij przycisk OK.  
 
 
 
5.8.5. Blokowanie warstw 
Blokowanie warstwy zapobiega przypadkowej modyfikacji zawartości warstwy. Gdy warstwa jest zablokowana (ale widoczna i niezamrożona), nie możesz edytować jej elementów. Jeżeli zablokujesz bieżącą warstwę nie tracisz możliwości dodawania nowych obiektów do niej. Możesz również zmienić typ linii i kolor związany z tą warstwą. Odblokowanie warstwy przywraca jej pełną edytowalność. 
Aby zamknąć lub otworzyć warstwy, wykonaj: Wersja ENG:  Format > Layer Wersja PL:  Format > Warstwa  
Wykonaj komendę LAYER w wierszu poleceń 
Następnie: -Kliknij na ikonę w kolumnie Lock (wer. PL: Zamknięcie), przypisaną do żądanej warstwy. -Kliknij OK.  
 
  



5. Narzędzia precyzyjne i właściwości rysunków 
 

64  

5.8.6. Kontrola wydruku warstwy 
Kontrola wydruku warstwy pozwala określić, które obiekty rysunku mają zostać wydrukowane. Dzięki temu możesz wyłączyć wydruk niepotrzebnych elementów, bez konieczności ich usuwania. Gdy wyłączysz drukowanie warstwy, jej elementy dalej pozostaną widoczne na ekranie ale nie zostaną wydrukowane. 
Aby włączyć lub wyłączyć drukowanie, wykonaj: Wersja ENG:  Format > Layer Wersja PL:  Format > Warstwa  
Wykonaj komendę LAYER w wierszu poleceń 
Następnie: -Kliknij ikonę w kolumnie Plot (wer. PL: Drukuj) przypisaną do żądanej warstwy. -Kliknij OK.  
 
5.8.7. Ustawienia stylu wydruku warstwy 
Jeżeli używasz nazwanej tabeli stylów wydruku, możesz określić styl drukowania dla każdej warstwy. Nazwana tabela stylów zawiera listę stylów wydruku, które możesz do kontroli nad wyglądem drukowanych elementów na poszczególnych warstwach, bez konieczności dokonywania zmian na rysunku. Jeżeli wykorzystujesz tabelę stylów, w których rodzaj linii powiązany jest z kolorem, nie możesz określić stylu warstwy na wydruku. Taki typ tabel stylów wydruku określa automatycznie wymagania wydruku, na podstawie kolorów przypisanych do warstw lub obiektów. 
Aby zmienić styl wydruku przypisany do jednej lub więcej warstw (tylko dla nazwanych tabel stylu wydruku, wykonaj): Wersja ENG:  Format > Layer Wersja PL:  Format > Warstwa  
Wykonaj komendę LAYER w wierszu poleceń 
Następnie: -Kliknij na nazwę stylu wydruku znajdującą się na liście, aby otworzyć okno dialogowe, w którym możesz określić żądany styl wydruku. -Kliknij OK. 
 
5.8.8. Zamrożone warstwy 
Możesz też zamrozić warstwy aby poprawić wydajność niektórych operacji, takich jak przybliżenie czy przesuwanie widoku lub tworzeniu ukrytych linii lub zacieniowanych obrazów. 
Aby zamrozić warstwy, wykonaj: Wersja ENG:  Format > Layer Wersja PL:  Format > Warstwa  
Wykonaj komendę LAYER w wierszu poleceń 
Następnie: -Kliknij ikonę w kolumnie Freeze (wer. PL: Zablokowania), przypisaną do żądanej warstwy. -Kliknij OK. 
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5.8.9. Ustawienia koloru warstwy 
Każda warstwa na rysunku posiada przypisany kolor. Program GstarCAD wykorzystuje kolor na warstwie (BYLAYER) jako domyślny dla obiektów utworzonych na tej warstwie. 
Aby zmienić kolor warstwy, wykonaj:  Wersja ENG:  Format > Layer Wersja PL:  Format > Warstwa  
Wykonaj komendę LAYER w wierszu poleceń 
Następnie: -Kliknij ikonę w kolumnie Color (wer. PL: Kolor), przypisaną do żądanej warstwy i skorzystaj z palety aby wybrać żądany kolor.  -Kliknij OK. 
 
5.8.10. Ustawienia typu linii na warstwie 
Każda warstwa wykorzystuje domyślny typ linii. Typ linii określa wygląd obiektów wyświetlanych jak i drukowanych. Polecane jest przypisanie typu linii zależnego od konkretnej warstwy (BYLAYER). 
Aby zmienić typ linii dla jednej lub więcej warstw, wykonaj: Wersja ENG:  Format > Layer Wersja PL:  Format > Warstwa  
Wykonaj komendę LAYER w wierszu poleceń 
Następnie: -Wybierz żądaną nazwę typu linii z listy znajdującej się w oknie dialogowym . -Kliknij OK. 
 
5.8.11. Ustawienia szerokości linii na warstwie 
Każda warstwa korzysta z domyślnej szerokości linii. Szerokość linii określa grubość kreski jaką rysowane są obiekty na ekranie oraz podczas drukowania. Domyślnie, wszystkie nowe warstwy mają linię o szerokości 25 milimetrów lub 0.1 cala. Jeżeli chcesz określić inną szerokość linii przypisaną do warstwy, możesz ją łatwo zmienić za pomocą menadżera właściwości warstwy. 
Aby zmienić szerokość linii dla jednej lub więcej warstw, wykonaj: Wersja ENG:  Format > Layer Wersja PL:  Format > Warstwa  
Wykonaj komendę LAYER w wierszu poleceń 
Następnie: -Wybierz żądaną szerokość linii z listy znajdującej się w oknie dialogowym.  -Kliknij OK. 
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5.8.12. Filtrowanie listy warstw 
Możesz użyć filtru warstwy aby ograniczyć liczbę wyświetlanych nazw warstw na liście menadżera właściwości warstwy. W filtrze warstw możesz użyć następujących właściwości: nazwy warstw, kolory, typy i szerokości linii oraz style wydruku. Możesz też szybko wyszukać żądaną warstwę wpisując jej nazwę, skutkuje to wyświetleniem wszystkich warstw zawierających w nazwie wpisaną frazę.  
Aby zastosować filtr warstw, wykonaj: Wersja ENG:  Format > Layer Wersja PL:  Format > Warstwa  
Wykonaj komendę LAYER w wierszu poleceń 
Następnie: -Kliknij ikonę New Property Filter (wer. PL: Nowe właściwości filtra). -W oknie dialogowym wprowadź żądane właściwości warstw. -Kliknij OK. 
 
 
 
5.9. Wyświetlanie szerokości linii 
Szerokości linii są wyświetlane w rożny sposób w przestrzeni papieru i w przestrzeni w modelu. Szerokości linii są przydatne do graficznej reprezentacji rożnych obiektów i informacji. 
5.9.1. Wyświetlanie szerokości linii w obszarze Modelu 
W przestrzeni modelu, szerokość linii o wartości 0 jest wyświetlana jako piksel. Inne wyświetlane linie mają szerokość proporcjonalną do ich wartości rzeczywistych. W przestrzeni modelu, szerokość linii nie zmienia się wraz ze zmianą współczynnika przybliżenia. Wartość szerokości linii jest reprezentowana przez kilka pikseli i zawsze jest wyświetlana przez taką samą ich liczbę. Kliknij na ikonę szerokości linii na pasku stanu aby włączyć lub wyłączyć wyświetlanie szerokości linii.                      
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5.9.2. Wyświetlanie szerokości linii w obszarze Układu 
W obszarze papieru (zakładka Układ) i podglądzie wydruku, szerokości linii są wyświetlane dokładnie tak jak będą wyglądały po wydruku. W raz ze zmianą współczynnika skali zmienia się również szerokość linii. Możesz kontrolować szerokość linii przy wydruku i skalowanie rysunku w oknie dialogowym  drukowania, zmieniając parametry w zakładce skali. W przestrzeni papieru, kliknij na ikonę szerokości linii na pasku stanu aby włączyć lub wyłączyć wyświetlanie szerokości linii. Zmiana ta nie ma wpływu na szerokość drukowanych linii.                     
 
 
 
5.10. Sprawdzanie pisowni 
Porogram GstarCAD 2016 pozwala na sprawdzanie pisowni tekstu wprowadzanego na rysunku za pomocą polecenie SPELL. Możesz również określić język słownika, którym tekst ma zostać sprawdzony.   
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6. Tworzenie obiektów 
Rysowanie obiektów odbywa się poprzez określanie punktów za pomocą myszy, innego urządzenia wskazującego lub przez wprowadzanie wartości współrzędnych w wierszu poleceń.  
6.1. Rysowanie obiektów liniowych 
6.1.1. Linia: Proces rysowania linii polega na określeniu punktu początkowego oraz punktu końcowego. Możesz narysować serię linii, ale każda linia pozostanie niezależnym obiektem linii.  Aby narysować linie, wykonaj:  Wersja ENG: Draw > Line Wersja PL: Rysuj > Linia  
Lub wykonaj komendę LINE w wierszu poleceń 
1. Wykonaj polecenie LINE 2.Określ punkt początkowy. 3. Określ punkt końcowy. 4. Zakończ wykonywanie polecenia wciskając klawisz Enter. 
Aby rozpocząć rysowanie nowej linii zaczynając od punktu końcowego poprzedniej linii, wywołaj polecenie rysowania linii ponownie i wciśnij klawisz Enter aby automatycznie określić punkt początkowy nowej linii w miejscu punktu końcowego poprzednio narysowanej. 
6.1.2. Multilinia Element ten składa się z kilku równoległych linii. 
Możesz określić pozycje elementów poprzez ustalenie przesunięcia od pierwotnego położenia każdego z elementów. Domyślnie, obiekty multiliniowe zawierają dwa elementy. Możesz utworzyć i zapisać nowy styl multilinii lub zmodyfikować już istniejący. 
Aby narysować multilinie, wykonaj: Wersja ENG: Draw > Multiline Wersja PL: Rysuj > Multilinia  
Lub wykonaj komendę MLINE w wierszu poleceń 
1. Wykonaj polecenie MLINE. 2. Określ punkt początkowy. 3. Określ punkt końcowy. 4. Naciśnij klawisz Enter aby zatwierdzić polecenie.               
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6.1.3. Półprosta Półprosta jest linią w przestrzeni trójwymiarowej, posiadająca punkt początkowy z punktem końcowym dążącym do nieskończoności. Ponieważ długość półprostych dąży do nieskończoności, nie można wliczać ich do zakresu rysunku. 
Aby narysować półprostą, wykonaj: Wersja ENG: Draw > Ray Wersja PL: Rysuj > Półprosta  
Lub wykonaj komendę RAY w wierszu poleceń 
1. Wykonaj polecenie RAY.  2. Określ punkt początkowy i kierunek. 3. Naciśnij klawisz Enter aby zakończyć wykonywanie plecenia. 
 
 

6.1.4. Linia konstrukcyjna Jest to linia, która przechodzi przez zadany punkt, zorientowana pod określonym kątem w przestrzeni trójwymiarowej, dążąca w nieskończoność w obydwu kierunkach. Możesz też rysować linie konstrukcyjną pod określonym kątem lub kątem powiązanym z istniejącym obiektem. 
Aby narysować linię konstrukcyjną, wykonaj: Wersja ENG: Draw > Construction line Wersja PL: Rysuj > Linia konstrukcyjna  
Lub wykonaj komendę XLINE w wierszu poleceń 
1. Wykonaj polecenie XLINE.  2. Określ punkt wzdłuż linii. 3. Określ kierunek. 4. Naciśnij klawisz Enter aby zakończyć polecenie. 
 
 
6.1.5. Polilinia Polilinia jest pojedynczym obiektem zawierającym połączoną sekwencję linii lub/i łukow. W czasie rysowania polilinii możesz przełączać się pomiędzy rożnymi opcjami. Po narysowaniu więcej niż jednego segmentu (linii lub łuku) możesz zamknąć, cofnąć zakończony krok lub zakończyć proces. 
Aby narysować  prostą polilinię, wykonaj: Wersja ENG: Draw > Polyline Wersja PL: Rysuj > Polilinia  
Lub wykonaj komendę PLINE w wierszu poleceń 
1. Wykonaj polecenie PLINE. 2. Określ punkt początkowy. 3. Określ punkt końcowy będący punktem początkowym następnego segmentu. 4. Naciśnij klawisz Enter aby zakończyć rysowanie lub wprowadź literę C aby zamknąć polilinię.  
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Aby narysować polilinię złożoną z linii i łuków, wykonaj: Wersja ENG: Draw > Polyline Wersja PL: Rysuj > Polilinia  
Lub wykonaj komendę PLINE w wierszu poleceń 
1. Wykonaj polecenie PLINE. 2. Określ punkt początkowy. 3. Określ punkt końcowy. 4. Kliknij prawym przyciskiem myszy I wybierz z menu rozwijalnego opcję Łuk. 5. Określ punkt końcowy łuku. 6. Zakończ polecenie wciskając klawisz Enter.  
Aby narysować zamkniętą polilinię, wykonaj: Wersja ENG: Draw > Polyline Wersja PL: Rysuj > Polilinia  
Lub wykonaj komendę PLINE w wierszu poleceń 
Możesz utworzyć zamkniętą polilinię tylko jeżeli nie mniej niż dwie linie lub łuki zostały narysowany. Zamknięta polilinia zostanie narysowana, gdy połączysz punkt początkowy polilinii z punktem końcowym ostatniego segmentu polininii.        Aby narysować szeroką polilinię, wykonaj: Wersja ENG: Draw > Polyline Wersja PL: Rysuj > Polilinia  
Lub wykonaj komendę PLINE w wierszu poleceń 
Możesz rysować polilinie o rożnej szerokość, używając opcji powiązanych z poleceniem PLINE. Szerokość linii może być dostosowana dla każdego kolejnego segmentu polilinii oddzielnie, co daje możliwość stworzenia efektu zwężającej się stopniowo linii.      Aby narysować obwiednię, wykonaj:  Wersja ENG: Draw > Boundary Wersja PL: Rysuj > Obwiednia  
Lub wykonaj komendę BOUNDARY w wierszu poleceń 
1. Wykonaj polecenie BOUNDARY. 2. Określ obiekty, wykonując jeden z następujących zestawów:  - Current viewport  (wer. PL: Bieżąca rzutnia). Definiuje obwiednię zawierającą wszystkie elementy danej rzutni. Jeżeli zostanie wybrana ta opcja, każdy zestaw obwiedni obecnie używany zostanie anulowany.  
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-Istniejący zbiór, Kliknij przycisk New (wer. PL: Nowy), aby przełączyć się do obszaru rysunku i zaznaczyć obiekty definiujące zbiór obwiedni. Naciśnij przycisk Enter aby wrócić do okna dialogowego. Pozycja Istniejący zbiór będzie widoczna tylko po uprzednim zaznaczeniu wybranych elementów.  3. Zaznacz pole wyboru opcji Wykrywanie wysp. 4. Kliknij na ikonę Wskaż punkty. 5. W obszarze rysunku, kliknij na przestrzeń ograniczoną obwodem zamkniętym, nie na samą polilinię. Możesz dodatkowo wybrać dodatkowe obwody klikając w ich wnętrze. 6. Aby zakończyć naciśnij klawisz Enter. 7. Kliknij przycisk OK w oknie dialogowym "Tworzenie obwiedni".               
6.1.6. Wieloboki Tworzenie wieloboków pozwala na łatwe narysowanie kwadratu, trójkąta równobocznego, ośmioboku i wielu innych. Wielokąty to zamknięte polilinie zawierające między 3 a 1,024 równej długości boków.  Aby narysować wielobok, wykonaj:  Wersja ENG: Draw > Polygon Wersja PL: Rysuj > Wielobok  
Lub wykonaj komendę POLYGON w wierszu poleceń 
1. Wykonaj polecenie POLYGON. 2.Wprowadź liczbę reprezentującą liczbę bokow wieloboku. 3. Określ środek wieloboku. 4. Określ wierzchołek wieloboku.    
6.1.7. Prostokąty Prostokąty są zamkniętymi poliliniami, złożonymi z czterech boków. Rysowanie prostokąta odbywa się przez określenie dwóch przeciwległych wierzchołków. Domyślnie, boki prostokątów są równoległe do bieżącej siatki, możesz jednak użyć opcji obracania aby zorientować prostokąt pod dowolnym kątem. 
Aby narysować prostokąt, wykonaj:  Wersja ENG: Draw > Rectangle Wersja PL: Rysuj > Prostokąt  
Lub wykonaj komendę RECTANG w wierszu poleceń 
1. Użyj jednej z poniższych metod: -Wybierz Rysuj > Prostokąt z menu głównego. -Kliknij ikonę prostokąta na pasku narzędziowym lub wprowadź polecenie RECTANG w wierszu poleceń i zatwierdź klawiszem Enter. 2. Określ jeden z wierzchołków prostokąta lub wybierz jedną z dostępnych opcji [Fazuj/Poziomo/Zaokrąglij/Grubość/Szerokość]. 3. Określ przeciwległy wierzchołek lub wybierz jedną z dostępnych opcji [Obszar/Wymiary/Obrót]. 
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6.1.8. Punkty Możesz narysować punkt w formacie pojedynczej kropki lub jednego z 19 możliwych do wyświetlenia stylów. 
Aby narysować punkt, wykonaj:  Wersja ENG: Draw > Point > Single Point Wersja PL: Rysuj > Punkt  > Jeden 
Lub wykonaj komendę POINT w wierszu poleceń 
1. Wykonaj polecenie POINT. 2.Określ położenie punktu. 
Aby narysować kilka punktów, wykonaj: Wersja ENG: Draw > Point > Multiple Point Wersja PL: Rysuj > Punkt > Wiele 
Określ położenie każdego punktu. 
Aby zmienić rozmiar i wygląd punktów, wykonaj: Wersja ENG: Format > Point Style Wersja PL: Format > Styl punktu 
Lub wykonaj komendę DDPTYPE w wierszu poleceń 
 1. Wykonaj polecenie DDPTYPE 2. Wybierz żądany styl. 3. Określ wielkość punktu lub wybierz jedną z opcji. 4. Kliknij przycisk OK. 
Gdy odświeżysz rysunek, wszystkie punkty zostaną zmienione, zgodnie z nowo ustawioną wielkością i wyglądem.     
6.1.9. Szkicowanie Szkic składa się z wielu prostych linii, utworzony z pojedynczych obiektów linii, bądź z polilinii. Przed rozpoczęciem tworzenia szkicu, należy ustawić długość lub przyrost każdego z segmentów. Im krótsza długość segmentu, tym większa dokładność szkicowania lecz znacznie większy rozmiar pliku. 
Aby rozpocząć szkicowanie, wykonaj: 1. Wprowadź polecenie SKETCH i zatwierdź klawiszem Enter. 2. Wprowadź wartość przyrostu nagrania, określający minimalną długość segmentu. 3. Aby rozpocząć szkicowanie kliknij lewym przyciskiem myszy w obszarze rysowania lub wprowadź opcję P (pióro) w wierszu poleceń. 4. Kliknij ponownie lub wprowadź opcję P (pióro) w wierszu poleceń aby zatrzymać szkicowanie. 5.Wprowadź opcję R (Zapisz) aby wczytać na rysunku stworzony szkic i te już narysowane. 6. Naciśnij klawisz Enter aby zakończyć wczytywanie szkiców. 
Aby wymazać naszkicowane linie, wykonaj: 1. Podczas gdy polecenie SKETCH jest aktywne, wprowadź opcję E (wymazanie) w wierszu poleceń. Jeżeli opcja pióra jest w użyciu zostanie wyłączona. 2.Przesuwaj kursor wstecz od punktu końcowego naszkicowanej linii do punktu, w którym wymazywanie ma zostać zakończone. 
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3. Aby zakończyć opcję wymazywania wprowadź ponownie opcję E w wierszu poleceń. Jeżeli chcesz zmienić bieżącą rzutnię podczas szkicowania upewnij się, że opcja pióra jest wyłączona oraz wszystkie szkice zostały wczytane na rysunek. 
 
6.2. Rysowanie krzywych 
6.2.1 Łuk Łuk jest fragmentem okręgu. Istnieje mnóstwo sposobów definiowania łuku. Domyślną metodą jest określenie trzech punktów. Używając tej metody rysowanie łuku rozpoczyna się w ustalonym przez użytkownika punkcie początkowym, następnie przechodzi przez kolejny zadany punkt i zostaje zakończony w punkcie końcowym wybranym przez użytkownika. Istnieją również inne metody rysowania luków: -3 punkty -Punkt początkowy, środkowy, końcowy. -Punkt początkowy, środkowy, kąt. -Punkt początkowy, środkowy, długość. -Punkt początkowy, końcowy, kąt.  -Punkt początkowy, końcowy, kierunek. -Punkt początkowy, końcowy, promień. -Punkt środkowy, początkowy, końcowy. -Punkt Środkowy, początkowy, kąt. -Punkt środkowy, początkowy, długość. -Kontynuuj. 
Aby narysować łuk określając 3 punkty, wykonaj:  1. Wybierz: -Wersja ENG: Draw > Arc > 3 Points -Wersja PL:  Rysuj > Łuk>3 punkty  2. Określ punkt początkowy oraz drugi punkt. 3. Określ punkt końcowy. 
6.2.2. Okrąg Domyślnie aby narysować okrąg należy określić jego środek i jego promień. Możesz też narysować okrąg korzystając z następujących metod: -Określ punkt środkowy, promień. -Określ punkt środkowy i średnicę. -Określ 2 punkty. -Określ 3 punkty. -Określ 2 styczne i promień. -Określ 3 styczne.  
 
 
Aby narysować okrąg określając jego środek i promień, wykonaj: Wersja ENG: Draw > Circle> Center, Radius Wersja PL: Rysuj > Okrąg > Środek, promień 
Lub wykonaj komendę CIRCLE w wierszu poleceń 
1. Wykonaj polecenie CIRCLE 2. Określ środek okręgu. 3. Określ promień okręgu. 
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  Aby narysować okrąg styczny do istniejących obiektów, wykonaj: 1. Wybierz: Wersja ENG: Draw > Circle> Tan, Tan, Radius Wersja PL: Rysuj > Okrąg > Styczna, styczna, promień 
1. Wybierz Rysuj > Okrąg > Styczna, styczna, promień, z menu głownego. 2. Zaznacz pierwszy punkt styczności okręgu z obiektem. 3.Zaznacz drugi punkt styczności okręgu z obiektem. 4. Określ promień okręgu. 
 
6.2.3. Elipsa Domyślną metodą rysowania elipsy jest określenie punktu końcowego jednej z jej osi i połowy długości drugiej osi. Punkt końcowy pierwszej osi ustala orientację elipsy. Możesz rysować elipsy określając punkt środkowy, osie, punkt końcowy, elipsę lub łuk. 
Aby narysować elipsę określając osie i punkt końcowy, wykonaj: Wersja ENG: Draw > Ellipse> Axis Wersja PL: Rysuj > Elipsa > Oś 
Lub wykonaj komendę ELLIPSE w wierszu poleceń 
1. Wybierz: Wersja ENG: Draw > Ellipse> Axis, End Wersja PL: Rysuj > Elipsa > Oś, koniec 
2. Określ oba punkty końcowe elipsy. 3. Określ połowę długości drugiej osi.  
Aby narysować eliptyczny łuk określając punkty końcowe osi, wybierz: Wersja ENG: Draw > Ellipse> Arc Wersja PL: Rysuj > Elipsa > Łuk 
Lub wykonaj komendę ELLIPSE w wierszu poleceń 
1. Wybierz: Wersja ENG: Draw > Ellipse> Arc Wersja PL: Rysuj > Elipsa > Łuk 
2. Określ pierwszy punkt końcowy. 3. Określ drugi punkt końcowy. 4. Określ połowę długości drugiej osi. 5. Określ kąt początkowy łuku. 6. Określ kąt końcowy łuku. 
 
 
6.2.4. Splajn Jest to krzywa złożona z serii zakrzywionych linii przechodzących przez zadane punkty. Określenie wielu punktów jest wymagane do narysowania nieregularnych linii, które mogą tworzyć również zamknięte kształty. Punkty początkowe i końcowe są zgodne i styczne. Dopasowanie pomiędzy wieloma punktami określa się za pomocą parametru tolerancji. Do tworzenie obiektów splajn stosuje się głownie dwa sposoby: -Konwersja polilinii za pomocą opcji SPLINE polecenia PEDIT. -Użycie polecenia SPLINE. 
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Aby narysować obiekt splajn, wykonaj: Wersja ENG: Draw > Spline Wersja PL: Rysuj > Splajn 
Lub wykonaj komendę SPLINE w wierszu poleceń
1. Wywołaj polecenie SPLINE. 2. Określ pierwszy punkt krzywej. 3. Określ drugi punkt. 4. Określ kolejne punkty, jeżeli tworzysz obiekt złożony z większej ilości segmentów.5. Aby zakończyć polecenie naciśnij klawisz Enter.
    Aby narysować zamknięty obiekt Splajn, wykonaj:1. Wywołaj polecenie SPLINE. 2. Określ pierwszy punkt obiektu splajn. 3. Określ drugi punkt. 4.Określ kolejne punkty, jeżeli rysujesz obiekt złożony z większej ilości 5. Po określeniu wszystkich punktówklawiszem Enter. 6. Aby zakończyć polecenie określ punkt styczności.
  
       

 
6.2.5. Spirala Program umożliwia stworzenie spirali dwu lub trójwymiarowej. Wstępnie domyślny promień spirali ma wartość 1. Podczas tworzenia nowego rysunku, domyślną wartością promienia spirali zawsze jest bazowy promień wprowadzony poprzednio dla wszystkich podstawowych nie może mieć wartości 0. 
Aby narysować spiralę, wykonaj:  Wersja ENG: Draw > Helix Wersja PL: Rysuj > Spirala 
Lub wykonaj komendę HELIX w wierszu poleceń
W wierszu poleceń zostaną wyświetlone (domyślna wartość). 1. Określ bazowy punkt środkowy: Określ środek podstawy.2. Określ promień lub średnicę podstawy: Określ promień podstawy, wprowadź D aby zdefiniować średnice lub wklawisz Enter aby określić domyślną wartość promienia.3. Określ górny promień lub średnicę: Określ aby określić domyślną wartość promienia.4. Określ wysokość spirali lub koniec osi (A), liczbę jedną z opcji. 
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Aby narysować obiekt splajn, wykonaj:  

Lub wykonaj komendę SPLINE w wierszu poleceń 

4. Określ kolejne punkty, jeżeli tworzysz obiekt złożony z większej ilości segmentów. 5. Aby zakończyć polecenie naciśnij klawisz Enter. 

Aby narysować zamknięty obiekt Splajn, wykonaj: 
 

4.Określ kolejne punkty, jeżeli rysujesz obiekt złożony z większej ilości segmentów. punktów, wprowadź opcję C w wierszu poleceń i zatwierdź 
eśl punkt styczności.  

Program umożliwia stworzenie spirali dwu lub trójwymiarowej. Wstępnie domyślny promień spirali ma wartość 1. Podczas tworzenia nowego rysunku, domyślną wartością promienia promień wprowadzony poprzednio dla wszystkich podstawowych 

Lub wykonaj komendę HELIX w wierszu poleceń 
W wierszu poleceń zostaną wyświetlone następujące podpowiedzi: Obroty = 3 (domyślna wartość), Skręcenia = CWW 
1. Określ bazowy punkt środkowy: Określ środek podstawy. 2. Określ promień lub średnicę podstawy: Określ promień podstawy, wprowadź D aby zdefiniować średnice lub wklawisz Enter aby określić domyślną wartość promienia. 3. Określ górny promień lub średnicę: Określ górny promień, wprowadź D aby zdefiniować średnicę lub wciśnij klawisz Enter aby określić domyślną wartość promienia. koniec osi (A), liczbę zwojów (T), skok (H), kierunek (W): określ wysokość spirali lub wybierz 

 

następujące podpowiedzi: Obroty = 3 (domyślna wartość), Skręcenia = CWW 

2. Określ promień lub średnicę podstawy: Określ promień podstawy, wprowadź D aby zdefiniować średnice lub wciśnij 
promień, wprowadź D aby zdefiniować średnicę lub wciśnij klawisz Enter 

(T), skok (H), kierunek (W): określ wysokość spirali lub wybierz 
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6.2.6. Pierścień Jest to zamknięty element ograniczony okręgiem. Zmienna systemowa FILLMODE kontroluje wypełnienie powierzchni wewnętrznej pierścienia (przy wartości 1 pierścień jest wypełniony). 
Aby utworzyć pierścień, określ wewnętrzną i zewnętrzną średnicę oraz ich wspólny środek. Możesz utworzyć wiele pierścieni o tych samych średnicach określając rożne punkty środkowe. Aby utworzyć koło, ustaw ten sam promień dla wewnętrznego i zewnętrznego okręgu. 
Aby narysować pierścień, wykonaj: Wersja ENG: Draw > Donut Wersja PL: Rysuj > Pierścień 
Lub wykonaj komendę DONUT w wierszu poleceń  
1. Wykonaj polecenie DONUT. 2. Określ wewnętrzną średnicę pierścienia. 3. Określ zewnętrzną średnicę pierścienia. 4. Określ środek pierścienia. 5. Określ środek kolejnego pierścienia o tych samych wymiarach lub naciśnij klawisz Enter aby zakończyć rysowanie. 
6.3. Tworzenie obiektów 3D 
Pracując w środowisku 3D możesz: zobaczyć zawartość rysunku w trzech wymiarach, tworzyć i edytować elementy w przestrzeni trójwymiarowej, wyświetlać ukryte linie i zacieniowanie trójwymiarowych elementów. 
6.3.1. Grubość i wysokość obiektów 3D Domyślnie program tworzy nowe dwuwymiarowe obiekty określając wartość ich grubości lub wysokość jako 0. Aby w łatwy sposób utworzyć obiekt trójwymiarowy wystarczy zmienić wartość grubości w menu właściwości istniejącego już dwuwymiarowego obiektu. W ten sposób można przenieść dowolny obiekt 2D do trójwymiarowej przestrzeni. Na przykład można wykorzystać okrąg do utworzenia cylindra, linii do utworzenia płaszczyzny czy prostokąta do stworzenia prostopadłościanu. 
 
Aby ustawić bieżącą wysokość, wykonaj:  
1. Wprowadź polecenie CHANGE w wierszu poleceń, zaznacz żądane obiekty dwuwymiarowe w obszarze rysunku i zatwierdź wybór klawiszem Enter. 2.Wprowadź w wierszu poleceń P aby zobaczyć opcje właściwości i zatwierdź klawiszem Enter. 



6. Tworzenie obiektów 
 

77  

3. Wprowadź E w wierszu poleceń aby moc określić wysokość obiektu i zatwierdź klawiszem Enter. 4. Określ nową wysokość obiektu i zatwierdź klawiszem Enter.  
 
 
Aby określić bieżącą grubość, wykonaj:  
1. Wprowadź polecenie CHANGE w wierszu poleceń, zaznacz żądane obiekty dwuwymiarowe w obszarze rysunku i zatwierdź wybór klawiszem Enter. 2.Wprowadź w wierszu poleceń P aby zobaczyć opcje właściwości i zatwierdź klawiszem Enter. 3. Wprowadź w wierszu poleceń T aby moc określić grubość obiektu i zatwierdź klawiszem Enter. 4. Określ nową grubość obiektu i zatwierdź klawiszem Enter. 
 
6.3.2. Powierzchnia 3D Możesz utworzyć trójwymiarową powierzchnię, która składa się z części płaszczyzny w trójwymiarowej przestrzeni. Po określeniu czwartego punktu, program umożliwia dodanie kolejnej płaszczyzny określając jej trzeci i czwarty punkt co pozwala na utworzenie w pełni trójwymiarowego obiektu.     Aby utworzyć powierzchnię 3D, wykonaj: Wersja ENG: Draw > Modeling > Meshes > 3D Face Wersja PL:  Rysuj > Modelowanie > Siatki > Powierzchnia 3D Wiersz poleceń>3DFACE 
Lub wprowadź komendę 3DFACE w wierszu poleceń 
1. Wykonaj polecenie 3DFACE.  2. Określ pierwszy punkt trójwymiarowej płaszczyzny. 3. Określ pozostałe trzy punkty płaszczyzny. 4. Określ trzeci i czwarty punkt dodatkowej płaszczyzny 5. Aby zakończyć polecenie naciśnij klawisz Enter. 
6.3.3. Siatka prostokreślna Możesz określić siatkę prostokreślną, która jest trójwymiarowym korpusem zbliżonym do powierzchni pomiędzy dwoma istniejącymi elementami. Zaznacz dwa elementy, które mają zdefiniować siatkę prostokątną. Elementy te mogą być łukami, okręgami, liniami, punktami lub poliliniami. 
Aby utworzyć siatka prostokreślną, wykonaj: Wersja ENG:  Draw > Modeling>Meshes>Ruled Mesh    Wersja PL:  Rysuj > Modelowanie > Siatki > Siatka prostokreślna 
Lub wykonaj komendę RULESURF w wierszu poleceń 
1. Wykonaj polecenie RULESURF. 2. Zaznacz pierwszy obiekt. 3. Określ drugi obiekt. 
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6.3.4. Siatka walcowa Jest stosowana jako seria równoległych wielokątów na określonej ścieżce, należy narysować wektor kierunku i obiekt bazowy przed utworzeniem siatki walcowej. Obiekty takie jak linia, łuk, okrąg, elipsa, polilinie 2D lub 3d mogą być stosowane jako zarys krzywizny dla definiowanych wielokątów. 
Aby utworzyć wytyczaną powierzchnię siatki, wykonaj: Wersja ENG: Draw > Modeling > Meshes > Tabulated Mesh Wersja PL: Rysuj > Modelowanie > Siatki > Siatka walcowa  
Lub wykonaj komendę TABSURF w wierszu poleceń 
1. Wykonaj polecenie TABSURF.  2. Zaznacz obiekt do wytyczenia ścieżki. 3. Zaznacz ścieżkę. 
6.3.5. Siatka przekręcona Siatka utworzona przez obrót profilu obiektu wokół osi. Obiektem obróconym może być linia, łuk, okrąg, elipsa, łuk eliptyczny, zamknięta polilinia, zamknięty obiekt splajn lub torus. Ten typ siatki jest przy tworzeniu powierzchni z obiektów o symetrycznej osi obrotu. 
Aby utworzyć siatkę przekręconą, wykonaj:  Wersja ENG: Draw > Modeling>Meshes>Revolved Mesh     Wersja PL:  Rysuj > Modelowanie > Siatki > Siatka przekręcona  
Lub wykonaj komendę REVSURF w wierszu poleceń 
1. Wprowadź polecenie REVSURF w wierszu poleceń. 2. Zaznacz obiekt do obrotu. 3.Zaznacz obiekt, który będzie osią obrotu. 4. Określ kąt początkowy. 5. Określ liczbę stopni obrotu obiektu.            
6.3.6. Kostka Składa się z sześciu prostokątnych ścian. Podstawa kostki jest zawsze równoległa do płaszczyzny XY bieżącego LUW. Długość kostki jest przypisana do osi X bieżącego LUW, szerokość do osi Y a wysokość do osi Z. Za pomocą polecenia RECTANG lub PLINE możesz utworzyć prostokąt lub zamkniętą polilinię, która może zostać użyta jako podstawa tworzonej kostki za pomocą polecenia EXTRUDE. 
Aby utworzyć kostkę, wykonaj: Wersja ENG:  Draw > Modeling>Box   Wersja PL: Rysuj > Modelowanie > Kostka  
Lub wykonaj komendę BOX w wierszu poleceń 
1. Wykonaj polecenie BOX.  2. Określ pierwszy wierzchołek podstawy. 3. Określ przeciwległy wierzchołek podstawy. 4. Określ wysokość. 
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6.3.7. Stożek Domyślnie, podstawa stożka leży na płaszczyźnie XY bieżącego LUW. Jego wysokość jest równoległa do osi Z. Wierzchołek określa wysokość i orientację stożka. Możesz narysować dwuwymiarowy okrąg i używając polecenia EXTRUDE poprowadzić wysokość stożka pod kątem wzdłuż osi Z. Aby zakończyć obcinanie, możesz odjąć pole od wierzchołka stożka korzystając z polecenia SUBTRACT. 
Aby utworzyć stożek, wykonaj: Wersja ENG: Draw > Modeling>Cone    Wersja PL:  Rysuj > Modelowanie > Stożek  
Lub wykonaj komendę CONE w wierszu poleceń 
1. Wykonaj polecenie CONE.  2. Określ środek podstawy stożka. 3. Określ promień lub średnicę. 4.Określ wysokość. 
 
 
6.3.8. Walec Możesz stworzyć walca określając okrągłą podstawę. Podstawa walca jest zawsze równoległa do płaszczyzny XY bieżącego LUW. Wysokość walca jest zawsze równoległa do osi Z. Możesz narysować okrąg i utworzyć walec za pomocą polecenie EXTRUDE. 
Aby utworzyć walec, wykonaj: Wersja ENG: Draw > Modeling>Cylinder    Wersja PL:  Rysuj > Modelowanie > Walec  
Lub wykonaj komendę CYLINDER 
1. Wykonaj polecenie CYLINDER. 2. Określ środek podstawy. 3. Określ promień lub średnicę. 4. Określ wysokość.  
 
6.3.9. Sfera Linie szerokości geograficznej siatki sfery są zawsze równoległe do płaszczyzny XY bieżącego LUW. Oś centralna jest zawsze równoległa do osi Z. Możesz ustalić rozmiar sfery określając jej promień lub średnicę. 
Aby narysować sferę, wykonaj:  Wersja ENG: Draw > Modeling>Sphere   Wersja PL: Rysuj > Modelowanie > Sfera 
 Lub wykonaj komendę SPHERE w wierszu poleceń 
1. Wykonaj polecenie SPHERE.  2. Określ punkt centralny sfery. 3. Określ promień lub średnicę. 
6.3.10. Torus Jest skonstruowany przez obrót okręgu względem linii rysowania na płaszczyźnie okręgu i równoległy z osią Z bieżącego LUW. Możesz ustalić rozmiar torusa określając całkowitą średnicę lub promień okręgu, który jest obracany. 
Aby utworzyć torus, wykonaj:  Wersja ENG: Draw > Modeling>Torus   Wersja PL: Rysuj > Modelowanie > Torus  
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Lub wykonaj komendę TORUS w wierszu poleceń 
1. Wykonaj polecenie TORUS. 2. Określ środek torusa. 3. Określ kąt lub średnicę. 4. Określ promień lub średnicę korpusu torusa. 
6.3.11. Ostrosłup Możesz utworzyć ostrosłup o rożnej podstawie. Podstawa jest zawsze równoległa do płaszczyzny XY bieżącego LUW. Możesz określić rozmiar ostrosłupa określając punkty podstawy i wierzchołek, wierzchołki górnej powierzchni lub punkt końcowy kalenicy. 
Aby utworzyć ostrosłup, wykonaj:  Wersja ENG: Draw > Modeling>Pyramid   Wersja PL: Rysuj> Modelowanie > Ostrosłup  
Lub wykonaj komendę PYRAMID 
1. Wykonaj polecenie PYRAMID.  2. Określ pierwszy punkt podstawy ostrosłupa. 3. Określ drugi i trzeci punkt. 4. Określ położenie wierzchołka.  
6.3.12. Klin Możesz utworzyć trójwymiarowy klin, złożony z pięciu powierzchni. Możesz określić jego rozmiar określając jego drugi wierzchołek i wysokość. Definiowanie rozmiaru klina opiera się na sześcianie o zadanej długość lub określeniu długości, szerokości i wysokości. 
Aby utworzyć klin, wykonaj:  Wersja ENG: Draw > Modeling>Wedge   Wersja PL:  Rysuj > Modelowanie > Klin  
Lub wykonaj komendę WEDGE w wierszu poleceń 
1. Wykonaj polecenie WEDGE.  2. Określ pierwszy wierzchołek podstawy. 3. Określ przeciwległy wierzchołek. 4. Określ wysokość. 
6.3.13. Wyciągnięcie bryły Polecenie EXTRUDE wyciąga po wybranym profilu zaznaczony obiekt w celu utworzenia bryły. Nie można wyciągnąć obiektów złożonych z bloków lub polilinii przecinających się ze sobą lub z innymi elementami. 
Aby wyciągnąć obiekt po profilu, wykonaj: Wersja ENG: Draw > Modeling>Extrude    Wersja PL: Rysuj > Modelowanie > Wyciągnięcie  
Lub wykonaj komendę EXTRUDE w wierszu poleceń 
1. Wykonaj polecenie EXTRUDE.  2. Zaznacz obiekt do wyciągnięcia. 3. Zaznacz ścieżkę do wyciągnięcia obiektu. 
 
6.3.14. Obrót bryły Polecenie REVOLVE obraca obiekt 2D pod określonym kątem tworząc bryłę. Osią obrotu może być oś X lub Y bieżącego LUW jak również linia bądź pililinia. 
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Aby utworzyć bryłę poprzez obrót, wykonaj:  Wersja ENG: Draw > Modeling>Revolve    Wersja PL: Rysuj > Modelowanie > Obrót  
Lub wykonaj komendę REVOLVE w wierszu poleceń 
1. Wykonaj polecenie REVOLVE. 2. Zaznacz obiekt do obrotu. 3. Wybierz jedną z następujących możliwości zdefiniowania osi obrotu: -Określ punkt początkowy i końcowy. -Wprowadź O w wierszu poleceń i zatwierdź klawiszem enter aby zaznaczyć obiekt. -Wprowadź X w wierszu poleceń i zatwierdź klawiszem Enter aby zaznaczy oś X. -Wprowadź Y w wierszu poleceń i zatwierdź klawiszem Enter aby zaznaczyć oś Y. 4. Określ kąt obrotu.  
6.3.15. Bryły złożone Możesz utworzyć bryłę złożoną łącząc ze sobą dwie lub więcej brył. Za pomocą polecenia UNION, możesz połączyć ze sobą osobne bryły w jeden obiekt złożony. 
 Aby połączyć bryły, wykonaj: Wersja ENG: Modify> Solid Editing>Union    Wersja PL: Modyfikuj> Edycja brył > Suma  
Lub wykonaj komendę UNION w wierszu poleceń 
1. Wykonaj polecenie UNION. 2. Zaznacz obiekty, które chcesz połączyć. 
Aby odjąć bryły, wykonaj: Wersja ENG: Modify>Solid Editing>Subtract    Wersja PL: Modyfikuj > Edycja brył > Różnica  
Lub wykonaj komendę SUBTRACT w wierszu poleceń 
1. Wykonaj polecenie SUBSTRACT. 2. Zaznacz obiekty, które chcesz od siebie odjąć. 
Aby skrzyżować bryły, wykonaj:  Wersja ENG: Modify> Solid Editing>Intersect    Wersja PL: Modyfikuj> Edycja brył > Iloczyn 
 Lub wykonaj komendę INTERSECT w wierszu poleceń 
1. Wykonaj polecenie INTERSECT.  2. Zaznacz obiekty, które chcesz skrzyżować. 
 
6.4. Tworzenie regionów 
Możesz przekształcić zamknięte obiekty w dwuwymiarowe regiony. Po utworzeniu regionu, możesz zmodyfikować go używając rożnych trójwymiarowych narzędzi. 
Aby utworzyć region, wykonaj:  Wersja ENG: Draw> Region   Wersja PL: Rysuj> Region  
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Lub wprowadź komendę REGION w wierszu poleceń 
1. Wykonaj polecenie REGION 2. Zaznacz obiekty do utworzenia regionu i zatwierdź klawiszem Enter.  
 
6.5. Tworzenie wzoru chmury 
Polecenie REVCLOUD umożliwia stworzenie popilnii złożonej z sekwencji luków dających obiekt o kształcie chmury. Możesz w ten sposób przekształcić zarysy okręgów , elips, polilinii czy obiektów splajn.. Możesz ustawić minimalną i maksymalną wartość długości łuku tworzącego wzór chmury. 
Abu utworzyć wzór chmury, wykonaj:  Wykonaj komendę REVCLOUD w wierszu poleceń. 
1. Po wprowadzeniu polecenia REVCLOUD określ pierwszy punkt. 2. Poprowadź wzor wzdłuż ścieżki. 3. Zweryfikuj wykończenie kształtu (klikając jak najbliżej punktu początkowego).    
6.6. Tworzenie linii przerwania 
Tworzy polilinie i wstawia symbole przerwania. Aby użyć własnego bloku jako symbolu przerwania, upewnij się, że ten blok zawiera dwa punkty na warstwie Defpoints. 
Aby utworzyć chmurkę wersji, wykonaj:  Wykonaj komendę BREAKLINE w wierszu poleceń.  1. Wprowadź BREAKLINE w wierszu poleceń. 2. Określ pierwszy i drugi punkt dla linii przerywania. 3. Określ położenie symbolu przerywania. 
 
6.7. Funkcja przykryj 
Używa istniejących wielokątów, łamanych zamkniętych lub nowych polilinii, które są rysowane podczas korzystania z polecenia WIPEOUT. 
Aby użyć funkcji przykryj, wykonaj:  Wersja ENG: Draw > Wipeout   Wersja PL: Rysu j> Przykryj 
Lub wykonaj komendę WIPEOUT w wierszu poleceń 
1. Wykonaj polecenie WIPEOUT 2.Określ punkt początkowy i końcowy każdego odcinka. 3. Po określeniu ostatniego punktu końcowego naciśnij klawisz Enter.   
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7. Edycja obiektów 
Program GstarCAD 2016 pozwala na modyfikację wielkości, kształtu i położenia obiektów. Możesz wprowadzić polecenie a następnie zaznaczyć obiekty do zmodyfikowania lub najpierw zaznaczyć obiekty a następnie wykonać polecenie modyfikacji. 
7.1. Usuwanie 
Możesz usuwać obiekty korzystając z polecenia ERASE. Aby przywrócić usunięty obiekt wykonaj polecenie UNDO aby cofnąć. Istnieje kilka sposobów usuwania elementów z rysunku: usunięcie za pomocą polecenia ERASE, wycięcie zaznaczonego elementu lub usunięcie zaznaczonego elementu klawiszem Delete. 
7.2. Kopiowanie 
Masz możliwość wykonywania kopii elementów z bieżącego rysunku. Domyślną metodą jest stworzenie wybranego punktu bazowego i punktu wstawienia dla kopiowanego obiektu. Aby skopiować obiekty w odpowiedniej odległości od oryginału, określ bezpośrednio dystans gdy tryb Orto lub śledzenie biegunowe jest włączone. 
Tworzenie pojedynczej kopii obiektu: 
1. Wybierz:  Wersja ENG: Modify > Copy Wersja PL: Modyfikuj > Kopiuj 2. Zaznacz obiekt i potwierdź klawiszem Enter. 3. W wierszu poleceń wprowadź O (mOde). 4. W wierszu poleceń wprowadź S (pojedynczy). 5. Określ punkt bazowy i punkt wstawienia. 
Tworzenie wielu kopii obiektu:  
1. Wybierz:  Wersja ENG: Modify > Copy Wersja PL: Modyfikuj > Kopiuj 2. Zaznacz obiekt i potwierdź klawiszem Enter. 3. W wierszu poleceń wprowadź O (mOde). 4. W wierszu poleceń wprowadź M (wiele). 5. Określ punkt bazowy i punkt wstawienia pierwszej kopii. 6. Określ punkt końcowy następnej kopii. 7. Aby zakończyć wykonywanie polecenia naciśnij klawisz Enter. 
7.3. Odbicie lustrzane 
Za pomocą polecenia MIRROR możesz określić linię bazową do stworzenia odbicia lustrzanego obiektu względem tej linii. W efekcie otrzymuje się symetryczny obraz obiektu. Pozwala to na stworzenie symetrycznego obiektu poprzez narysowanie jego połowy i wykonania jej odbicia symetrycznego. 
Aby wykonać odbicie lustrzane: 1. Wybierz:  Wersja ENG: Modify > Mirror Wersja PL: Modyfikuj > Lustro 2. Zaznacz obiekt i zatwierdź klawiszem Enter. 3. Określ punkty przez które przechodzić ma linia lustra. 4. Jeżeli chcesz zachować obiekt źródłowy wprowadź N w wierszu poleceń lub Y jeżeli chcesz usunąć obiekt źródłowy. 
 
7.4. Odsunięcie obiektu 
Wykorzystaj tą opcję aby skopiować zaznaczone obiekty i odsunąć je od obiektu bazowego na określoną odległość. Możesz wykonać odsunięć za pomocą luków, okręgów, elips, linii, dwuwymiarowych polilinii, półprostych oraz prostych. 
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Aby skopiować zaznaczone obiekty i odsunąć je od obiektu bazowego na określoną odległość: 1. Wybierz:  Wersja ENG: Modify > Offset Wersja PL: Modyfikuj > Odsuń 2. Określ odległość (zaznaczając dwa punkty lub wprowadzając wartość). 3. Zaznacz obiekt do odsunięcia. 4. Określ, po ktorej stronie obiektu ma być umieszczona rownoległa kopia. 5. Zatwierdź polecenie klawiszem Enter. 
Aby skopiować zaznaczone obiekty i wykonać odsunięcie przechodzące przez punkt: 1. Wybierz:  Wersja ENG: Modify > Offset Wersja PL: Modyfikuj > Odsuń 2. W wierszu poleceń wprowadź T. 3. Zaznacz obiekt do wykonania odsunięcia. 4. Określ punkt, przez ktory ma przejść obiekt. 5. Zatwierdź polecenie klawiszem Enter. 
 
 
 
7.5. Szyk 
Możesz utworzyć kopie obiektów ułożone w szyku prostokątnym lub kołowy. Dla szyku prostokątnego, możesz określić liczbę rzędów i kolumn, a także przedziały. Dla szyku kołowego liczbę kopii oraz które z nich mają być obrócone. 
Aby stworzyć szyk prostokątny: 1. Wybierz:  Wersja ENG: Modify > Array Wersja PL: Modyfikuj > Szyk 2. Wybierz opcję szyku prostokątny. 3. Kliknij przycisk Wybierz obiekty i zaznacz żądane obiekty w obszarze rysunku. 4. W oknie dialogowym "Szyk" określ liczbę rzędów i kolumn, odległość i kąt przesunięcia. 5. Kliknij OK.  
 
 
Aby stworzyć szyk biegunowy: 1. Wybierz:  Wersja ENG: Modify > Array Wersja PL: Modyfikuj > Szyk 2. Wybierz opcję szyku kołowego. 3. Kliknij przycisk Wybierz obiekty i zaznacz żądane obiekty w obszarze rysunku. 4. Określ żądane parametry i zatwierdź przyciskiem OK.   
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7.6. Przesunięcie 
Możesz przesunąć obiekty w nowe miejsce na rysunku bez zmian jego parametrów. Możesz zastosować polecenie MOVE w wierszu poleceń i zaznaczyć żądany obiekt(1) do przesunięcia, określić punkt bazowy(2) i punkt przesunięcia(3). Po wykonaniu polecenia obiekt zostanie przesunięty z punktu bazowego do punktu przesunięcia. 
 Aby przesunąć element: 1. Wybierz:  Wersja ENG: Modify > Move Wersja PL: Modyfikuj > Przesuń 2. Zaznacz obiekty i zatwierdź klawiszem Enter. 3. Określ punkt bazowy i punkt przesunięcia. 
Aby przesunąć obiekt używając uchwytów: 1. Zaznacz obiekt. 2. Kliknij na uchwyt. 3. Przeciągnij obiekt aby zmienić jego położenie a następnie kliknij ponownie aby zakończyć. 
 
 
7.7. Obrót 
Możesz dowolnie obracać obiekty wokoł określonego punktu. Określ kąt obrotu przez zaznaczenie punktu na rysunku lub wprowadzając bezpośrednio jego wartość. Kierunek obrotu obiektu zależy od tego czy wprowadzona wartość jest dodatnia czy ujemna. 
Aby obrócić obiekt: 1. Wybierz:  Wersja ENG: Modify > Rotete Wersja PL: Modyfikuj > Obrót 2. Zaznacz obiekty i zatwierdź klawiszem Enter. 3. Określ punkt bazowy i kąt obrotu. 
Aby obrócić zaznaczony element odniesieniu do kąta bezwzględnego: 1. Wybierz:  Wersja ENG: Modify > Rotete Wersja PL: Modyfikuj > Obrót 2. Zaznacz obiekty i zatwierdź klawiszem Enter. 3. Określ punkt bazowy. 4. W wierszu poleceń wprowadź R (odnośnik). 5. Określ odnośnik i nowy kąt.  
 
7.8. Dopasowywanie obiektów 
Możesz dopasowywać obiekty podczas wykonywania ruchu lub obrotu za pomocą polecenia ALIGN. 
Dopasowanie obiektów względem siebie: 1. Wybierz:  Wersja ENG: Modify > Align Wersja PL: Modyfikuj > Dopasuj 2. Zaznacz obiekty i zatwierdź klawiszem Enter. 3. Zaznacz pierwszy punkt źródłowy. 4. Określ punkt docelowy. 5. Zakończ polecenie wciskając klawisz Enter. 
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7.9. Skalowanie 
Użyj polecenia SCALE aby określić proporcjonalność zaznaczonych obiektów. Możesz wprowadzić współczynnik skali lub określić punkt bazowy i odległość określającą przybliżenie obiektów. Gdy wskaźnik skali jest większy niż 1 powoduje powiększenie, w przeciwnym razie powoduje oddalenie obiektów. 
Aby zmienić ustawienia skal za pomocą wskaźnika skali: 1. Wybierz:  Wersja ENG: Modify > Scale Wersja PL: Modyfikuj > Skala 2. Zaznacz obiekty i zatwierdź klawiszem Enter. 3. Określ punkt bazowy. 4. Określ wskaźnik skali. 
7.10. Zmiana długości 
Możesz zmienić długość elementów lub kąty luków. Efekt jest podobny do rozszerzenia i przycinania. Polecenie nie wpływa na zamknięte elementy. 
Aby zmienić długość obiektu za pomocą przeciągnięcia: 1. Wykonaj polecenie LENGTHEN.  2. W wierszu poleceń Wprowadź DY (przyrost). 3. Zaznacz żądane obiekty, które chcesz zmienić. 4. Określ nowy punkt końcowy lub zawarty kąt. 
7.11. Rozciąganie 
Gdy rozciągasz obiekty, możesz określić punkt bazowy i punkt docelowy. Należy użyć przejścia do zaznaczenia żądanych obiektów. Rozciągnąć obiekt można również za pomocą uchwytu. 
Aby rozciągnąć obiekt: 1. Wybierz:  Wersja ENG: Modify > Stretch Wersja PL: Modyfikuj > Rozciągnij 2. Zaznacz obiekty używając okna przejścia lub wielokąta przejścia i zatwierdź klawiszem Enter. 3. Określ punkt bazowy. 4. Określ punkt docelowy. 
Aby rozciągnąć obiekt za pomocą uchwytów: 1. Zaznacz obiekt.  2. Kliknij na uchwyt. 3. Przeciągnij uchwyt. 4. Kliknij ponownie aby zakończyć. 
 
7.12. Przycinanie 
Możesz przycinać obiekty na ich końcach lub wykonywać złożone cięcia zdefiniowane innymi obiektami. 
Aby przyciąć obiekt: 1. Wybierz:  Wersja ENG: Modify > Trim Wersja PL: Modyfikuj > Utnij 2. Zaznacz jedną lub więcej krawędzi cięcia i zatwierdź klawiszem Enter. 3. Zaznacz obiekt do przycięcia. 4. Zakończ poleceni wciskając klawisz Enter. 
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 Aby przyciąć kilka obiektów korzystając z krawędzi: 1. Wybierz:  Wersja ENG: Modify > Trim Wersja PL: Modyfikuj > Utnij 2. Zaznacz jedną lub więcej krawędzi cięcia i zatwierdź klawiszem Enter. 3. W wierszu poleceń wprowadź F (krawędź). 4. Określ pierwszy punkt krawędzi. 5. Określ drugi punkt krawędzi. 6. Naciśnij klawisz Enter aby zakończyć. 
 
7.13. Wydłużanie 
Możesz wydłużyć obiekty w taki sposob, aby ich długość ograniczały inne obiekty. 
Aby wydłużyć obiekt: 1. Wybierz:  Wersja ENG: Modify > Extend Wersja PL: Modyfikuj > Wydłuż 2. Zaznacz jeden lub więcej obiektów określających granice i zatwierdź klawiszem Enter. 3. Zaznacz obiekt do wydłużenia i wciśnij klawisz Enter aby zakończyć wykonywanie polecenia. 
 Aby wydłużyć do dodanych granic: 1. Wybierz:  Wersja ENG: Modify > Extend Wersja PL: Modyfikuj > Wydłuż 2. Zaznacz jedną lub więcej krawędzi granicy i zatwierdź klawiszem Enter. 3. W wierszu poleceń wprowadź E. 4. Ponownie wprowadź E w wierszu poleceń. 5. Zaznacz obiekt do wydłużenia i zakończ polecenie wciskając klawisz Enter. 
  Aby wydłużyć kilka obiektów korzystając z krawędzi: 1. Wybierz:  Wersja ENG: Modify > Extend Wersja PL: Modyfikuj > Wydłuż 2. Zaznacz jedną lub więcej krawędzi granicy i zatwierdź klawiszem Enter. 4. Określ pierwszy i drugi punkt krawędzi. 5. Zakończ wciskając klawisz Enter.    
7.14. Przerywanie 
Możesz tworzyć przerwy w łukach, okręgach, elipsach, liniach, poliliniach, półprostych oraz prostych. Aby utworzyć przerwę w elemencie należy określić na nim dwa punkty. Domyślnie, punkt wybrany do zaznaczenia elementu staje się pierwszym punktem przerwania, możesz również użyć opcji zaznaczenia pierwszego punktu przerwania aby wybrać inny punkt zaznaczonego elementu. 
Aby przerwać obiekt: 1. Wybierz:  Wersja ENG: Modify > Break Wersja PL: Modyfikuj > Przerwij 2. Zaznacz obiekt. 3. Określ drugi punkt przerwania. 
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Aby przerwać obiekt określając dwa punkty przerwania: 1. Wybierz:  Wersja ENG: Modify > Break Wersja PL: Modyfikuj > Przerwij 2. Zaznacz obiekt. 3. W wierszu poleceń wprowadź F aby określić ponownie pierwszy punkt. 4. Określ pierwszy i drugi punkt przerwania. 
 
7.15. Fazowanie 
Możesz połączyć dwa nierównoległe obiekty poprzez rozszerzenie lub przycięcie ich aby połączyć je linią aby utworzyć skos. Gdy tworzysz sfazowanie, możesz określić jak daleko przyciąć obiekty od miejsca ich przecięcia (metoda dystans - dystans) lub określenie długości sfazowania i jego kąta, które powstanie wzdłuż pierwszego obiektu  (metoda dystans - kąt). 
Gdy fazujesz polinie, możesz sfazować wiele odcinków pomiędzy zaznaczonymi punktami lub sfazować całą polilinię. 
Aby sfazować dwa obiekty metodą dystans - dystans: 1. Wybierz:  Wersja ENG: Modify > Chamfer Wersja PL: Modyfikuj > Fazuj 2. W wierszu poleceń wprowadź D (odległość). 3. Określ pierwszą odległość fazowania. 4. Określ drugą odległość fazowania. 5. Zaznacz pierwszy obiekt do sfazowania. 6. Zaznacz drugi obiekt do sfazowania. 
   Aby sfazować dwa obiekty metodą dystans - kąt: 1. Wybierz:  Wersja ENG: Modify > Chamfer Wersja PL: Modyfikuj > Fazuj 2. W wierszu poleceń wprowadź A (kąt). 3. Określ długość sfazowania na pierwszej linii. 4. Określ kąt sfazowania pierwszej linii. 5. Zaznacz pierwszy obiekt do sfazowania. 6. Zaznacz drugi obiekt do sfazowania. 
  Aby sfazować wybrane wierzchołki polilinii:. 1. Wybierz:  Wersja ENG: Modify > Chamfer Wersja PL: Modyfikuj > Fazuj 2. Zaznacz odcinek poliginii, od którego chcesz rozpocząć fazowanie. 3. Zaznacz kolejny odcinek, aby określić miejsce zakończenia fazowania. 
Aby sfazować wszystkie wierzchołki polilinii: 1. Wybierz:  Wersja ENG: Modify > Chamfer Wersja PL: Modyfikuj > Fazuj 2. W wierszu poleceń wprowadź P (polilinia). 3.Zaznacz polilinie. 
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7.16. Zaokrąglanie 
Zaokrąglenia tworzy się za pomocą polecenia FILLET. Ma ono zastosowanie w modyfikacji obiektów, takich jak łuki, okręgi, elipsy, linie, polilinie, półproste, obiekty splajn, linie konstrukcyjne. Zaokrąglenie łączy dwa obiekty za pomocą łuku o określonym promieniu. Zanim utworzysz zaokrąglenie, upewnij się, że dystans pomiędzy każdym wierzchołkiem jest wystarczająco duży do pomieszczenia promienia zaokrąglenia, aby możliwe było wstawienie łuku zaokrąglenia. Gdy promień zaokrąglenia ma wartość 0, łuk nie zostanie wstawiony. Jeżeli dwa odcinki polilinii są oddzielone od siebie za pomocą łuku, program usunie go i wydłuży linie aby przecięły się ze sobą. 
Aby zaokrąglić dwa obiekty: 1. Wybierz:  Wersja ENG: Modify > Fillet Wersja PL: Modyfikuj > Zaokrąglaj 2. W wierszu poleceń wprowadź R (promień). 3. Określ kąt zaokrąglenia. 4. Zaznacz obiekty, między którymi chcesz utworzyć zaokrąglenie. 
Aby zaokrąglić całą polilinię: 1. Wybierz:  Wersja ENG: Modify > Fillet Wersja PL: Modyfikuj > Zaokrąglaj 2. W wierszu poleceń wprowadź P (polilinia). 3. Zaznacz polilinię. 
Aby zaokrąglić zaznaczone wierzchołki polilinii: 1. Wybierz:  Wersja ENG: Modify > Fillet Wersja PL: Modyfikuj > Zaokrąglaj 2. Zaznacz odcinek polilinii, który będzie początkiem zaokrąglenia. 3. Zaznacz odcinek, który będzie zakończeniem zaokrąglenia. 
7.16.1. Przycinanie i rozszerzanie zaokrągleń Podczas wykonywania zaokrąglenia, możesz skorzystać z opcji Utnij aby zdecydować, które z krawędzi zostaną rozszerzone do punktu końcowego łuku zaokrąglenia. Domyślnie, wszystkie obiekt są przycinane lub wydłużane podczas zaokrąglania. 
 
7.16.2. Połączenie zaokrąglenia z polilinią Jeżeli obiekty do zaokrąglenia są liniami lub poliginiami, linia lub przedłużenie musi przecinać się z jednym z odcinków polilinii. Zaokrąglone obiekty łączą się z łukami zaokrąglenia aby utworzyć nową polilinię, korzystając z opcji Utnij.  
7.16.3. Połączenie zaokrąglenia z liniami równoległymi Możesz zaokrąglić równoległe linie, półproste i proste. Element muszą być liniami, półprostymi lub prostymi. Średnica zaokrąglenia jest zawsze równa odległości pomiędzy równoległymi elementami. Bieżąca ustawiona wartość promienia jest ignorowana. 
7.16.4. Odwrócenie zaokrąglenia Jeżeli zajdzie taka potrzeba możesz odwrócić zaokrąglenie, aby otrzymać łuk wklęsły. W programie GstarCAD 2016 funkcja FILLET oferuje teraz nową opcję Invert (wer. PL: Odwróć). Dzięki niej możesz utworzyć odwrócone zaokrąglenie. 
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7.17 Rozdzielanie złożonych obiektów 
Możesz rozdzielić elementy złożonych obiektow, takich jak bloki czy polilinie na pojedyncze elementy składowe. Rozbijając złożony obiekt otrzymuje się zbiór pojedynczych elementów takich jak linie i łuki. Bloki zostają przekształcone w pojedyncze elementy i mogą zawierać inne, osadzone bloki, składające się z oryginalnych elementów.                         Rozbicie elementów nie ma wpływu na wygląd rysunku, z wyłączeniem następujących przypadków: -Jeżeli bazowa polilinia miała zadaną szerokość, informacja ta zostanie utracona po wykonaniu rozbicia. -Jeżeli rozbijesz blok zawierający atrybuty, zostaną one utracone, lecz bazowe atrybuty zostaną zachowane. -Kolory, typy linii, szerokości linii i style wydruku przydzielone po bloku (BYBLOCK) mogą zostać zmienione po wykonaniu rozbicia ponieważ rozbite elementy przejmą domyślne parametry zawarte w kolejnym bloku.  
 7.18. Edycja polilinii 
Prostokąty, wielokąty i pierścienie, a także trójwymiarowe obiekty takie jak ostrosłupy, walce i sfery złożone są z edytowalnych polilinii. Aby zmodyfikować te poliginie, wykonaj polecenie PEDIT w wierszu poleceń. Dostępne opcje zależą od zaznaczonej polilinii, z której zbudowany jest obiekt. Jeżeli zaznaczony obiekt nie jest polilinią, narzędzie edycji polilinii umożliwi skorzystanie z odpowiedniej opcji. Możesz przekształcić w poliginie tylko łuki i linie. Jeżeli kilka łukow lub linie są połączone ze sobą, mogą zostać przekształcone w polilinię.                    
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7.19. Edycja multilinii 
Możesz skorzystać ze wspólnych poleceń edycji aby zmodyfikować kilka elementów jednocześnie. Użyj polecenia MLEDIT aby dodać lub usunąć wierzchołki wielolinii, aby kontrolować ich punkty przecięcia, aby określić style linii za pomocą istniejących stylów, jak również liczbę elementów, kolor, typ linii, szerokość linii i odsunięcie linii od siebie.  
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8. Uwagi i etykiety 
 
8.1.  Tworzenie tekstu 
Program GstarCAD 2016 pozwala na tworzenie obiektów tekstu jedno oraz wielo wierszowych. 
 
8.1.1. Tekst jednowierszowy Możesz skorzystać z polecenia TEXT w wierszu poleceń, aby utworzyć obiekt tekstowy jedno lub wielowierszowy. Każda linia tekstu jest niezależnym obiektem, który może być zmodyfikowany. Zanim wprowadzisz tekst, możesz określić jego styl oraz sposób wyrównania wierszy tworzonego tekstu. 
Naciśnij klawisz Enter, jeżeli wprowadziłeś tekst, następnie wprowadź stosowną opcję do wiersza poleceń aby utworzyć kolejny rząd tekstu. Podczas tworzenia tekstu jednowierszowego, istnieje możliwość określenia wysokości oraz kąta obrotu tekstu, wykorzystując opcje wewnątrz polecenia TEXT. 
Aby utworzyć tekst: 1. Wybierz: Wersja ENG: Text > Single Line Text Wersja PL: Tekst > Pojedynczy tekst. 2. Określ punkt początkowy. 3. Określ wysokość tekstu. 4. Określ kąt obrotu tekstu. 5. Wprowadź tekst i zatwierdź i naciśnij klawisz Enter aby przejść do następnej linii. 6. Aby zakończyć naciśnij klawisz Enter ponownie. 
Aby określić wyrównanie tekstu: 1. Wybierz: Wersja ENG: Text > Single Line Text Wersja PL: Tekst > Pojedynczy tekst 2. W wierszu poleceń wprowadź J (wyrównanie) i zatwierdź klawiszem Enter. 3. Wprowadź opcję wyrównania BR aby wyrównać do dolnego prawego rogu. 5. Wprowadź tekst i zatwierdź i naciśnij klawisz Enter aby przejść do następnej linii. 6. Aby zakończyć naciśnij klawisz Enter ponownie. 
 
8.1.2. Tekst wielowierszowy Składa się z większej ilości linii tekstu lub akapitów, zawartych wewnątrz pola tekstowego, o wymiarach określonych przez użytkownika. Na początku tworzenia tekstu wielowierszowego należy określić wielkość pola tekstowego poprzez określenie przeciwległych wierzchołków prostokątnego pola. Tekst wielowierszowy automatycznie dopasowuje się do obszaru pola tekstowego. Po określeniu wielkości pola tekstowego pojawia się okno dialogowe edytora tekstu. Możesz w nim określić parametry wprowadzanego tekstu. 
Aby utworzyć tekst wielowierszowy: 1. Wybierz: Wersja ENG: Text > Multiline Text Wersja PL: Tekst > Tekst wielowierszowy 2. Określ przeciwległe wierzchołki pola tekstowego. 3. Wprowadź tekst. 4. Aby utworzyć akapit naciśnij klawisz Enter. 
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Formatowanie tekstu, za pomocą narzędzi edytora tekstu: 1. Aby zmienić czcionkę zaznaczonego tekstu, wybierz rodzaj czcionki z listy rozwijalnej na pasku formatowania tekstu. 2. Aby zmienić rozmiar czcionki zaznaczonego tekstu, wprowadź żądaną wartość w polu wysokości. 3. Aby określić kolor zaznaczonego tekstu, wybierz kolor z listy kolorów. 4. Kliknij przycisk OK. na pasku formatowania tekstu lub użyj skrótu klawiszowego Ctrl + Enter. 
   Wyrównanie tekstu wielowierszowego:  Możesz określić punkt zamocowania tekstu w specyficznych punktach pola tekstowego takich jak: góra lewo, góra centrum, gora prawo, środek lewo, środek centrum, środek prawo, dół lewo, dół centrum, dół prawo. Wielowierszowy tekst może być dowolnie przemieszczany w poziomi i pionie.  
  Formatowanie tekstu wielowierszowego:  Podczas tworzenia tekstu wielowierszowego, możesz zmieniać parametry zaznaczonego fragmentu tekstu za pomocą narzędzi formatowania tekstu. 
  Wcięcie w tekście i używanie tabulatur:  Możesz wpływać na wygląd tekstu i tworzyć na przykład listę korzystając tabulatur i wcięć w tekście.  
  Określanie odstępów:  Odstęp w tekście wielowierszowym jest to odległość pomiędzy podstawową a kolejną linią tekstu. Możesz kliknąć prawym przyciskiem myszy w polu tekstowym i wybrać opcję akapit aby określić żądaną odległość między liniami. 
 
Tworzenie ułamków:  Zapis ułamkowy stosowany jest do oznaczania jednostek tolerancji lub jednostki miar. Do jego tworzenia stosowane są znaki specjalne, aby wskazać ich miejsce w tekście. Poniżej przedstawiono znaki specjalne i ich funkcje: -Slash (/): Tworzy ułamek pionowy i oddziela go w linii poziomej. -Hash (#): Tworzy ułamek ukośny i oddziela go po linii ukośnej. -Carat (^): Tworzy ułamek tolerancji, który jest ułamkiem pionowym, nie oddzielonym linią. Możesz również użyć przycisku zapisu ułamkowego na pasku narzędziowym. 
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8.2. Style tekstu 
Styl tekstu jest stosowany w obiektach tekstowych. Skorzystaj ze styli tekstu aby dowolnie zmieniać parametry tekstu. Domyślnie, bieżący styl ustawiony jest jako STANDARD, możesz utworzyć inny styl tekstu, określając jego parametry według potrzeb. Styl standardowy ma następujące właściwości:                        Aby utworzyć styl tekstu: 1. Wybierz: Wersja ENG: Format > Text Style Wersja PL: Format > Styl tekstu 2. Kliknij Nowy, określ nazwę stylu i kliknij przycisk OK. 3. Określ wielkość tekstu, współczynnik szerokości i kąt pochylenia 4. Wybierz czcionkę, którą chcesz zastosować z paska rozwijalnego. 5. Kliknij przycisk Zastosuj a następnie OK. 
 
8.3. Tworzenie linii odniesienia 
8.3.1. Linia odniesienia Jest to linia lub obiekt splajn zakończony strzałką w punkcie końcowym. Do linii odniesienia można dodać adnotację w postaci tekstu umieszczonego bezpośrednio obok ostatniego punktu. 
Aby utworzyć linię odniesienia i adnotację: 1. Wybierz: Wersja ENG: Dimension > Leader Wersja PL: Wymiar > Linia odniesienia 2. Określ punkt początkowy. 3. Określ punkt końcowy odcinka linii odniesienia. 4. Określ dodatkowe odcinki. 5. Po określeniu ostatniego punktu końcowego wciśnij klawisz Enter. 6. Wprowadź adnotację i naciśnij klawisz Enter by przejść do następnej linii tekstu. 7. Naciśnij klawisz Enter aby zakończyć.  
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8.3.2.  Multilinia odniesienia Pozwala na dodanie adnotacji do wielu linii odniesienia,  aby umieścić dodatkowe informacje na rysunku. Dodatkowo daje możliwość używania bloków jako odnośników. Program GstarCAD 2016 udostępnia szereg opcji dla tej komendy, takich jak: dodawanie, usuwanie, dopasowywanie i grupowanie odniesień.   

       
8.4. Edycja tekstu 
8.4.1. Zmiana tekstu Każdy obiekt może zostać przeniesiony, obrocony, usunięty i skopiowany. Możesz zmienić właściwości tekstu w panelu Właściwości. Istnieją dwa sposoby modyfikacji tekstu jednowierszowego: -Za pomocą polecenia DDEDIT. -Za pomocą polecenia PROPERTIES, aby otworzyć paletę właściwości, w której możesz zmienić istotne ustawienia. 
 Aby zmodyfikować tekst wielowierszowy: 1. Wykonaj polecenie DDEDIT. 2. Zaznacz tekst jedno lub wieloliniowy. 3. W polu edycji tekstu dokonaj żądanych zmian i zatwierdź klawiszem Enter.              
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Aby zmienić właściwości tekstu: 
1. Zaznacz obiekt tekstu. 2. Kliknij prawym przyciskiem myszy na zaznaczony obiekt i wybierz opcje Właściwości z menu skrótów. 3. W palecie właściwości, wprowadź nowy tekst w Zawartości Tekstu i zmień pozostałe właściwości według potrzeb. 4. Możesz też dwukrotnie kliknąć tekst wielowierszowy aby otworzyć okno edytora tekstu i sformatować jego zawartość.                     
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9. Wymiary i tolerancje 
Wymiary wskazują wartości miar obiektów (takich jak długość czy szerokość), dystans lub kąt pomiędzy obiektami, odległość pomiędzy punktem cechy i określonego początku. Możesz utworzyć pięć podstawowych typów wymiarów: liniowy, kątowy, promieniowy i średnicowy. Wymiary posiadają kilka odrębnych elementów: wymiar, tekst, linia wymiarowa, strzałki i linie pomocnicze.  
1. Tekst wymiaru: Tekst reprezentujący wartość danego wymiaru. 2. Linia wymiarowania: Wskazuje kierunek i zakres wymiaru . 3.Strzałki: Wyświetlane są na obu końcach linii wymiarowania. 4.Linie pomocnicze: Określają zakres danego wymiaru. 
 
  
 
9.1. Tworzenie wymiaru 
Możesz utworzyć wymiary przez zaznaczenie obiektu do zwymiarowania i określenie położenia linii wymiarowania lub określając linie pomocniczych dla tego obiektu a następnie linii wymiarowania. 
 
9.1.1. Wymiar poziomy i pionowy Po zwymiarowaniu obiektu, program automatycznie zatwierdzi poziome i pionowe linie wymiarowania, w zależności od określonych linii pomocniczych lub położenia zaznaczonego obiektu. W czasie wymiarowania możesz określić czy wymiary są poziome czy pionowe. 
Aby stworzyć poziomy lub pionowy wymiar: 1. Wybierz: Wersja ENG: Dimension > Linear Wersja PL: Wymiar > Liniowy 2. Naciśnij klawisz Enter i zaznacz obiekt do zwymiarowania lub określ pierwszy i drugi punkty początku linii pomocniczej. 3. Określ położenie linii wymiarowania. 
 
9.1.2. Tworzenie wymiarów normalnych  W wymiarowaniu normalnym, linia wymiarowania jest równoległa do linii przechodzącej przez początkową linie pomocniczą. Jest również równoległy do powierzchni obiektu, który został określony. Program automatycznie utworzy potrzebne linie pomocnicze. 
Aby utworzyć wymiar normalny: 1. Wybierz: Wersja ENG: Dimension > Aligned Wersja PL: Wymiar > Normalny 2. Wciśnij klawisz Enter i zaznacz obiekty do zwymiarowania lub określ punkty początku linii pomocniczej. 3. Określ położenie linii wymiarowania. 
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9.1.3. Tworzenie linii bazowej i kontynuowanie wymiarowania W obu przypadkach mamy do czynienia z wieloliniowymi wymiarami liniowymi. Bazowe linie wymiarowania są miarami głównymi. Kontynuowanie wymiarowania tworzy linie zlokalizowane koniec przy końcu. Zanim utworzysz linię bazową lub będziesz kontynuował wymiarowanie, utwórz wymiar linowy lub kątowy. 
 
Aby utworzyć bazowy liniowy wymiar: 
1. Wybierz: Wersja ENG: Dimension > Baseline Wersja PL: Wymiar > Baza 2. Określ drugą podstawową linię pomocniczą. 3. Zaznacz następną linię pomocniczą. 4. Zaznacz dodatkowe linie pomocnicze, jeżeli to konieczne. 5. Aby zakończyć polecenie naciśnij klawisz Enter dwukrotnie.  
  Aby kontynuować wymiarowanie liniowe: 1. Wybierz: Wersja ENG: Dimension > Continue Wersja PL: Wymiar > Kontynuuj 2. Zaznacz początkowy wymiar i zatwierdź klawiszem Enter. 3. Zaznacz następną linię pomocniczą i zaznacz istniejący wymiar aby kontynuować. 4. Dodaj kolejne wymiary zaznaczając kolejne początki linii pomocniczych. 5. Aby zakończyć polecenie naciśnij klawisz Enter dwukrotnie. 
 
 
 
9.1.4. Tworzenie obróconego wymiaru  Możesz utworzyć obrócony wymiar określając kąt obrotu za pomocą opcji Rotated polecenia DIMLINEAR.  
 
9.1.5. Tworzenie wymiaru kątowego  Wymiary kątowe stosowane są do zmierzenia miary pomiędzy liniami lub trzema punktami. 
Aby utworzyć wymiar kątowy między dwoma liniami: 1. Wybierz: Wersja ENG: Dimension > Angular Wersja PL: Wymiar > Kątowy 2. Zaznacz jedną z linii. 3. Zaznacz inną linię. 4. Określ położenie linii wymiarowania. 
 Aby zwymiarować łuk: 1. Wybierz: Wersja ENG: Dimension > Angular Wersja PL: Wymiar > Kątowy 2. Zaznacz łuk. 3. Określ położenie linii wymiarowania. 
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9.1.6. Tworzenie wymiaru promieniowego  Możesz stworzyć wymiar promieniowy dla okręgu lub łuku mierząc ich promień. Wymiar promieniowy jest reprezentowany przez linię ze strzałką wskazującą okrąg lub łuk. 
Aby utworzyć wymiar promieniowy: 1. Wybierz: Wersja ENG: Dimension > Radius Wersja PL: Wymiar > Promień 2. Zaznacz łuk lub okrąg. 3. Określ położenie linii wymiarowania. 
9.1.7. Wymiar ucięty Jest to wymiar promieniowy. Możesz określić centralną pozycję początkowego wymiaru aby przesunąć punkt środkowy okręgu lub łuku wewnątrz wymiaru promieniowego. Polecenie DIMJOGGED jest użyteczne do utworzenia wymiarów, gdy środek okręgu lub łuku jest zlokalizowany poza układem rysunku i nie może zostać wyświetlony w jego pozycji rzeczywistej. 
Aby utworzyć ucięty wymiar promieniowy: 1. Wybierz: Wersja ENG: Dimension > Jogged Wersja PL: Wymiar > Ucięty 2. Zaznacz okrąg lub łuk. 3. Zaznacz punkt środkowy. 4. Określ punkt aby wstawić symbol ucięcia. 
9.1.8. Tworzenie wymiaru średnicowego Możesz utworzyć wymiar średnicowy dla okręgu lub łuku aby określić miarę ich średnicy. 
Aby utworzyć wymiar średnicowy: 1. Wybierz: Wersja ENG: Dimension > Diameter Wersja PL: Wymiar > Średnica 2. Zaznacz łuk lub okrąg. 3. Określ położenie linii średnicy.  
9.1.9. Tworzenie wymiarów współrzędnych  Wymiar współrzędnych składają się z linii wymiarowania o wartościach X lub Y i rysowanych wzdłuż kierunków bieżącego LUW. 
Aby utworzyć wymiar współrzędnych:  1. Wybierz: Wersja ENG: Dimension > Ordinate Wersja PL: Wymiar > Współrzędne 2. Zaznacz punkt do zwymiarowania współrzędnych. 3. Określ punkt końcowy linii wymiarowania współrzędnych. 
 
9.1.10. Szybkie wymiarowanie Pozwala na szybkie zwymiarowanie za pomocą polecenia QDIM.  
Aby wykonać szybkie wymiarowanie: 1. Wybierz: Wersja ENG: Dimension > Quick Dimension Wersja PL: Wymiar > Szybki wymiar 2. Zaznacz geometrię do zwymiarowania i zatwierdź klawiszem Enter. 3. W wierszy poleceń zostaną wyświetlone opcje polecenia QDIM, które możesz wykonać. 
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9.1.11. Wymiarowanie długości łuku Jest dostępne dla miary długości łuku lub odcinka polilinii. Program GstarCAD tworzy wymiar długości przez określanie położenia linii pomocniczej bezpośrednio po zaznaczeniu łuku. Wykorzystany zostaje symbol łuku jako wymiar długości łuku, ktory określany jest na podstawie wymiaru liniowego i kątowego. 
Aby utworzyć wymiar długości łuku: 1. Wybierz:  Wersja ENG: Dimension > Arc Length Wersja PL: Wymiar > Długość łuku 2. Zaznacz łuk lub łuk będący odcinkiem polilinii. 3. Określ pozycję wymiaru długości łuku. 
 
 
9.2. Style wymiarowania 
Możesz kontrolować wygląd wymiarowania przez zmianę ustawień aby pomoc utrzymać standardy wymiarowania. 
9.2.1. Style wymiarowania  Możesz utworzyć, zapisać, przywrocić i usunąć nazwane style wymiarowania. Style wymiarowania zapewniają wiele możliwości ustawień kontrolujących wygląd wymiarowania. Zmianą podlegają następujące ustawienia: -Linie pomocnicze, linie wymiarowania, strzałki, linie oraz odsunięcie między nimi. -Pozycjonowanie części wymiarowania względem siebie oraz orientacja tekstu wymiarowania. -Zawartość i wygląd tekstu wymiarowania oraz wartości jednostek. 
Aby utworzyć styl wymiarowania: 1. Wybierz: Wersja ENG: Dimension > Style Wersja PL: Wymiar > Styl wymiarowania 2. W oknie dialogowym "Menadżer stylów wymiarowania" kliknij przycisk Nowy. 3. Wprowadź nazwę nowego stylu i wybierz rodzaj stylu wymiarowania. Następnie kliknij Kontynuuj. 4. Zmień konieczne ustawienia wymiarowania. 5. Aby zakończyć kliknij OK.                         
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Aby zmienić nazwę stylu wymiarowania: 1. Wybierz: Wersja ENG: Dimension > Style Wersja PL: Wymiar > Styl wymiarowania 2. Z listy stylów wybierz żądany styl i wykonaj jedną z czynności: -Kliknij dwukrotnie na żądany styl.  -Kliknij prawym przyciskiem myszy na żądany styl i wybierz Zmień nazwę z menu skrótów. 3. Wprowadź nową nazwę. 4. Kliknij przycisk Zamknij. 
 
 
Aby usunąć styl wymiarowania: 1. Wybierz: Wersja ENG: Dimension > Style Wersja PL: Wymiar > Styl wymiarowania 2. Kliknij prawym przyciskiem myszy na styl na liście i wybierz Usuń z menu rozwijalnego.  3. Kliknij Zamknij aby zamknąć okno. 
 
 
 
Aby wyświetlić informację o bieżącym stylu: 1. Wybierz: Wersja ENG: Dimension > Style Wersja PL: Wymiar > Styl wymiarowania 2. W oknie dialogowym kliknij przycisk Porównaj. 3. W nowym oknie wybierz te same style z listy rozwijalnej. Wszystkie właściwości zostaną wyświetlone. 4. Jeżeli chcesz porównać informacje dwoch rożnych stylow wybierz dwa rożne style. 
5. Kliknij Zamknij aby zamknąć okno dialogowe. 
 
 
9.2.2. Modyfikacja linii wymiarowania W oknie dialogowym modyfikacji stylu możesz ustawić kolor, szerokość i grubość linii, poza liniami pomocniczymi i liniami bazowymi. 
 
9.2.3. Modyfikacja linii pomocniczych  Linie pomocnicze posiadają następujące właściwości: kolor, szerokość linii, odległość między kolejnymi liniami, odsunięcie od początkowej linii pomocniczej i widoczność. Możesz ustawić właściwości w zakładce Linie w oknie dialogowym modyfikacji stylów wymiarowania. 
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9.2.4. Wybór strzałek  Możesz kontrolować wygląd i rozmiar strzałek lub położenie haczyków na końcach linii wymiarowania. Możesz określić rożne strzałki dla obu końców linii. 
Aby wybrać strzałkę: 1. Wybierz: Wersja ENG: Dimension > Style Wersja PL: Wymiar > Styl wymiarowania 2. W menadżerze stylów wybierz styl, który chcesz zmodyfikować. 3. Zmień symbol strzałki w modyfikowanym stylu.  
4. Kliknij OK a następnie Zamknij. 
 
 
 
 
9.2.5. Dopasowanie stylu tekstu wymiarowania  Gdy nie ma wystarczającej ilości miejsca pomiędzy liniami pomocniczymi aby wyświetlić tekst wymiarowania i strzałki, możesz dopasować ich rozmieszczenie. Domyślnie, program rozmyśla te elementy w najlepszy możliwy sposób, w zależności od dostępnej przestrzeni. Możesz określić inne metody dopasowania w zakładce Dopasowanie, w oknie dialogowym edytora stylów wymiarowania. 
Aby sformatować wymiarowanie: 1. Wybierz: Wersja ENG: Dimension > Style Wersja PL: Wymiar > Styl wymiarowania 2. W Menadżerze stylów wymiarowania zaznacz style, które chcesz zmodyfikować. 3. Kliknij zakładkę Dopasuj. 4. Zaznacz żądane opcje. 5. Kliknij OK a następnie Zamknij. 
 
 
 
9.2.6. Dopasuj tekst wymiarowania do średnicy  Możesz utworzyć rożne wymiary średnicy, z rożnym rozmieszczeniem tekstu wymiarowania. Zaznacz opcję "Zawsze wstawiaj tekst między linie wymiarowania" w zakładce Dopasuj.            
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9.2.7. Wyrównanie tekstu wymiarowania Gdy tekst znajduje się wewnątrz lub na zewnątrz linii pomocniczej, nie daje to efektu wyrównania tekstu do linii. Możesz wybrać czy tekst ma być wyrównany do linii czy pozostać poziomo. 
Aby wyrównać tekst do linii wymiarowania: 1. Wybierz: Wersja ENG: Dimension > Style Wersja PL: Wymiar > Styl wymiarowania 2.W menadżerze stylow zaznacz styl, ktory chcesz zmodyfikować. 3. Kliknij zakładkę Tekst. 4. Zaznacz żądane opcje. 5. Kliknij OK a następnie Zamknij. 
 
 

9.2.8. Pozycjonowanie tekstu wymiarowania pionowo Pionowe położenie tekstu jest zależne od wymiaru. Możesz umieścić tekst powyżej, poniżej lub w centrum linii wymiarowania.  
 
9.2.9. Pozycjonowanie tekstu wymiarowania poziomo Pozycja tekstu wzdłuż osi poziomej jest zależna od linii pomocniczych. Może być umieszczony w centrum, na linii 1 lub2, nad linia 1 lub 2. 
 
9.2.10. Jednostki wymiarowania  Możesz określić wygląd i format jednostek wymiarowania. Możesz ustalić jednostki podstawowe, wraz z ich formą i dokładnością. Ustawienia te kontrolują wyświetlanie wartości wymiarowania. 
Aby zaokrąglić wymiar: 1. Wybierz: Wersja ENG: Dimension > Style Wersja PL: Wymiar > Styl wymiarowania 2.W menadżerze stylow zaznacz styl, ktory chcesz zmodyfikować. 3.Wybierz zakładkę Jednostki podstawowe. 4. Określ dokładność żądanych jednostek. 5. Kliknij OK a następnie Zamknij. 
 
 
 
9.2.11. Jednostki dodatkowe  Możesz utworzyć dwa systemy miar jednocześnie na jednym rysunku. Cecha ta jest pomocna gdy chcesz dodać stopy i cale do rysunku korzystającego z jednostek metrycznych. Dodatkowe jednostki zostają wyświetlane w prostokątnych nawiasach w tekście wymiarowania. 
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Aby utworzyć jednostki dodatkowe:  1. Wybierz: Wersja ENG: Dimension > Style Wersja PL: Wymiar > Styl wymiarowania 2.W menadżerze stylów zaznacz styl, który chcesz zmodyfikować. 3.Wybierz zakładkę Jednostki dodatkowe. 4. Określ dokładność żądanych jednostek. 5. Kliknij OK a następnie Zamknij. 
 
 
 
 
9.2.12. Wyświetlanie bocznej tolerancji Reprezentuje ona wartość, ktorej miara odległości jest zmienna. Możesz kontrolować stopień dokładność potrzebny przyszłego określenia tolerancji w procesie produkcji. Wymiary tolerancji wskazują największy i najmniejszy dopuszczalny rozmiar. Tolerancje odchylenia stanowią o dodatnich i ujemnych wartościach dołączonych do wartości wymiarowania. Jeżeli tolerancje odchylenia są równe, znaki poprzedzające i ich wartości są symetryczne. W przeciwnym wypadku, wartość  dodatnia określa położenie powyżej wartości ujemnej. Pionowe położenie wartości tolerancji jest zależne od głównego tekstu wymiarowania. Na przykład, możesz wyrownać tolerancję z gorą, środkiem i dołem tekstu wymiarowania. 

 
9.2.13. Ustawienia skali dla wymiarowania  Ustawienia skali wymiarowania są zależne od określonego układu i opcji drukowania rysunku. Skala wymiarowania wpływa na wielkość geometrii wymiarowania powiązanej z obiektami na rysunku. Poza wielkością tekstu i strzałek, skala wymiarowania wpływa również na inne elementy wymiarowania, takie jak początkowe odsunięcie linii konstrukcyjnej. Podczas tworzenia wymiarów, zaleca się ustawienie wielkości zgodnie z aktualnym stylem wydruku. Tolerancja, długość miary, współrzędne i kąty nie mogą być zatwierdzone do ogólnego współczynnika skali. Metody tworzenia wymiarów w układzie rysunku przedstawione są poniżej: - Wymiary w przestrzeni modelu do wydruku w przestrzeni modelu. Jeżeli chcesz utworzyć wymiary zgodne ze skalą wydruku, ustaw zmienną systemową DIMSCALE w wierszu poleceń jako odwrotność żądanej skali wydruku. Na przykład, jeżeli skala wydruku jest ustawiona na 1/4, należy ustawić wartość zmiennej DIMSCALE jako 4. - Wymiar w przestrzeni modelu do wydruku w przestrzeni papieru. Jeżeli chcesz aby utworzone wymiary były automatycznie skalowane do wyświetlanej przestrzeni papieru w układzie papieru, określ wartość zmiennej DIMSCALE jako 0. Metoda ta jest użyteczna w następujących przypadkach: wymiary na rysunku wymagają odwołania do innego rysunku (w przypadku plików xref); gdy tworzysz izometryczne wymiary w izometrycznym widoku 3D. Aby zapobiec wyświetlaniu wymiarów widocznych na jednej rzutni układu w innej, należy utworzyć warstwę, na której umieszczane będą wymiary i zamrozić ją dla pozostałych rzutni układu. 
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- Wymiary w przestrzeni różnych układów. Możesz utworzyć wymiary w przestrzeni papieru, zaznaczając obiekty w przestrzeni modelu lub określając położenie uchwytów obiektów z przestrzeni modelu. Wymiary utworzone w przestrzeni papieru nie wymagają dodatkowego skalowania. 
9.3. Modyfikowanie istniejących wymiarów 
Możesz modyfikować element istniejących wymiarów osobno lub korzystając z menadżera stylów wymiarowania. 

9.3.1. Modyfikacja stylu wymiarowania  Możesz modyfikować wszystkie właściwości istniejącego obiektu wymiarowania za pomocą stylow wymiarowania. Możesz również utworzyć zmieniając czasowo zmienne systemowe bez zmiany bieżącego stylu wymiarowania. Zmiany w bieżącym stylu wymiarowania powodują automatyczne zaktualizowanie powiązanych z nim wymiarów. 
 
9.3.2. Wymiary ukośne Linie konstrukcyjne tworzone są pod kątem prostym do linii wymiarowania. Możesz zmienić kąt linii konstrukcyjnych, co wpłynie również na powiązane z nimi linie wymiarowania. 
Abu utworzyć pochyłą linie konstrukcyjne: 1. Wybierz: Wersja ENG: Dimension > Oblique Wersja PL: Wymiar > Pochyl 2. Zaznacz wymiar liniowy i zatwierdź klawiszem Enter. 3. Wprowadź kąt pochylenia i zatwierdź klawiszem Enter. 
Uwaga: Aby wyrównać kąt pochylenia, jeżeli nie znasz dokładnej miary, użyj uchwytów aby wybrać dwa punkty elementu. 
 
9.3.3. Wymiar ścięcia liniowego  Polecenie DIMJOGLINE służy do dodawania lub usuwania symbol ucięcia dla wymiarów linowych. Domyślnie symbol ucięcia wstawiany jest w punkcie środkowym pomiędzy pierwszą linią konstrukcyjną a tekstem. Możesz zmienić jego położenie wyrównując pozycję tekstu wymiarowania lub określając nowe położenie ucięcia po ponownym zaznaczeniu wymiaru. 
Aby dodać ucięcie do wymiaru liniowego: 1. Wybierz: Wersja ENG: Dimension > Jogged Wersja PL: Wymiar > Ucięty liniowy 2. Zaznacz wymiar liniowy. 3. Określ punkt wymiaru, aby określić położenie symbol ucięcia lub wciśnij klawisz Enter, aby wstawić symbol w punkcie domyślnym. 
 
9.3.4. Kontrola wymiarów  Służy do określenia częstotliwości sprawdzania części zwymiarowanej, wartości wymiarowania i części tolerancji o określonym zasięgu. Przegląd przedstawiony jest w formie ramki z wewnętrznym tekstem, zawierająca trzy skrajne rodzaje informacji: oznaczenie kontroli, wartość wymiaru i szybkość sprawdzania. 
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Oznaczenie kontroli, jest znakiem zlokalizowanym po lewej stronie ramki kontroli.  Wartość wymiaru, to wartość sprzed dodania kontroli, jest położona w środkowej części wymiaru kontrolnego zawierająca tolerancję, tekst i wartość miary. Szybkość sprawdzania, jest wyrażony w procentach, zlokalizowany po prawej stronie wewnątrz ramki kontrolnej, zawiera wymaganą częstotliwość części, która została stworzona. 
Aby utworzyć kontrolę wymiaru: 1. Wybierz: Wersja ENG: Dimension > Inspect Wersja PL: Wymiar > Kontrola 2. W oknie dialogowym kliknij przycisk Wybierz wymiary. 3. Zaznacz wymiary aby dodać kontrolę i zatwierdź klawiszem Enter. 4. Zaznacz symbol ramki. 5. Zaznacz opcję etykietki aby wprowadzić etykietkę w polu tekstowym. 6. Zaznacz opcję szybkość sprawdzania aby wprowadzić wartość w procentach. 7. Kliknij OK. 
Aby usunąć kontrolę wymiaru: 1. Wybierz: Wersja ENG: Dimension > Inspect Wersja PL: Wymiar > Kontrola 2. W oknie dialogowym kliknij przycisk Wybierz wymiary. 3. Zaznacz wymiary, których kontrolę chcesz usunąć i zatwierdź klawiszem Enter. 4. Kliknij przycisk Usuń sprawdzenie. 5. Kliknij OK. 
9.3.5. Wyrównanie odstępów wymiaru  Przy tworzeniu równoległych wielolinii wymiarowania lub wymiarów kątowych, możesz wyrównać odstępy między nimi z wartością rowną domyślnej bądź określonej. Polecenie DIMSPACE wyrównuje przestrzeń pomiędzy liniowymi wymiarami równoległymi, wymiarami kątowymi lub zachodzącymi na siebie wymiarami.  
 
 
 
 
9.4. Dodawanie tolerancji geometrycznej 
Tolerancja geometryczna pokazuje akceptowalne odchyłki profile, orientacji, położenia i bicia cechy. Tolerancję geometryczną dodaje się w ramce kontrolnej cechy. Ramki te zawierają wszystkie informacje dotyczące tolerancji dla pojedynczego wymiaru. Tolerancja geometryczna może utworzono bez linii odniesienia. Tolerancję możesz utworzyć za pomocą polecenia TOLERANCE lub LEADER.  
Ramka kontrolna cechy zawiera dwa lub więcej elementów. Pierwszą cechą jest symbol reprezentującą charakterystykę geometryczną, do której została zatwierdzona tolerancja, na przykład położenie, profil, 
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forma, orientacja lub bicie. Forma tolerancji ustala prostoliniowość, płaskość, okrągłość i walcowość; profile kontrolują linie i powierzchnie.  
9.4.1. Okno dialogowe tolerancji geometrycznej Pozwala określić symbole i wartości w ramce kontroli cech. 
1. Symbol charakterystyki geometrycznej (menu) 2. Pole tolerancji (przełącznik) 3. Wartość pola tolerancji 4. Pasowanie (menu) 5. Punkty odniesienia 1 z 3 6. Punkty odniesienia 2 z 3 7. Symbol prognozowanego pola tolerancji (przełącznik) 8. Wartość prognozowego pola tolerancji 9. Identyfikator punktu odniesienia 
9.4.2. Symbole tolerancji geometrycznej  Poniżej przedstawiono symbole tolerancji geometrycznej i ich znacznie: 
1. Pozycja (Położenie) 2. Koncentryczny lub współosiowy (Położenie) 3. Symetryczny (Położenie) 4. Równoległy (Orientacja) 5. Prostopadły (Orientacja) 6. Kątowy (Orientacja) 7. Cylindryczny (Orientacja)  8. Płaski (Orientacja) 9. Kołowy lub okrągły (Forma) 10. Prostoliniowość (Forma) 11. Profil powierzchni (Profil) 12. Profil linii (Profil) 13. Bicie kołowe (Bicie) 14. Bicie całkowite (Bicie) 
 
9.4.3. Implikacja materialna W zależności od typu kontrolowania, możesz dodać symbol średnicy przed wartością tolerancji i określić symbol implikacji materialnej za tą wartością. Możesz zatwierdzić implikacje materialną do cech mogących różnić się wielkością. 
9.4.4. Punkt odniesienia ramki Punkt odniesienia zawiera wartości i symbole modyfikacji. Punkt ten jest teoretycznie dokładnym odniesieniem geometrycznym, zmierzonym i zweryfikowanym punktu, osi lub płaszczyzny. Program zapewnia do trzech liter punktu odniesienia i powiązanych z odpowiednimi symbolami wartości tolerancji. 
9.4.5. Prognozowane pola tolerancji Kontrolują wysokość nieruchomej części pionowej rozszerzonego obszaru i określają dokładność tolerancji przez jej pozycjonowanie. Przed ustawieniem symbolu prognozowanego pola tolerancji, należy ustawić wartość wysokości, aby określić minimalne pole tolerancji. 
 
9.4.6. Tolerancja złożona  
Składa się z dwóch tolerancji zatwierdzonych do tej samej charakterystyki geometrycznej lub cech o rożnych punktach odniesienia. Zanim zostanie utworzony wymiar i dodana do niego tolerancja złożona, należy określić pierwszą linię ramki kontrolnej cechy i wybrać ten sam symbol charakterystyki geometrycznej dla drugiej linii ramki kontroli cechy. Przedział określonego symbolu geometrycznego jest przedłużony poza obie linie. Następnie możesz utworzyć drugą linię symboli tolerancji. 
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Aby dodać tolerancję geometryczną: 1. Wybierz: Wersja ENG: Dimension > Tolerance Wersja PL:  Wymiar > Tolerancja 2.W oknie dialogowym, kliknij pierwszy kwadrat w kolumnie symbol i zaznacz symbol do wstawienia. 3. W kolumnie Tolerancja 1, kliknij pierwszy kwadracik i wstaw symbol średnicy. 4. W polu tekstowym wprowadź pierwszą wartość tolerancji. 5. Aby dodać implikację materialną, kliknij na drugi kwadracik i zaznacz symbol do wstawienia. 6. W kolumnie Tolerancja 2, powtórz kroki od 3 do 5 dodając drugą wartość tolerancji. 7. W kolumnie Ident. 1, Ident. 2 i Ident. 3, wprowadź litery punktów odniesienia. 8. Kliknij kwadracik aby dodać implikację materialną dla każdego punktu odniesienia. 9. W polu tekstowym Wysokość, wprowadź wartość wysokości pola tolerancji. 10. Aby wstawić symbol prognozowanego pola tolerancji, kliknij na kwadracik pola tolerancji. 11. Dodaj wartości punktu, w nowym oknie i kliknij przycisk OK. 12. Określ położenie ramki cechy w obszarze rysunku.  
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10. Bloki, atrybuty, odniesienia 
10.1. Tworzenie i wstawianie bloków 
Zazwyczaj, bloki składają się z kilku obiektów połączonych w jeden, który po wstawieniu do rysunku jest traktowany jako pojedynczy obiekt. Bloki pomagają w lepszej organizacji pracy i szybszym przeglądaniu rysunku oraz zmniejszenie wielkości pliku. 
10.1.1. Tworzenie bloków Zazwyczaj, bloki składają się z kilku obiektów połączonych w jeden, który po wstawieniu do rysunku jest traktowany jako pojedynczy obiekt. Blok może zawierać widoczne obiekty, takie jak linie, łuku czy okręgi oraz niewidoczne, tak zwane atrybuty. Bloki są przechowywane jako elementy w pliku rysunku. Możesz tworzyć bloki na kilka sposobów:  
-Połączyć obiekty aby utworzyć definicję bloku w bieżącym rysunku. -Utworzyć rysunek a następnie wstawić go jako blok w innym. 
 
Aby utworzyć blok do wykorzystania wewnątrz bieżącego rysunku: 1. Wybierz:  Wersja ENG: Draw > Block > Make Wersja PL: Rysuj > Blok > Utwórz 2. W oknie dialogowym, wprowadź nazwę bloku. 3. Zaznacz pole wyboru Wybierz na ekranie aby określić punkt wstawienia klikając na wybrany punkt na rysunku. 4.Kliknij przycieś Zaznacz obiekty aby zaznaczyć obiekty, które chcesz umieścić w bloku a następnie naciśnij klawisz Enter. Zakończ klikając przycisk OK. 
10.1.2. Tworzenie osadzonych bloków Możesz zdefiniować bloki jako bloki osadzone, aby uprościć ich organizację w przypadku złożonych obiektów. Dzięki temu, możesz zbudować pojedynczy blok z kliku elementów. Zauważ jednak, że bloki odnoszące się do siebie nie mogą być wstawione. 
 
      

10.1.3. Plik rysunkowy jako blok. Możesz stworzyć blok będący oddzielnym plikiem rysunku, dzięki czemu będziesz mógł wstawić go do dowolnego innego rysunku. 
Aby zapisać blok jako oddzielny plik rysunku: 1. W wierszu poleceń, wprowadź polecenie WBLOCK.  2. W obszarze źródłowym, wybierz jedno z poniższych: -Blok: Zapisuje istniejący blok w osobnym pliku rysunku. -Cały rysunek: Zapisuje wszystkie obiekty jako osobny plik. -Obiekty: Zapisuje zaznaczone obiekty jako nowy rysunek. 3. W obszarze docelowym, wprowadź nazwę pliku, który chcesz utworzyć i określ ścieżkę zapisu.   
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10.1.4. Zmiana punktu bazowego rysunku do użycia jako blok  Domyślnie, gdy wstawiasz plik rysunku jako blok, program określa bazowe współrzędne początkowe jako (0, 0, 0). Aby określić inny punkt wstawienia, użyj polecenia BASE. Następnym razem, blok zostanie wstawiony w nowo określonym punkcie wstawienia. 
10.1.5. Aktualizacja zmian na rysunku źródłowym  Plik rysunku wstawiony jako blok do innego również podlega edycji, lecz wstawiony blok nie zostanie zmieniony po edycji pliku źródłowego. Jeżeli zdarzają się zmiany bloku, wraz z plikiem źródłowym, należy załączyć go jako odnośnik zewnętrzny a nie jako blok. 
10.1.6. Użycie obiektów w przestrzeni papieru jako bloków Obiekty utworzone w przestrzeni papieru nie są zawarte w bloku, gdy jest wstawiany do rysunku. Możesz przekształcić obiekty w przestrzeni papieru na bloki lub zapisać je jako osobny plik rysunku zanim plik rysunku zostanie wstawiony jako blok. 
 
10.1.7. Wstawianie bloków  Możesz wstawiać bloki i inne pliki rysunków do bieżącego rysunku. Gdy wstawiasz blok, jest on traktowany jako zwykły obiekt. Gdy wstawiasz plik rysunku, zostaje dodany do bieżącego rysunku jako blok. Zmiany dokonane na pliku źródłowym bloku nie zostaną zaktualizowane w bieżącym rysunku do momentu ponownego zdefiniowania wstawionego pliku. 
 Aby wstawić blok: 1. Wybierz:  Wersja ENG: Insert > Block Wersja PL: Wstaw > Blok 2.W oknie dialogowym kliknij na pasek rozwijalny nazywa. 3. Wybierz nazwę bloku, który chcesz wstawić. 4. Możesz określić punkt wstawienia, skalę i obrót, klikając punkty na ekranie lub wprowadzając odpowiednie wartości. 5. Kliknij OK.  
   Aby wstawić cały plik rysunku jako blok: 1. Wybierz:  Wersja ENG: Insert > Block Wersja PL: Wstaw > Blok 2.Kilkinij przycisk przeglądaj, aby określić plik, który chcesz wstawić. 4. Możesz określić punkt wstawienia, skalę i obrót, klikając punkty na ekranie lub wprowadzając odpowiednie wartości. 5. Jeżeli chcesz wstawić obiekty rysunku jako pojedyncze elementy, zaznacz opcję rozbij.  6. Kliknij OK. 
   
10.1.8. Modyfikacja zdefiniowanych bloków Możesz ponownie zdefiniować wszystkie obiekty bloków w bieżącym rysunku. Aby to zrobić utwórz nowy blok o tej samej nazwie. Możesz w ten sposób zaktualizować wszystkie bloki. Jeżeli blok został wstawiony z oddzielnego pliku rysunku nastąpi aktualizacja i ponowne wstawienie danego bloku. 
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Aby ponownie określić blok wstawiony w bieżącym rysunku: 1. Wybierz:  Wersja ENG: Draw > Block > Make Wersja PL: Rysuj > Blok > Utwórz 2. W oknie dialogowym, wprowadź nazwę bloku, który chcesz zdefiniować ponownie. 3. Określ punkt wstawienia bloku w obszarze rysunku. 4. Zaznacz obiekty, które chcesz dodać do bloku i zatwierdź klawiszem Enter. 5. Kliknij OK. 6. Kliknij Taka by zatwierdzić ponowne zdefiniowanie bloku.  
 
 
10.1.9. Usuwanie zdefiniowanych bloków Zbyt duża ilość zdefiniowanych bloków, wpływa na rozmiar pliku rysunku. Aby zmniejszyć jego rozmiar, możesz usunąć nieużywane bloki zdefiniowane w rysunku. Wymazanie zdefiniowanych bloków usuwa je z rysunku ale mogą pozostać w tabeli zdefiniowanych bloków. Polecenie P RUGE może pomóc w usunięciu niewykorzystywanych bloków.  
   
  10.1.10. Definiowanie i używanie atrybutów bloku Atrybut jest szczególnym obiektem, który można zapisać jako część definicji bloku. Atrybuty zawierają dane tekstowe. Mogą być wykorzystywane do śledzenia części liczb i cen. Wartości atrybutów mogą być stałe lub zmienne. 
Aby zdefiniować atrybut: 1. Wybierz:  Wersja ENG: Draw > Block > Define Attributes Wersja PL: Rysuj > Blok > Zdefiniuj atrybut 2.Wprowadź etykietę, monit, domyślny tekst. 3. Określ punkt wstawienia i położeni atrybutu lub określ parametry klikając na wybrane punkty w obszarze rysunku. 4. Zaznacz dodatkowe tryby. 5. Określ styl tekstu. 6. Aby dodać atrybut do rysunku, wykonaj jedno z poniższych działań: -Kliknij Definiuj aby dodać atrybut i zachować aktywne okno dialogowe. -Kliknij Definiuj i wyjdź aby dodać atrybut i zamknąć okno dialogowe.  
   Aby edytować zdefiniowany atrybut: 1. W wierszu poleceń wprowadź polecenie DDEDIT.  2. Zaznacz tekst definiowanego atrybutu do edycji. 3. Modyfikuj parametry atrybutu w wyświetlonym oknie dialogowym. 4. Kliknij OK. 
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10.1.11. Modyfikacja atrybutów bloku Możesz skorzystać z menadżera atrybutów bloku aby modyfikować atrybuty. Na przykład, możesz zmodyfikować następujące pozycje:  
-Atrybuty bloków mogą być wyświetlone po modyfikacji. -Właściwości tekstu, definiujące jaki tekst atrybutu jest wyświetlany na rysunku. -Właściwości definiujące warstwę, na której znajduje się atrybut, takie jak: 
kolor linii, szerokość i rodzaj. 
Aby edytować atrybuty załączone do bloku: 1. W wierszu poleceń wprowadź polecenie DDEDIT. 2. Zaznacz bloki do edycji. W oknie dialogowym wyświetlone są wszystkie atrybuty dodanie do zaznaczonego bloku. 3. Edytuj wartości atrybutów według potrzeb. Następnie kliknij OK. 
 
 
10.1.12. Wyciągnięcie danych z atrybutów bloku Wprowadź polecenie EATTEXT aby rozpocząć wyciąganie atrybutów z bloków na rysunku, które je posiadają. Możesz wyciągnąć informacje o bloku, stosując szybki kreator i wygenerować listę zawierającą przegląd informacji o atrybutach bloków.  
Za pomocą funkcji wyciągania danych z atrybutów bloków, możesz w łatwy sposób utworzyć listę, z której możesz skorzystać podczas wyciągania informacji o atrybutach i eksportowaniu ich do zewnętrznego pliku.  
 
 
 
 
10.2. Pliki XREF 
Zewnętrzne odnośniki zapewniają dodatkowe możliwości, niedostępne przy wstawianiu zwykłych bloków. Gdy dołączony zostanie zewnętrzny odnośnik, wszystkie zmiany dokonane w pliku źródłowym zostają odświeżone po odświeżeniu bieżącego rysunku. Odnośniki zewnętrzne są użyteczne przy bardzo złożonych rysunkach. Użyj zewnętrznych odnośników do koordynowania prac wykonywanych przez grupę projektantów. Odnośniki zewnętrzne pomagają również ograniczyć wielkość pliku rysunku, gwarantując jednocześnie pracę na najbardziej aktualnej wersji tworzonego projektu. 
10.2.1. Załączanie zewnętrznego odnośnika Gdy plik rysunku jest dołączony do bieżącego rysunku jako plik XREF, każda zmiana będzie miała odzwierciedlenie w bieżącym rysunku. Zewnętrzne odniesienia zostają wstawione do bieżącego rysunku jako definicje bloków i używane jako pojedyncze obiekty ale możesz rozróżnić je od zwykłych bloków. 
Aby załączyć zewnętrzny odnośnik: 1. Wybierz: Wersja ENG: Insert > External References Wersja PL:  Wstaw > Odnośnik 2. Kliknij ikonę DWG, umieszczonej w lewym, górnym narożniku okna. 3. W oknie dialogowym, określ plik rysunku do załączenia i kliknij przycisk Otwórz. 
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4. Określ sposób wstawienia rysunku: -Dołączony: Wstawia kopię rysunku. -Nakładowy: kopiuje warstwy rysunku na rysunek główny. 5. Zaznacz dodatkowe właściwości a następnie kliknij OK. 6. Jeżeli wybrałeś opcje wybierz na ekranie dla wszystkich właściwości, określ je kolejno kliknięciami myszy w obszarze rysunku.                
10.2.2. Kontrola właściwości odnośników warstw Możesz kontrolować widoczność, kolor, typ linii i inne właściwości warstw odnośnikow i określić te zmiany jako czasowe lub stałe. Jeżeli zmienna systemowa VISRETAIN ma ustawioną wartość 0, zmiany zostają zastosowane tylko w bieżącym rysunku. Kontroli podlega tez zmienna XDWGFADECTL. Dodatkowo możesz kontrolować warstwy bezpośrednio z poziomu menadżera warstw.  
 
10.2.3. Przycinanie granic pliku XREF Możesz kontrolować kiedy program ma wyświetlać przycięte granice pliku XREF bezpośrednio za pomocą zmiennej XCLIPFRAME. Możesz również przyciąć wyświetlany plik wybierając opcje z paska menu: Wersja ENG: Modify > Clip> Xref Wersja PL: Modyfikuj > Przytnij > Odnośnik 
 
               
10.2.4. Osadzenie i nachodzenie odnośników zewnętrznych  Pliki XREF mogą być osadzone w innym pliku XREF i załączone do bieżącego rysunku. W procesie załączania, możesz zaznaczyć punkt wstawienia, wspołczynnik skalowania i kąt obrotu odnośnika.  
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10.2.5. Powiązanie pliku XREF z rysunkiem Aby przekazać kopię rysunku zawierającego odnośniki zewnętrzne do innego użytkownika, należy zapewnić dostęp do wszystkich plików XREF. Powiązanie plików XREF powoduje, że stają się stałym elementem rysunku, który jest podobny do wstawionego oddzielnie rysunku jako blok. Możesz powiązać zewnętrzny odnośnik klikając prawym przyciskiem myszy na zaznaczony plik XREF.  
 
 
 
 
10.2.6. Odświeżanie plików XREF Możesz odświeżyć zewnętrzne odnośniki, klikając przycisk odśwież na górze okna dialogowego odnośników zewnętrznych. 
 
 
 

10.3. Plik DGN jako podkład 
GstarCAD 2016 pozwala na wykorzystywanie plików DGN jako podkładów na rysunku. Za pomocą poleceń DGNIMPORT, DGNATTACH, DGNADJUST, DGNMAPING, itp. możesz importować i załączać pliki DGN (format natywny programu Microstation).  
             
10.4. Plik DWF jako podkład 
W programie GstarCAD możesz użyć pliku DWF jako podkładu.  
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10.5. Plik PDF jako podkład 
Dzięki programowi GstarCAD możesz wykorzystać otrzymany plik PDF jako podkład w swoim rysunku.                                 Po wstawieniu pliku PDF jako podkładu możesz skorzystać podczas rysunku ze szczególnych punktów zaznaczonych na podkładzie. 
Co więcej, możesz regulować takie parametry wyświetlania podkładu, jak: kontrast, nasycenie i kolory. W tym celu skorzystaj z palety narzędzi.  
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10.6. Edycja zakładki  odniesień 
GstarCAD 2016 posiada funkcję REFEDIT, która pozwala na edycję bloków jako odniesień. Użytkownik ma dostęp do funkcji znajdujących się na pasku narzędzi w widoku klasycznym, oraz zakładki wstążki z interfejsu wstążkowego. Program pozwala na dokonywanie zmian wyświetlania zawartości tego panelu. 
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11. Kreskowanie i obrazy rastrowe 
 
11.1. Kreskowanie 
11.1.1. Określanie granicy kreskowania  Aby utworzyć kreskowanie, należy zdefiniować jego granice przez zaznaczenie obiektów, które mają zostać zakreskowane lub wybranie punktu wewnątrz żądanego obiektu. Granice kreskowania mogą składać się z połączenia wielu obiektów, takich jak linie, łuki, okręgi i polilinie tworzące zamknięty obszar. 
 
11.1.2. Kontrola kreskowania wyspowego  Możesz określić opcję kreskowania obiektów na skrajnej granicy jako normalną, skrajną i ignoruj. Kreskowanie normalne jest domyślnym wzorem, możesz zobaczyć efekt wybrania rożnych typów kreskowania w obszarze wyspowy, w zakładce kreskowania i oknie dialogowym gradientu. 
Normalny : Wzór kreskowania od zewnętrznej granicy do środka. Proces kreskowania zostanie zakończony, gdy napotkany zostanie wewnętrzny punkt przejścia, i kontynuowane dopóki drugi wewnętrzny punkt przejścia się nie pojawi. 
Skrajny: Kreskowanie z najbardziej zewnętrznej warstwy, zachowuje puste wnętrze ograniczone granicą. 
Zignoruj: Zakreskowuje jedynie obiekty zewnętrzne. 
  Aby zaznaczyć obiekty do zakreskowania: 1. Wybierz:  Wersja ENG: Draw > Hatch Wersja PL: Rysuj > Kreskuj 2. W oknie dialogowym zaznacz opcję wykrywanie wysp i wybierz jeden z typów: Normalny, Skrajny, Zignoruj: 

 3. Aby zachować wszystkie nowe obiekty, które zostały utworzone na granic kreskowania, zaznacz opcję Zachowaj obwiednię. 4. Kliknij Wybierz obiekty z opcji obwiedni. 5. Na rysunku, kliknij na obiekty do indywidualnego kreskowania i zatwierdź klawiszem Enter. 6. W oknie dialogowym kliknij przycisk OK. 
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Zaznaczanie obszaru do kreskowania: 1. Wybierz:  Wersja ENG: Draw > Hatch Wersja PL: Rysuj > Kreskuj 2. W oknie dialogowym zaznacz opcję wykrywanie wysp i wybierz jeden z typów: Normalny, Skrajny, Zignoruj.          3. Aby zachować wszystkie nowe obiekty, które zostały utworzone na granic kreskowania, zaznacz opcję Zachowaj obwiednię. 4. Kliknij Wskaż punkty z opcji obwiedni. 5. Na rysunku, kliknij wewnątrz zamkniętego obwodu. Jeżeli potrzebne jest zaznaczenie więcej obwodów, kontynuuj wybieranie punktów na rysunku. 6. Aby zakończyć naciśnij klawisz Enter, a następnie kliknij przycisk OK.  
 
 
 
11.1.3. Wybieranie i definiowanie wzorów kreskowania Wzór kreskowania składa się z powtarzającego się wzoru linii, skosów i punktów. Możesz zaznaczyć wzór kreskowania z zestawu predefiniowanych wzorów lub zdefiniować własny wzór. Najczęściej stosowane wzór będzie dostępny jako domyślny przy następnym dodawaniu kreskowania. Program wspiera predefiniowane standardowe wzory kreskowania, które są przechowywane w plikach ICAD.pat i ICADISO.pat. 
 
 
 
Aby określić predefiniowany wzór kreskowania: 1. Wybierz:  Wersja ENG: Draw > Hatch Wersja PL: Rysuj > Kreskuj 2. W oknie dialogowym, kliknij zakładkę Kreskowanie. 3. Z rozwijalnej listy typu wybierz opcje wstępnie zdefiniowane. 4. Wprowadź współczynnik skali, jako procent wartości domyślnej. 5. Wprowadź wartość kąta. Domyślnie, kąt jest zgodny z ruchem wskazówek zegara. 6. Wprowadź szerokość pióra ISO. Dostępne tylko dla zaznaczonego wzoru ISO. 7. Aby skopiować właściwości z istniejącego wzoru, wybierz Właściwości dziedziczone. 8. Aby skojarzyć wzór kreskowania z granicami obiektów, zaznacz odpowiednią opcję. Skojarzone kreskowanie jest automatycznie aktualizowane, gdy przesunięta zostanie jedna z granic. 9. Aby kontynuować, dodaj kreskowanie przez zaznaczenie obiektów, określenie punktów zaznaczonego obszaru lub granice, które mają być zakreskowane. 
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Aby określić wzór kreskowania zdefiniowany przez użytkownika: 1. Wybierz:  Wersja ENG: Draw > Hatch Wersja PL: Rysuj > Kreskuj 2. W oknie dialogowym, kliknij zakładkę Kreskowanie. 3. Z rozwijalnej listy typu wybierz opcje użytkownika. 4. Ustaw odstępy linii dla wzoru. 5. Aby skopiować właściwości z istniejącego wzoru, wybierz Właściwości dziedziczone. 6. Aby skojarzyć wzór kreskowania z granicami obiektów, zaznacz odpowiednią opcję. Skojarzone kreskowanie jest automatycznie aktualizowane, gdy przesunięta zostanie jedna z granic. 7. Aby kontynuować, dodaj kreskowanie przez zaznaczenie obiektów, określenie punktów zaznaczonego obszaru lub granice, które mają być zakreskowane.  
Aby użyć predefiniowanej biblioteki wzorów: 1. Wybierz:  Wersja ENG: Draw > Hatch Wersja PL: Rysuj > Kreskuj 2. W oknie dialogowym, kliknij zakładkę Kreskowanie. 3. Z rozwijalnej listy typu wybierz opcje wstępnie zdefiniowane. 4.Aby zaznaczyć predefiniowany wzór, wykonaj jedną z poniższych czynności: -Wybierz żądaną nazwę wzoru z listy -Kliknij na grafikę reprezentującą żądany wzór. 5. Aby kontynuować, dodaj kreskowanie przez zaznaczenie obiektów, określenie punktów zaznaczonego obszaru lub granice, które mają być zakreskowane. 
 
 
 
11.4.1. Bryły Za pomocą narzędzi płaszczyzn, możesz narysować prostokąt, trójkąt lub czworobok, wypełniony jednym kolorem. Domyślnym sposobem jest określenie wierzchołków płaszczyzny. Po określeniu pierwszych dwóch wierzchołków, płaszczyzna zostanie wyświetlona po określeniu pozostałych wierzchołków. Program wyświetli monit dotyczący wyznaczenia trzeciego a następnie czwartego punktu. 
Aby narysować czworokątną płaszczyznę: 1. Wybierz:  Wersja ENG: Draw > Modeling > Meshes > 2D Solid Wersja PL: Rysuj > Modelowanie > Siatka > Bryła 2D 2. Określ punkty wyznaczające wierzchołki płaszczyzny. 3. Zakończ polecenie klawiszem Enter. 
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11.2. Praca z plikami rastrowymi 
Możesz przeglądać i manipulować plik rastrowy i skojarzone ścieżki do pliku na rysunku. 
11.2.1. Dołączanie, skalowanie, odłączanie obrazów rastrowych Plik rastrowy składa się z prostokątnej siatki małych kwadratów i pikseli. Plik rastrowy może być kopiowany, przesuwany lub przycinany, tak jak standardowy obiekt na rysunku. Możesz również regulować kontrast, przezroczystość, jakość obrazu i widzialność ramki, Dodatkowo, wykryty format rastrowy wstawianego pliku, zależny jest od jego zawartości a nie od istniejącej nazwy. Tabela obok zawiera wspierane formaty plików. 
 
11.2.2. Dołączanie obrazu rastrowego Użyj polecenia IMAGEATTACH aby zaznaczyć i dołączyć plik rastrowy lub plik graficzny. Plik graficzny może być wstawiony jako blok, przycięty i wy edytowany. 
Aby dołączyć plik rastrowy: 1. Wybierz:  Wersja ENG: Insert > Raster Image reference Wersja PL: Wstaw > Odniesienie do obrazu rastrowego 2. Określ plik, który ma zostać dołączony i kliknij OK. 3. W oknie dialogowym wprowadź parametry położenia pliku lub zaznacz opcje wybierz na ekranie i kliknij OK. 4. Określ punkt wstawienia. 5. Określ skalę. 
 
11.2.3. Skala obrazu rastrowego Możesz określić współczynnik skali w oknie dialogowym, w przeciwnym razie wielkość rysunku będzie zgodna z jego oryginalnym rozmiarem. 
11.2.4. Odłączanie obrazu rastrowego  Plik rastrowy może zostać odłączony od rysunku, gdy przestaje być potrzebny. Odłączenie pliku nie ma wpływu na zawartość pliku źródłowego.  
 
11.2.5. Modyfikacja i zarządzanie obrazami rastrowymi  Możesz określić właściwości pliku rastrowego, takie jak wyświetlanie i przycięcie granic. Możesz przeglądać i manipulować dołączonymi plikami oraz zmieniać zapisaną ścieżkę do pliku. Za pomocą polecenia IMAGEFRAME możesz włączać i wyłączać granice w bieżącym widoku zmieniając wartości na 0 (wyłączone) lub 1 (włączone). 
Aby włączyć lub wyłączyć ramki dla wszystkich obrazów: 1. Wybierz:  Wersja ENG: Modify > Object > Image > Frame Wersja PL: Modyfikuj > Obiekt > Obraz > Obramowanie 2. Ustaw jeden z następujących przełączników obramowania jako włączony lub wyłączony: -Wprowadź wartość 1 aby moc wyświetlić i wydrukować wszystkie ramki dla wszystkich obrazow na rysunku. -Wprowadź wartość 0 aby ukryć wszystkie ramki.  



11. Kreskowanie i obrazy rastrowe 
 

121  

Aby przyciąć obraz do kształtu wyznaczonego przez prostokąt lub wielokąt: 1. Wybierz:  Wersja ENG: Modify > Object > Image  Wersja PL: Modyfikuj > Obiekt > Obraz 2. Zaznacz krawędzie obrazu, który chcesz przyciąć.  3. W wierszu poleceń wprowadź N (nowa granica) aby utworzyć granicę do przycięcia. 4. Jeżeli wybrałeś czworokąt: -Określ pierwszy wierzchołek -Określ przeciwległy wierzchołek 5. Jeżeli wybrałeś wielokąt:: -Zaznacz punkty wierzchołków wielokąta i zatwierdź klawiszem Enter.  
 
11.2.6. Zmiana jasności, kontrastu i zaciemnienia obrazu rastrowego  Użyj polecenia IMAGEADJUST, aby wyregulować parametry wyświetlanego obrazu. Zmiany te nie mają wpływu na źródłowy plik obrazu.  

 
11.2.7. Poprawa szybkości wyświetlania obrazów rastrowych  Możesz wyregulować szybkość wyświetlania za pomocą ustawień jakości obraz rastrowego. Jakość obrazu jest podzielona na wysoką i poziomy rysowania. Jeżeli jakość zostanie ustawiona do rysowania, obraz może posiadać szumy, natomiast jest szybciej wyświetlany. 
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12. Układ, wydruk i publikowanie rysunków 
12.1. Tworzenie wielo widokowych układów rynków 
12.1.1. Przegląd układu Układ reprezentujący stronę wydrukowaną na jednym lub większej ilości wyświetlanych widoków modeli. Program GstarCAD 2016 zapewnia dwa rodzaje zabezpieczeń środowisk pracy, takich jak zakładki Model i Układ. Możesz utworzyć tematyczne modele w zakładce modeli. Wiele slajdów modelu może być ustawionych w zakładce Układu. Użyj tych głównych kroków aby przygotować rysunek do wydruku wielu układów:  
1. Utwórz rysunek w zakładce Modelu. 2. Utwórz nowy Układ. Możesz skorzystać z istniejących już Układu 1, Układu 2 lub utworzyć nowy Układ 3. 3. Utwórz co najmniej jedną rzutnię w zakładce Układu. Użyj każdej rzutni aby ułatwić kontrolę nad fragmentami wydruków rysunku i określaniu skali. 4. Określ dodatkowe ustawienia Układu, takie jak skala, obszar wydruku, tabele stylu wydruku i wiele więcej. 5. Wydrukuj przygotowany rysunek.  
 
Możesz kliknąć prawym przyciskiem myszy na zakładkę Układu i zaznaczyć opcję Nowy Układ, aby utworzyć nowy układ lub importować szablon. Opcje dostępne z listy skrótów: 

12.1.2. Praca w przestrzeni modelu i przestrzeni papieru  Przestrzeń modelu jest zwykle wykorzystywana do tworzenia i edycji rysunku. Przestrzeń papieru przeznaczona jest do przygotowania wydruku.  
Przestrzeń modelu jest obszarem, w którym możesz utworzyć dwu lub trójwymiarowe obiekty. Zawartość przestrzeni papieru reprezentuje kartkę papieru, na której zostanie wydrukowany rysunek. W tym obszarze roboczym, możesz stworzyć i zaaranżować rożne widoki narysowanego modelu, co pozwala na wydrukowanie na przykład detalu rysunku. Możesz określić istotne ustawienia wydruku z poziomu zakładki Układu. Przestrzeń papieru zapewnia dostęp, do każdej opcji dostępnej w zakładce Układu, umożliwia utworzenie rzutni i pozwala na zmianę ustawień strony, takich jak rozmiar papieru, orientację i położenie. Zmiany te mogą zostać zapisane dla wszystkich Układów.  
Możesz zapisać i nazwać ustawienia strony i zatwierdzić je dla innych Układu podczas zmiany ustawień strony. Ponadto, możesz utworzyć nowy Układ, korzystając z  istniejących plików szablonów (w formacie DWT lub DWG). 
 Kliknij na zakładkę Model, aby zobaczyć i edytować obiekty w przestrzeni modelu.  
12.1.3. Określenie ustawień układu  Po utworzeniu rysunku w zakładce Model, możesz przełączać się między zakładkami Układu i ustawić układ wydruku. Poprzez kliknięcie prawym przyciskiem myszy na zakładkę Układu, możesz utworzyć nowy Układ, importować szablony z pliku lub otworzyć menadżer ustawienia strony.  
12.1.4. Zaznaczanie rozmiaru papieru dla Układu  Rozmiar papieru odnosi się do rysunku. Gdy otworzysz okno dialogowe wydruku w zakładce Układu, możesz przydzielić rodzaj papieru z listy rozwijalnej pola tekstowego rozmiar papieru. Rozmiar papieru posiada podgląd szkicu wraz z wielkościami i jednostkami. Dostępne rodzaje papieru zależą od bieżących ustawień. Aby wyeksportować obraz rastrowy, należy 
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określić wyjściowy rozmiar w pikselach. Rozmiar papieru może zostać spersonalizowany w edytorze konfiguracji drukarki. 
 
12.1.5. Ustalenie orientacji układu   Orientacja rysunku jest podzielona na poziomą i pionową. Decyduje ona o orientacji drukowanego rysunku na papierze. Po określeniu orientacji rysunku, możesz wybrać czy rysunek ma zostać wydrukowany normalnie, czy odwrócony. Zmiany wprowadzone w oknie dialogowym ustawień strony zostają w dalszym ciągu zapisane dla układów. Niektóre ustawienia strony mogą zostać zastąpione przez dostosowane później ustawienia wydruku, lecz nie zostaną zapisane do momentu kliknięcia przycisku Zatwierdź. 
 
 
12.1.6. Regulowanie odsunięcia wydruku układu Możesz odsunąć geometrię na papierze, wprowadzając dodatnie lub ujemne wartości X i Y w polach odsunięcia wydruku. Zmieniając orientację wydruku możesz zmienić pozycję rysunku na papierze. Początkowe położenie wydruku określone jest przez lewy dolny wierzchołek obszaru wydruku, z odsunięciem o wartości 0 dla powiązanych kierunków X i Y. Zaznacz środek papieru, jeżeli określony obszar wydruku jest tylko fragmentem całego układu.                
 
 
12.1.7. Ustawienia obszary wydruk układu Możesz ustawić obszar wydruku w oknie dialogowym wydruku. Gdy utworzony zostaje nowy układ, domyślne opcje wydruku posiadają limit, który określa ilość wszystkich obiektów w obszarze drukowania. Aby zmienić obszar wydruku skorzystaj z: 
-Układ: Wydrukuj wszystkie elementy należące do układu. -Okno: Określ obszar wydruku za pomocą prostokątnej ramki, zostaną wydrukowane jedynie obiekty znajdujące się w zaznaczonym obszarze.  -Zakres: Wydrukowany zostanie fragment bieżącej przestrzeni rysunku, która zawiera obiekty. -Ekran: Wydrukowana zostanie zawartość bieżącego widoku. 
 

Wydruk z początkiem w (0,0) Wydruk z początkiem w  (101,0) 
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12.1.8. Ustawienia wydruku i szerokości linii Możesz określić skalę drukowanego rysunku. Zazwyczaj obiekty w przestrzeni modelu są wyświetlane zgodnie ze skalą ustawioną dla rzutni układu. Aby wydrukować obiekty z przestrzeni modelu w skali określonej w układzie, należy ustawić skalę jako 1:1. Nawet, gdy skala wydruku układu jest ustawiona, istnieje możliwość określenia szerokości linii. Skalowanie szerokości linii nie ma nic wspólnego ze skalą wydruku. Jest głownie stosowne dla linii, z których składają się drukowane obiekty. 
 
12.1.9. Przesuwanie i kopiowanie układów Za pomocą kliknięcia prawym przyciskiem myszy, możesz przesunąć lub skopiować Układ. W oknie dialogowym, wybierz nowe położenie bieżącego układu aby go przesunąć. Możesz też utworzyć kopię układu. Zauważ, że zakładka modelu nie może być przesunięta lub skopiowana.  
 
 
 
12.1.10. Tworzenie układu za pomocą szablonu Kliknij prawym przyciskiem myszy na zakładkę Układu i zaznacz opcję szablonów, aby wczytać plik DWG lub DWT i użyć go jako szablonu nowego Układu. Program wspiera pliki szablonów z rozszerzeniem .dwt. Szablony układu każdego rysunku mogą być zaimportowane w bieżącym. 
Aby utworzyć nowy układ za pomocą istniejącego pliku: 1. Wybierz:  Wersja ENG: Insert > Layout > Layout from Template Wersja PL: Wstaw > Układ > Układ z szablonu 2. W oknie dialogowym, zaznacz żądany plik szablonu i kliknij przycisk Otwórz. 3. W oknie dialogowym wstawianego układu, zaznacz układ, który chcesz wstawić i kliknij OK. 
 
12.1.11. Tworzenie i modyfikowanie rzutni układu  W zakładce Układu, należy utworzyć przynajmniej jedną rzutnię układu aby zobaczyć narysowany model. Każda rzutnia układu jest tworzona oddzielnie, możesz ją dowolnie przesuwać, kopiować lub usunąć. Każda zmiana, której dokonasz w jednej rzutni jest widoczna na pozostałych. Przybliżanie i przesuwanie widoku jest widoczne dla każdej rzutni osobno. 
 Tworzenie rzutni układu: 1. W wierszu poleceń wprowadź polecenie MVIEW. 2. Wprowadź F(dopasuj) lub inną z możliwych opcji. 3.Wybierz aranżację rzutni, wprowadzając H (dla widoku poziomego) lub V (dla widoku pionowego). 4. Skorzystaj z jednej z poniższych możliwości: -Aby wypełnić bieżący obszar graficzny rzutni wprowadź F. -Aby dopasować rzutnię do prostokątnej granicy, określ wierzchołki prostokąta. Możesz utworzyć pojedynczą rzutnię lub podzielić obszar graficzny na wiele rzutni ułożonych poziomo, pionowo, powyżej, poniżej, na lewo, na prawo.   
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 Aby zmodyfikować właściwości układu: 1. Kliknij na granicę rzutni, której właściwości chcesz zmodyfikować. 2. Wybierz paletę właściwości z menu opcji Narzędzia > Palety > Właściwości lub z Modyfikuj  > Właściwości. 3. W palecie właściwości, zaznacz skalę standardową, a następnie zaznacz nową skalę z listy. Skala to zostanie zatwierdzono do rzutni. 
    Włączanie i wyłączanie rzutni: 1. Kliknij na żądaną zakładkę Układu. 2. Wprowadź polecenie MVIEW i potwierdź klawiszem Enter. 3. Określ czy rzutnia ma być włączona czy wyłączona.  4. Zaznacz krawędź rzutni, którą chcesz włączyć lub wyłączyć. 
 
 
 Tworzenie nie prostokątnej rzutni: Użyj opcji obiektów i wielokątów dostępnych w poleceniu MVIEW aby utworzyć nieregularną rzutnię. Zaznacz opcję obiektu aby przekształcić obiekty utworzone w przestrzeni papieru w rzutnie. Podczas zaznaczania opcji wielokątów, rysowana polilinia zostanie automatycznie zamknięta.  
 
 
12.2. Wydruk rysunku 
Po zakończeniu rysowania, możesz wykonać wydruk lub zapisać go do pliku. 
12.2.1. Ustawienia wydruku Tworzenie rysunku w dużej części odbywa się w zakładce modelu. W dowolnym momencie możesz wydrukować rysunek aby zobaczy jak wygląda na papierze. W prosty sposob możesz wydrukować rysunek i określić własne parametry wydruku. 
Aby rozpocząć wydruk:  1. Wybierz:  Wersja ENG: File > Plot Wersja PL: Plik > Drukuj 2. Wybierz drukarkę i określ istotne parametry, a następnie kliknij OK. 
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12.2.2. Ustawienia rozmiaru papieru  Możesz wybrać rozmiar papieru z listy rozwijalnej w polu tekstowym rozmiaru papieru. Aby móc wybrać rozmiar papieru, najpierw należy określić drukarkę. 
Aby wybrać drukarkę lub ploter:  1. Wybierz:  Wersja ENG: File > Plot Wersja PL: Plik > Drukuj 2. Wybierz drukarkę z listy i kliknij OK. 
 
 
12.2.3. Pozycja rysunku na papierze Możesz wyregulować położenie rysunku na papierze zanim rozpoczniesz wydruk. 
Aby określić początkowy obszar wydruku: 1. Jeżeli to konieczne, kliknij na żądaną zakładkę Układu lub Modelu. 2. Wybierz:  Wersja ENG: File > Plot Wersja PL: Plik > Drukuj 3. Wykonaj jedną z czynności w obszarze odsunięcia wydruku: -Zaznacz centrum aby ustawić obszar wydruku na środku kartki papieru. -Aby określić początek obszaru wydruku, wprowadź współrzędne X i Y. 4. Zaznacz OK, a następnie kliknij Zatwierdź dla układu. 
 
12.2.4. Ustawienia orientacji rysunku  Orientacja rysunku określa również orientację przy wydruku. Możesz też określić czy rysunek ma zostać wydrukowany odwrotnie. 
 
    

12.2.5. Ustawienia skali wydruku  Skala wydruku może zostać określona bezpośrednio w oknie dialogowym wydruku w polu skali wydruku. Możesz też sam wprowadzić wartość skali lub wybrać dopasowanie rysunku do rozmiaru papieru, wtedy skala zostanie dobrana automatycznie, tak aby wypełnić całą dostępną przestrzeń papieru. Skala i jednostki wydruku muszą zostać określone przed wydrukiem. 
  Aby automatycznie określić skalę rysunku do wydruku: 1. Jeżeli to konieczne, kliknij na żądaną zakładkę Układu lub Modelu.  2. Wybierz:  Wersja ENG: File > Plot Wersja PL: Plik > Drukuj 3. Wybierz opcję dopasowania do rysunku z obszaru skali, aby skala rysunku automatycznie dopasowała się do rozmiaru papieru. 
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12.2.6. Ustawienia opcji wydruku Następujące opcje są dostępne w palecie wydruku: 
-Drukuj w tle. Proces wydruku zostanie wykonany w tle.  -Drukuj szerokość linii. Drukuje szerokość linii przydzielonych do obiektów i warstw. -Drukuj ze stylami wydruku. Drukowanie zgodnie z określonym stylem wydruku. -Drukuj obszar papieru na końcu. Drukowana jest najpierw geometria z przestrzeni modelu. -Ukryj obiekty w obszarze papieru. Pominięte zostają obiekty umieszczone za innymi obiektami. Opcja dostępna jedynie w zakładkach Układu. -Ze znakiem wydruku. W określonym rogu rysunku zostaje wydrukowany informacyjny znak wydruku. -Zapisz zmiany w Układzie. Wszystkie zmiany wprowadzone w oknie dialogowym drukowania zostaną zapisane dla Układu. 
 

12.2.7. Określenie obszaru wydruku Możesz określić fragment rysunku do wydruku, jeżeli to konieczne kliknij zakładkę Układu lub Modelu. 1. Wybierz:  Wersja ENG: File > Plot Wersja PL: Plik > Drukuj 2. W obszarze wydruku, wybierz jedną z poniższych opcji:  -Ekran. Wyświetlony zostanie bieżący widok. -Granice. Zostanie wydrukowany obszar zawierający się określonych granicach wydruku. -Limity/Układ. Wydrukowana zostanie zawartość zgodnie z określonymi limitami w drukowalnym obszarze. -Okno. Wydrukowany zostanie fragment rysunku określony przez użytkownika. 
 
 
12.2.8. Podgląd wydruku Podgląd pozwala na zobaczenie jak rysunek będzie wyglądał na papierze, przed rozpoczęciem drukowania. 
Aby zobaczyć podgląd rysunku:  1. Jeżeli to konieczne, kliknij na żądaną zakładkę Układu lub Modelu. 2. Wybierz:  Wersja ENG: File > Plot Wersja PL: Plik > Drukuj 3. Wykonaj jedną z poniższych czynności: -Aby wydrukować, kliknij przycisk Drukuj. -Naciśnij klawisz Esc aby zakończyć podgląd. 
 

12.2.9. Korzystanie ze styli wydruku Style wydruku pomagają w kontroli wyglądu rysunku. Style wydruku przechowywane są zapisane w tabelach, które zlokalizowane są w plikach zapisanych na dysku, skorzystaj z nich aby wyeliminować potrzebę ponownego konfigurowania ustawień przy każdym nowym wydruku. Istnieją dwa rodzaje tabel stylów: 
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-Tabele stylów zależnych od koloru (CTB). Zawierają zestaw stylów wydruku bazujących na każdym z 255 indeksów kolorów dostępnych na rysunku. Mogą być zmienne, niezależnie od koloru. -Tabele stylów nazwanych (STB). Zawierają zestaw stylów wydruku określonych przez użytkownika. 
Aby przydzielić tabele stylów: 1. Jeżeli to konieczne, kliknij na żądaną zakładkę Układu lub Modelu. 2. Wybierz:  Wersja ENG: File > Plot Wersja PL: Plik > Drukuj 3. W tabelach stylów wydruku, zaznacz jedną z poniższych tabel stylów: -Brak: Nie zostanie zatwierdzona żadna tabela stylu. -Monochrome: wszystkie linie zostaną wydrukowane na czarno. -Nowy: Tworzy nową tabelę stylów wydruku. 4. Wybierz Zapisz zmiany i kliknij Zastosuj dla układu. 
 Aby zmodyfikować tabele stylów wydruku: 1. Wybierz:  Wersja ENG: File > Plot Wersja PL: Plik > Drukuj 2. W tabelach stylów, kliknij na tabelę stylów, którą chcesz edytować i kliknij przycisk edytora tabel stylów wydruku. 3. Kliknij na zakładkę Ogólne, możesz wykonać następujące czynności: -Wprowadź nowy opis stylu wydruku, -Zaznacz opcję Zastosuj globalny współczynnik skali dla rodzajów linii nie-ISO. -Wprowadź współczynnik skali, który ma zostać zastosowany. 4. Kliknij na zakładkę Formularza, możesz wykonać następujące czynności:  -Dokonaj zmiany w stylach wydruku zależnych od kolory, poprzez zaznaczenie odpowiedniej opcji na liście wydruku i określenie koloru, typu linii lub szerokości linii. Zmiany zostaną zapisane automatycznie dla zaznaczonego stylu. -Dokonaj zmian w nazwanych stylach wydruku, wybierając odpowiednią opcję z listy wydruku i określenie koloru, typu linii lub szerokości linii. Zmiany zostaną zapisane automatycznie dla zaznaczonego stylu. -Dodaj nowy styl wydruku, wprowadź jego nazwę i określ żądane parametry. -Usuń dowolny styl wydruku, wybierając go z listy i klikając Usuń styl. 5. Kliknij OK.  
 
 
12.2.10. Drukowanie plików do innych formatów  Pliki wydruku mają rożne format. Możesz utworzyć plik wydruku w każdym formacie obrazu dzięki unikalnemu sterownikowi wirtualnej drukarki.  
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12.2.11. Publikowanie rysunku  Możesz opublikować utworzony rysunek, ustawiaj wysyłając go do drukarki określonej w ustawieniach strony aby go wydrukować lub zapisać do pliku. Możesz skorzystać też z opcji publikowania. W oknie dialogowym publikowania znajdują się następujące opcje:
1. Przycisk wczytywania listy arkuszy: Powoduje wyświetlenie okna dialogowego, za pomocą którego możesz wybrać plik DSD lub BP3 do wczytania. 2. Przycisk zapisu: Powoduje wyświetlenie okno dialogowe pozwalające na zapisanie listy arkuszy. 3. Lista arkuszy: Wyświetla zawartość aktualnie wczytanego pliku. 4. Publikuj do: Określa sposób publikacji listy arkuszy. 5. Automatyczne wczytanie wszystkich otwieranych rysunków: Gdy opcja jest zaznaczona, wszystkie otwarte dokumenty zostają automatycznie dodane do listy. 6. Przycisk dodania arkusza: Pozwala na dodanie nowego arkusza do listy. 7. Przycisku usuwania arkusza: Pozwala na usunięcie arkusza z listy. 8. Przycisk przesunięcia arkusza w gorę listy: Pozwala na określenie miejsca arkusza na liście.  9. Przycisk przesunięcia arkusza w dół listy: Pozwala na określenie miejsca arkusza na liście. 10. Przycisk podglądu: Otwiera podgląd rysunku, w taki sam sposób jak podgląd wydruku rysunku. 

11. Nazwa arkusza: Łączy nazwę rysunku, z nazwą układu, oddzielając je myślnikiem. 
12. 3D DWF: Wyświetla nazwę ustawienia strony dla arkusza. Możesz zmienić ustawienia strony klikając na ich nazwę i zaznaczając inne ustawienia z listy. 13. Stan: Określa stan wczytanych arkuszy.  14/15. Pokaż lub ukryj szczegóły: Pozwala na ukrycie szczegółowych informacji o arkuszu. 16. Opcje publikowania: Otwiera okno dialogowe opcji publikowania. 17. Liczba kopii: Pozwala na określenie liczby kopii do opublikowania. 

18. Dokładność: Pozwala na określenie dokładności. 
19. Dodaj znak wydruku umieszczony w jednym z narożników rysunku: Dodaje określony znak wodny. 20. Przycisk ustawie wydruku: Otwiera okno dialogowe ustawie wydruku. 21. Publikuj w tle: Pozwala na publikowanie w tle zaznaczonych arkuszy. 22. Przesyłanie arkuszy w odwrotnej kolejności: Odwraca kolejność przesyłania arkuszy. 23. Po zakończeniu otwórz w przeglądarce: Po zakończeniu publikacji, pliki zostaną wyświetlone w przeglądarce.   
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13. Tworzenia i edycja bloków dynamicznych
W programie GstarCAD 2016, możesz tworzyć i edytować bloki dynamiczne. Odnośniki do bloku dynamicznego zawierają uchwyty lub właściwości pozwalające na ich edycję. Zmiany wykorzystaniu. Bloki dynamiczne pozwalają na zmianę kształtu, wielkości lub konfigurację wstawionego bloku, zamiast wstawiania wielu statycznych, pojedynczych bloków.
Niektóre bloki dynamiczne są zdefiniowanniektórych wielkości określonych w definicji bloku. Gdy używasz uchwytów, pozwalają one na dokonywanie zmian tylko w zakresie zdefiniowanym w ustawieniach bloku. Jeżeli wartość zmienidopuszczalnych, zostanie automatycznie zaokrąglona do najbliższej prawidłowej.
13.1. Edytor bloków dynamicznych
Aby otworzyć edytor bloków dynamicznych uzawierający parametrów.  Interfejs wstążkowy edycji bloków przedstawiono poniżej. Znaki czarnych strzałek pozwalają na zmianę miejsca zmiany parametrów, a żółte błyskawice symbolizują działania. Jeśli korzystasz z interfejsu kskorzystaj z rozwijalnego paska narzędzi. 

 
 
 
13.1.1. Panele edytora bloków dynamicznychSkorzystaj z poniższych narzędzi, aby w szybki i łatwy sposób określić, edytować i modyfikować bloki dynamiczne.
Zarządzaj Zapisuj lub zapisuj jako; Twórz lub edytuj kolejny blok.      

13. Tworzenia i edycja bloków dynamicznych 

130 

13. Tworzenia i edycja bloków dynamicznych 
W programie GstarCAD 2016, możesz tworzyć i edytować bloki dynamiczne. Odnośniki do bloku dynamicznego zawierają uchwyty lub właściwości pozwalające na ich edycję. Zmiany nimi wywołane będą wyświetlane na rysunku po ich wykorzystaniu. Bloki dynamiczne pozwalają na zmianę kształtu, wielkości lub konfigurację wstawionego bloku, zamiast wstawiania wielu statycznych, pojedynczych bloków. 
Niektóre bloki dynamiczne są zdefiniowane w taki sposób, że geometria w bloku może być edytowana tylko w obrębie niektórych wielkości określonych w definicji bloku. Gdy używasz uchwytów, pozwalają one na dokonywanie zmian tylko w zakresie zdefiniowanym w ustawieniach bloku. Jeżeli wartość zmienianego parametru przekroczy zakres wartości dopuszczalnych, zostanie automatycznie zaokrąglona do najbliższej prawidłowej. 
13.1. Edytor bloków dynamicznych 
Aby otworzyć edytor bloków dynamicznych użyj polecenia EDIT lub klikając dwukrotnie lewym przyciskiem myszy na blok nie Interfejs wstążkowy edycji bloków przedstawiono poniżej. Znaki czarnych strzałek pozwalają na zmianę miejsca zmiany parametrów, a żółte błyskawice symbolizują działania. Jeśli korzystasz z interfejsu kskorzystaj z rozwijalnego paska narzędzi.  

13.1.1. Panele edytora bloków dynamicznych Skorzystaj z poniższych narzędzi, aby w szybki i łatwy sposób określić, edytować i modyfikować bloki dynamiczne.

edytuj kolejny blok.  Narzędzia Zdefiniuj, edytuj lub zaktualizuj atrybuty bloku.      

 

W programie GstarCAD 2016, możesz tworzyć i edytować bloki dynamiczne. Odnośniki do bloku dynamicznego zawierają nimi wywołane będą wyświetlane na rysunku po ich wykorzystaniu. Bloki dynamiczne pozwalają na zmianę kształtu, wielkości lub konfigurację wstawionego bloku, zamiast 

e być edytowana tylko w obrębie niektórych wielkości określonych w definicji bloku. Gdy używasz uchwytów, pozwalają one na dokonywanie zmian tylko w anego parametru przekroczy zakres wartości 

przyciskiem myszy na blok nie Interfejs wstążkowy edycji bloków przedstawiono poniżej. Znaki czarnych strzałek pozwalają na zmianę miejsca zmiany parametrów, a żółte błyskawice symbolizują działania. Jeśli korzystasz z interfejsu klasycznego, 

Skorzystaj z poniższych narzędzi, aby w szybki i łatwy sposób określić, edytować i modyfikować bloki dynamiczne. 

lub zaktualizuj atrybuty bloku. 
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Parametry W tym panelu możesz dodać parametry bloków dynamicznych. 

  Operacja W tym panelu możesz dodać akcję modelu dynamicznego. 

  Zestawy parametrów W tym panelu możesz dodawać zestawy parametrów. 

  

 Widoczność Ten panel służy do ustawień związanych z widocznością. 

  Zamknij edytor bloków Powoduje zamknięcie edytora bloków.  

 
 

 
 
 
13.1.2 Parametry  Zmieniaj właściwości bloków dynamicznych przez określenie ich pozycji, odległości i kąta. Możesz dodawać parametry do bloków dynamicznych w edytorze bloków. Parametry pozycji, odległości i kąta geometrii są również określane w referencjach bloku. Gdy dodasz parametr do definicji bloku dynamicznego, parametr ten określi jedną lub więcej właściwości bloku. 
Definicja bloku dynamicznego musi zawierać co najmniej jeden parametr. Gdy parametr zostanie dodany, kluczowe punkty bloku automatycznie zostaną powiązane odpowiednimi uchwytami. Konieczne jest dodanie operacji do definicji bloku i powiązanie jej z parametrem. 
Parametry definiują też i zawierają wartości, które wpływają na zachowanie bloków dynamicznych na rysunku. Niektóre parametry mogą mieć stały zbiór wartości, wartości minimalne i maksymalne lub przyrost wartości. Na przykład, liniowy parametr używany w obiekcie bloku może mieć następujący zbiór wartości: 10, 20, 30 i 40. Gdy odniesienie do bloku jest wstawione do rysunku, możesz zmieniać wartości tego obiekty tylko w obrębie tych wartości. Dodanie nowego zbiory wartości pozwoli na wprowadzanie innych wartości. 
 
Parametr punktowy 

Ikona:  Polecenie: BParameter→O 
Definiuje położenie X i Y na rysunku. Może być powiązany z działaniem ruchu lub rozciągania. 

Parametr liniowy 
Ikona:  Polecenie: BParameter→L 
Pokazuje odległość pomiędzy dwoma zakotwiczonymi punktami. Ogranicza ruch uchwytu do zadanego kąta. Może być powiązany z ruchem, odcinkami, skalą lub operacjami szyku.
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Parametr biegunowy 

Ikona:  Polecenie: BParameter→P 
Pokazuje odległość pomiędzy dwoma zakotwiczonymi punktami i wartość kąta. Możesz użyć obydwu uchwytów i palety właściwości aby zmienić wartości odległości i kąta. Może być powiązany z ruchem, odcinkami, skalą lub operacjami szyku. 
Parametr XY 

Ikona:  Polecenie: BParameter→X 
Pokazuje odległości X i Y z punktu bazowego parametru. Może być powiązany z ruchem, odcinkami, skalą lub operacjami szyku.  Parametr obrotu 

Ikona:  Polecenie: BParameter→R 
Określa kąt. Kąt obrotu może być dowolną wartością, określonym zakresem lub wartością określoną. 
Parametr wyrównania 

Ikona:  Polecenie: BParameter→A 
Pokazuje odległości X i Y z punktu bazowego parametru oraz kąt. Parametr wyrównania zawsze zostaje zastosowany do całego bloku i wymaga powiązanej z tym operacji. Pozwala na automatyczny obrót bloku wokół punktu aby wyrównać do innego obiektu na rysunku. Parametr wpływa na własność obrotu bloku. 

 
Parametr odwrócenia 

Ikona:  Polecenie: BParameter→F 
Powoduje odwrócenie obiektów. Możesz powiązać ten parametr z operacją odwrócenia. 
Parametr widoczności 

Ikona:  Polecenie: BParameter→V 
Kontroluje widoczność bloku na rysunku. Parametr ten zawsze zostaje zastosowany do całego bloku i wymaga powiązania z odpowiednią operacją. Kliknij uchwyty na rysunku aby wyświetlić listę stanu widoczności dostępnych dla odnośnika bloku. 
Parametr przeglądania 

Ikona:  Polecenie: BParameter→K 
Parametr przeglądania pozwala na określenie lub ustawienie, czy ocenianą wartość z listy lub tabel można zdefiniować. Może zostać powiązany z odpowiednim uchwytem w bloku. Kliknij na uchwyt odnośnika do bloku, aby wyświetlić listę dostępnych wartości. Parametr może zostać powiązany z tą operacją. 
Parametr punktu bazowego 

Ikona:  Polecenie: BParameter→B 
Definiuje punkt bazowy odnośnika bloku dynamicznego, powiązany z jego geometrią. Nie można go powiązać z żadną operacją lecz może należeć do zestawu wybranych operacji. 

 
 
13.1.3 Akcje  Definiują w jaki sposób zmienia się geometria odnośnika bloku dynamicznego podczas zmiany jego właściwości na rysunku. 

Ruch  Polecenie: BActionTool→M Operacja ta powoduje przesunięcie wszystkich zaznaczonych obiektów o określoną odległość i kąt, w wybranym kierunku. 
 

Skala  Polecenie: BActionTool→S Operacje skali, takie jak parametr liniowy, biegunowy i XY, jak i skale zaznaczonych obiektów w kierunku parametru. Możesz zmieniać wartości i właściwości za pomocą odpowiednich uchwytów lub z poziomu palety właściwości. 
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Rozciąganie  Polecenie: BActionTool→T Operacja rozciągania powoduje przesunięcie oraz rozciągniecie obiektu o określoną odległość w określonym miejscu. Może zostać powiązana z punktem lub parametrem liniowym, biegunowym czy XY. 

Rozciągnięcie biegunowe  Polecenie: BParameter→PIn Rozciągnięcie biegunowe obraca, przesuwa i rozciąga obiekt o określony kąt i odległość, gdy kluczowy punkt powiązanego parametru biegunowego zostaje zmieniony za pomocą powiązanego uchwytu lub palety właściwości. Rozciąganie biegunowe może być zastosowane jedynie dla parametru biegunowego. 

Obrót  Polecenie: BActionTool→P Operacja obrotu zawsze powiązana jest z parametrem obrotu. Zaznaczony obiekt może być obracany dowolnie 

za pomocą odpowiedniego uchwytu lub z poziomu palety właściwości. 

Odwróć  Polecenie: BActionTool→F Operacja odwróć jest zawsze powiązana z parametrem odwrócenia. 

Szyk  polecenie: BActionTool→A Operacja szyku powiązana jest z parametrami liniowymi, biegunowymi i XY. Kopiuje i ustawia w szyku zaznaczone obiekty. 

Przeglądanie  Polecenie: BActionTool→L Operacja przeglądania może zostać powiązana wyłącznie parametrem przeglądania. 

 
13.1.4. Podstawowe kroki do utworzenia definicji bloku dynamicznego  W celu uzyskania definicji bloku dynamicznego, poprawienia wydajności edycji bloku i uniknięcia powtarzających się modyfikacji, można utworzyć blok dynamiczny wykonując następujące kroki.
Krok 1: Planowanie Istotną rzeczą przed utworzeniem bloku dynamicznego jest jego zaplanowanie. Zaplanuj funkcje wyglądu, sposobu rysowania oraz wymaganych parametrów i operacji, które są potrzebne do osiągnięcia żądanego efektu. 
Krok 2: Rysowanie figury geometrycznej Rysowanie dynamiczne odbywa się za pomocą standardowych 

pikseli, oczywiście możliwe jest rysowanie w edytorze bloków. 
Krok 3: Dodawanie parametrów i operacji Jest to kluczowy krok w tworzeniu bloku dynamicznego. Podczas edycji parametrów i operacji należy zwrócić uwagę nie tylko na osiągnięcie zamierzonego efektu, lecz również na czytelność i wygodę  późniejszych modyfikacji. Załącz punkt operacji parametrów w odpowiednim miejscu, najdalej 

jak to możliwe i wstaw operację najbliżej powiązanego parametru. Jeżeli parametrów i operacji jest więcej, wymagają zmiany nazw aby łatwiej je było edytować. 
Krok 4: Sprawdzenie bloku dynamicznego Zapisanie i opuszczenie edytora rozpoczyna test utworzonego bloku dynamicznego w celu sprawdzenia czy osiągnięty zostanie określony przez użytkownika efekt. 

 
13.2. Przykłady tworzenia bloków dynamicznych 
Zobacz możliwości edytora bloków dynamicznych na poniższych przykładach: 
13.2.1. Parametr punktu bazowego   Większość parametrów daje efekt gdy zostaną dopasowane do odpowiednich działań, mimo to istnieje kilka wyjątków. Jednym z nich jest parametr punktu bazowego. 
1. Zdefiniowanie bloków: Zdefiniuj blok i narysuj okrąg w edytorze bloku, jak na rysunku.  
    



13. Tworzenia i edycja bloków dynamicznych 
 

134  

2. Dodaj punkt bazowy:  Kliknij na parametr punktu bazowego, znajdujący się w panelu parametrów. Wstaw go w punkcie środka okręgu zgodnie z informacjami w wierszu poleceń, tak jak poniżej. 
         3. Wstaw blok:  Zapisz i opuść edytor bloku, wstaw blok w obszarze modelu. Punkt bazowy staje się punktem wstawienia bloku. Pamiętaj, że jeżeli określisz punkt wstawienia za pomocą okna dialogowego definicji bloku a następnie dodasz parametr punktu bazowego, ten drugi będzie domyślnym punktem wstawienia.  
13.2.2. Widoczność Skorzystaj z funkcji parametru widoczność, aby kontrolować wyświetlanie i ukrywanie pewnych widoków bloku dynamicznego. 
1. Przygotowanie widoku:  Przygotujmy trzy widoki samochodów i zdefiniujmy jako blok. 
 
               2. Dodawanie parametru widoczności:  Dodajmy parametr widoczności, klikając dwukrotnie na strzałki lub klikając prawym przyciskiem myszy na menu i wybierając przycisk parametru widoczności w panelu parametrów. Następnie wskażmy położenie parametru zależnie od informacji w wierszu poleceń. 
 
3. Edycja stanu widoczności:  Kliknij dwukrotnie przycisk widoczności aby otworzyć okno dialogowe. Możesz w nim zmienić nazwę, utworzyć nowy bądź usunąć stan widoczności. W celu kontroli widoczności widoku samochodów z przykładu, utwórzmy dla nich nowy stan widoczności, jak przedstawiono na rysunku.  
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Kliknij na następujący przycisk, tak jak na rysunku i wybierz Roadster z menu rozwijalnego. 

 
Kliknij przycisk niewidzialności w panelu narzędzi widoczności, zaznacz truck i car aby stały się niewidoczne w stanie nazwanym Roadster i naciśnij klawisz Enter aby potwierdzić. Postąp analogicznie w przypadku pozostałych dwóch stanów.  
   4. Przesuwanie i regulowanie:  Po zakończeniu edycji stanów widzialności, przesuń samochody jeden na drugi, tak jak na rysunku poniżej. 
 
 
 
   5. Sprawdzenie bloku dynamicznego: Wstaw edytowany blok dynamiczny do rysunku, zaznacz blok dynamiczny i kliknij na uchwyt parametru widoczności, wybierz jedną z opcji z listy menu rozwijalnego. Zmiany stanu widoczności bloku dynamicznego zostaną zmienione automatycznie, tak jak na rysunku poniżej.                   
 
 
13.2.3. Wyrównanie Parametr ten pozwala na wykorzystanie funkcji automatycznego wyrównania boku dynamicznego, który może zapisać etap obrotu bloków. 
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1. Dodawanie parametru wyrównania do symbolu chropowatości:Narysujmy symbol chropowatości w edytorze bloku. Zaznaczmy ikonę parametru wyrównania. Następnie określmy położenie i orientację wyrównania, program wyświetli przerywaną linię wskazującą orientację wyrównania.
 2. Sprawdzenie bloku dynamicznego:Wstawmy blok dynamiczny symbolu, przesuńmyinterfejsu, tak jak pokazano na rysunku. 
  Odwrócenie: Gdy używasz bloku symbolu chropowatości jako etykiety części sfery, symbol może zostać wstawiony w odpowiednim miejscu lecz mieć zły zwrot. aby otrzymać właściwie usytuowaną etykietę.
1. Dodawanie parametru obrotu:  Kliknij na przycisk parametru obrotu, aby dodać parametr zgodnie z informacjami w wierszu poleceń. 
 
 
2. Dodawanie operacji odwrócenia:  Kliknij na przycisk operacji odwrócenia, dopasuj parametr i obiekt do operacji. Tak jak pokazano poniżej.
  

 
13.2.4. Ruch punktu 
1. Narysujmy rysunek: Narysujmy rysunek i zdefiniujmy go jako blok.    2. Dodajmy parametr punktu:  
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1. Dodawanie parametru wyrównania do symbolu chropowatości: edytorze bloku. Zaznaczmy ikonę parametru wyrównania. Następnie określmy położenie i orientację wyrównania, program wyświetli przerywaną linię wskazującą orientację wyrównania.  
2. Sprawdzenie bloku dynamicznego: Wstawmy blok dynamiczny symbolu, przesuńmy uchwyt wyrównania, symbol zostanie wyrównany zgodnie z wymiarami   

Gdy używasz bloku symbolu chropowatości jako etykiety części sfery, symbol może zostać wstawiony w odpowiednim miejscu lecz mieć zły zwrot. Możemy dodać funkcję odwrócenia aby otrzymać właściwie usytuowaną etykietę. 

na przycisk parametru obrotu, aby dodać parametr zgodnie z 

Kliknij na przycisk operacji odwrócenia, dopasuj parametr i obiekt do operacji. Tak jak pokazano poniżej.

Użyj tej samej metody aby dodać parametr odwrócenia i operację dla kierunku pionowego:       

Narysujmy rysunek i zdefiniujmy go jako blok.  

 

edytorze bloku. Zaznaczmy ikonę parametru wyrównania. Następnie określmy położenie 

uchwyt wyrównania, symbol zostanie wyrównany zgodnie z wymiarami 

Gdy używasz bloku symbolu chropowatości jako etykiety części sfery, symbol może zostać wstawiony w 

Kliknij na przycisk operacji odwrócenia, dopasuj parametr i obiekt do operacji. Tak jak pokazano poniżej.  

metody aby dodać parametr odwrócenia i operację dla kierunku 
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Kliknijmy na parametr punku znajdujący się w pasku w wierszu poleceń.  
 
 3. Dodajmy operację ruchu: Kliknijmy przycisk operacji ruchu na panelu operacji, dopasujmy parametr i obiekt do operacji i zdefiniujmy położenie. Położenie etykiety operacji nie wpływa na efekt działania bloku dynamicznego, jednak aby zachować wygodę i estetykę, spróbuj wstawić ją blisko powiązanego parametru.  
 
 
 
 4. Sprawdźmy blok dynamiczny:  Wstawmy blok dynamiczny, przeciągnijmy niebieski uchwyt i przesuńmy odpowiednio w prawą stronę, tak jak pokazano na rysunku. Oczywiście, oczywiście ten sam efekt można osiągnąć korzystając z bloku dynamicznego. Upewnijmy się, że tryb ORTO nie jest aktywny. Wpust może zostać przesunięty w dowolnym kierunku, ponieważ kierunek parametru punktu jest losowy a jego działaniu decyduje charakterystyczny parametr.     
13.2.5. Ruch liniowy Ponieważ wpust pozwala jedynie na poziomej. Skorzystamy z liniowego parametru aby określić kierunek ruchu wpustu na linii centralnej wału. 
1. Rysowanie: Narysuj następujący rysunek i zdefiniuj go jako blok.
  2. Dodawanie parametru liniowego:  Aby dodać parametr liniowy jest podobne do dodawania wymiaru, wstawabsorpcji parametru na linii centralnej wału.
3. Dodawanie operacji ruchu:  W przeciwieństwie do ruchu punktu, po określeniu parametru, program wyświetli w wierszu poleceń komunikat: Określony parametr jest powiązany z ruchem. Zaznacz właściwy uchwyt parametru jako "Powiązany parametr punktu".
 Wspomniany parametr punktu odpowiada działaniu punktu ruchu. Po opuszczeniu edytora bloku, możesz przeciągnąć ten punkt, aby odpowiednio zmienić blok dynamiczny. Po zaznaczeniu powiązanego parametru punktu, określ przesunięcie obiektów dla operacji. Umieść etykietę operacji, a następnie zapisz i opuść blok dynamiczny.
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Kliknijmy na parametr punku znajdujący się w pasku narzędziowym, zdefiniujmy położenie parametru zależnie od informacji 

Kliknijmy przycisk operacji ruchu na panelu operacji, dopasujmy parametr i obiekt do operacji i zdefiniujmy y operacji nie wpływa na efekt działania bloku dynamicznego, jednak aby zachować wygodę i estetykę, spróbuj wstawić ją blisko powiązanego 

Wstawmy blok dynamiczny, przeciągnijmy niebieski uchwyt i przesuńmy wpust odpowiednio w prawą stronę, tak jak pokazano na rysunku. Oczywiście, oczywiście ten sam efekt można osiągnąć korzystając z bloku dynamicznego. Upewnijmy się, że tryb ORTO nie jest aktywny. Wpust może zostać przesunięty w dowolnym kierunku, ierunek parametru punktu jest losowy a jego działaniu decyduje 

Ponieważ wpust pozwala jedynie na umiejscowienie go na linii centralnej, wystarczający będzie ruch w płaszczyźnie liniowego parametru aby określić kierunek ruchu wpustu 

Narysuj następujący rysunek i zdefiniuj go jako blok.  

 Aby dodać parametr liniowy jest podobne do dodawania wymiaru, wstaw punkt absorpcji parametru na linii centralnej wału.  

W przeciwieństwie do ruchu punktu, po określeniu parametru, program wyświetli w wierszu poleceń komunikat: Określony parametr jest powiązany 
parametru jako "Powiązany parametr punktu". 

Wspomniany parametr punktu odpowiada działaniu punktu ruchu. Po opuszczeniu edytora bloku, możesz przeciągnąć ten punkt, aby odpowiednio zmienić blok dynamiczny. Po zaznaczeniu powiązanego określ przesunięcie obiektów dla operacji. Umieść etykietę operacji, a następnie zapisz i opuść blok dynamiczny.  

 
narzędziowym, zdefiniujmy położenie parametru zależnie od informacji 

umiejscowienie go na linii centralnej, wystarczający będzie ruch w płaszczyźnie 
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4 .Sprawdzenie bloku dynamicznego:Zaznacz blok dynamiczny i przeciągnij odpowiedni uchwyt parametru. Nie ma znaczenia w jaki sposób przesuwa się kursor, ruch wpustu jest ograniczony linią centralną wału. Dzięki temu wpust można przesuwać jedynie zgodnie z kierunkiem określonego parametru liniowego.
 
13.2.6. Liczba uchwytów  W edytorze bloku, zaznacz parametr liniowy, zmień liczbę uchwytów na wartość 1 w panelu właściwości.        Zapisz i opuść edytor bloku, wybierz blok dynamiczny. Możesz zauważyć, że jeden uchwyt zniknął. W rzeczywistości, po zmianie liczby uchwytów z 2 na 1 zniknął podstawowy uchwyt odpowiadający punktowi pierwszego dodanego parametru.  
 
13.2.7. Kąt odsunięcia  Otwórz edytor bloku, wybierz kąt odsunięcia z przedziału od 0°do 30°we właściwościach operacji, zapisz i opuść edytor bloków.  
 
 
Zaznacz blok dynamiczny i przesuń prawy uchwyt. Zauważ, że możesz poruszać się jedynie w zakresie do 30°. Kierunek operacji może zostać zmieniony zależnie od ustawień odsunięcia kąta.
  
13.2.8. Rozciągnięcie liniowe Podczas projektowania mechanicznego, często występuje możliwość dodania funkcji liniowego rozciągnięcia dla wpustu umieszczonego w wale.
1. Dodawanie parametru liniowego:  
  2. Dodawanie operacji rozciągania:  Kliknij na przycisk operacji rozciągania w panelu operacji, wybierz parametr zależnie od informacji w wierszu poleceń i zdefiniuj prawy uchwyt jako kluczowy parametr punktu. Obiekt bloku jest obiektem operowalnym działania, przerwana linia ramki jest ramką rozciągnięcia, obiekty które zostaną zaznaczone przez nią zostaną przesunięte. 
3. Sprawdzenie bloku dynamicznego:Opuść edytor bloku, przeciągnij uchwyt rozciągania wpustu. 
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4 .Sprawdzenie bloku dynamicznego: Zaznacz blok dynamiczny i przeciągnij odpowiedni uchwyt parametru. Nie przesuwa się kursor, ruch wpustu jest ograniczony linią centralną wału. Dzięki temu wpust można przesuwać jedynie zgodnie z kierunkiem określonego parametru liniowego.  

W edytorze bloku, zaznacz parametr liniowy, zmień liczbę uchwytów na wartość 1 w panelu właściwości.  

Zapisz i opuść edytor bloku, wybierz blok dynamiczny. Możesz zauważyć, że jeden uchwyt zniknął. W rzeczywistości, po zmianie liczby na 1 zniknął podstawowy uchwyt odpowiadający punktowi 

Otwórz edytor bloku, wybierz kąt odsunięcia z przedziału od we właściwościach operacji, zapisz i opuść edytor 

dynamiczny i przesuń prawy uchwyt. Zauważ, że możesz poruszać się jedynie w zakresie do 30°. Kierunek operacji może zostać zmieniony zależnie od ustawień odsunięcia kąta. 

Podczas projektowania mechanicznego, często występuje potrzeba zmiany położenia, a także wymiaru wpustu. Istnieje możliwość dodania funkcji liniowego rozciągnięcia dla wpustu umieszczonego w wale. 
 

Kliknij na przycisk operacji rozciągania w panelu operacji, wybierz parametr zależnie od informacji w wierszu poleceń i zdefiniuj prawy uchwyt jako kluczowy parametr punktu. Obiekt bloku jest obiektem nia, przerwana linia ramki jest ramką rozciągnięcia, obiekty które zostaną zaznaczone przez nią zostaną 

3. Sprawdzenie bloku dynamicznego: Opuść edytor bloku, przeciągnij uchwyt rozciągania wpustu.  

 

potrzeba zmiany położenia, a także wymiaru wpustu. Istnieje 
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13.2.9. Parametr zestawu wartości Dla projektowania mechanicznego, często wymagane jest rozciągnięcie wpustu do pewnej długości. W tym przykładzie pokażemy w jaki sposob wykonywać precyzyjne rozciąganie. Wybierz parametr liniowy wramki, która znajduje się po prawej stronie w opcji typu odległości w panelu właściwości, spowoduje to rozwinięcie menu kontekstowego. 
Jest to opcja dodatkowa, nie wymagana domyślnie. Możesz zdefiniować maksymalną i minimalną wartość za pomocą odpowiednio dwóch punktów.
 
"Przyrost" oznacza zwiększanie odległości w czasie rozciągania, zestaw wartości pojawia się po zaznaczeniu przyrostu. Jeżeli wybierzesz opcje lista, zestaw wartości zostanie wyświetlony. Blok dynamiczny może być rozszerzany tylko o wartość stosowną do wartości z listy.  
Kliknij na pole tekstowe, które znajduje się po prawej stronie listy wartości odległości, pojawi się przycisk z wielokropkiem. Kliknij na niego aby wyświetlić okno dialogowe. Dodaj w nim trzy liczby "1", "1.5", "2".
Opuść edytor bloku i rozciągnij obiekt za pomocą właściwego uchwytu, zaobserwujesz kilka szarych linii, które pojawią się po jednej ze stron wpustu. Wskazują one jak bardzo wpust może zostać rozciągnięty. Możesz zmienić dostępny zakres zmieniając odpowiednio wartości na liście. 
       
13.2.10. Symetryczne rozciąganie Jest łatwe do utworzenia z wykorzystaniem dwóch operacji 
rozciągania. Wymagają one kilku dodatkowych opcji:
-Po pierwsze, należy dodać dwie operacje rozciągania do parametru i zaznaczyć dwa uchwyty dla dwóch punktem obu operacji. -Po drugie, należy zmodyfikować położenie bazowe z punktu początkowego na punkt środkowy. Następnie zapisz i opuść edytor bloku.  
Dla wygody śledzenia efektu działania bloku, zostanie narysowana dodatkowo piolinia centralna, przechodząca przez środek wpustu a uchwyt rozciągania po jego lewej lub prawej stronie. Gdy uchwyt jest przesuwany, zostaje symetrycznie rozciągany po obu stronach.        
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Dla projektowania mechanicznego, często wymagane jest rozciągnięcie wpustu do pewnej długości. W tym przykładzie precyzyjne rozciąganie. Wybierz parametr liniowy w edytorze bloku, kliknij wewnątrz po prawej stronie w opcji typu odległości w panelu właściwości, spowoduje 

Jest to opcja dodatkowa, nie wymagana domyślnie. Możesz zdefiniować maksymalną i minimalną wartość za pomocą odpowiednio dwóch punktów. 

"Przyrost" oznacza zwiększanie odległości w czasie rozciągania, zestaw wartości pojawia się po zaznaczeniu przyrostu. Jeżeli wybierzesz opcje lista, zestaw wartości zostanie wyświetlony. Blok dynamiczny może być rozszerzany tylko o 

Kliknij na pole tekstowe, które znajduje się po prawej stronie listy wartości odległości, pojawi się przycisk z wielokropkiem. Kliknij na niego aby wyświetlić okno dialogowe. Dodaj w nim trzy liczby "1", "1.5", "2". 
ciągnij obiekt za pomocą właściwego uchwytu, zaobserwujesz kilka szarych linii, które pojawią się po jednej ze stron wpustu. Wskazują one jak bardzo wpust może zostać rozciągnięty. Możesz zmienić dostępny zakres zmieniając odpowiednio wartości 

Jest łatwe do utworzenia z wykorzystaniem dwóch operacji 
Wymagają one kilku dodatkowych opcji: 

Po pierwsze, należy dodać dwie operacje rozciągania do parametru i zaznaczyć dwa uchwyty dla dwóch parametrów powiązanych z 
Po drugie, należy zmodyfikować położenie bazowe z punktu początkowego na punkt środkowy. Następnie zapisz i opuść edytor 

Dla wygody śledzenia efektu działania bloku, zostanie narysowana dodatkowo pionowa linia centralna, przechodząca przez środek wpustu a uchwyt rozciągania po jego lewej lub prawej stronie. Gdy uchwyt jest przesuwany, zostaje symetrycznie rozciągany po obu 

 

Dla projektowania mechanicznego, często wymagane jest rozciągnięcie wpustu do pewnej długości. W tym przykładzie edytorze bloku, kliknij wewnątrz 
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13.2.11. Mnożnik odległości Do przykładu wykorzystamy wał, jeżeli rozciągniemy lewą częśćbędzie się znajdował w punkcie środkowym o mniejszej średnicy wału po rozszerzeniu. Następnie zastosujemy właściwości mnożnika odległości aby operacja osiągnęła swój cel.  
   1. Dodaj parametr liniowy i operację rozciągania dla wału:  Ukryj właściwy uchwyt parametru punktu, oknorozszerzenia pokazane jest na rysunku,jest obiektem działającej operacji.  
 
 
2. Dodaj operację ruchu do wpustu:  Zaznacz lewy uchwyt parametru liniowego przesuwania i rozciągania powiązanego parametru punktu. Przesuń obiekt operacji i zaznacz cały wpust.
 
3. Zmodyfikuj mnożnik odległości operacji:Zaznacz operację ruchu i zmodyfikuj domyślną wartość z 1 do 0.5 we właściwościach mnożnika odległościopuść edytor bloku. 
 
 
4.Śprawdź blok dynamiczny:  Przeciągnij uchwyt rozciągania w lewą stronę mniejsza średnica wału pojawi się wraz z efektem działania operacji rozciągania, wpust również zostanie przesunięty w lewą stronę, pozostając tym samnajmniejszej średnicy wału. Mimo, że rozciągnie i przesuwanie posiadają wspólny parametr, to gdy wartość mnożnika odległości zostaje zmieniony na 0.5, przemieszczenie może zostać rozciągnięte tylko półkrotnie.
13.2.12. Akcja łańcuchowa Jeżeli chcesz wykonać  jednocześnie symetryczne rozciąganie zmieniając długość najmniejszej średnicy wału bez zmiany położenia wpustu, wykonaj poniższe kroki:
1. Dodaj rozciąganie do wału:  Dodaj parametr rozciągania oraz operację do Pogrubione obiekty zawierają obiekty podlegające działaniu operacji. Ponieważ operacja nie spowoduje rozciągnięcia wału za pomocą uchwytów parametru liniowego, ich wartości mogą zostać zmienione na 0.
2. Dodaj parametr liniowy da wpustu:Ustaw pozycję punktu bazowego parametru liniowego jako centrum aby zrealizować funkcję symetrycznego rozciągania.
3. Dodaj operacje rozciągania prawostronnego dla wpustu i realizację operacji łańcuchowej: 
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jeżeli rozciągniemy lewą część wału, wpust nadal będzie się znajdował w punkcie środkowym o mniejszej średnicy wału po rozszerzeniu. Następnie zastosujemy właściwości mnożnika odległości aby operacja osiągnęła swój 

rację rozciągania dla 
Ukryj właściwy uchwyt parametru punktu, okno operacji rozszerzenia pokazane jest na rysunku, pogrubiony obiekt 

Zaznacz lewy uchwyt parametru liniowego podczas przesuwania i rozciągania powiązanego parametru punktu. Przesuń obiekt operacji i zaznacz cały wpust. 

3. Zmodyfikuj mnożnik odległości operacji: Zaznacz operację ruchu i zmodyfikuj domyślną wartość z 1 do 0.5 we właściwościach mnożnika odległości, zapisz i 

Przeciągnij uchwyt rozciągania w lewą stronę mniejsza średnica wału pojawi się wraz z efektem działania operacji rozciągania, wpust również zostanie przesunięty w lewą stronę, pozostając tym samym zawsze w punkcie środkowym najmniejszej średnicy wału. Mimo, że rozciągnie i przesuwanie posiadają wspólny parametr, to gdy wartość mnożnika odległości zostaje zmieniony na 0.5, przemieszczenie może zostać rozciągnięte tylko półkrotnie. 

jednocześnie symetryczne rozciąganie zmieniając długość najmniejszej średnicy wału bez zmiany położenia wpustu, wykonaj poniższe kroki: 

Dodaj parametr rozciągania oraz operację do narysowanego wału. Pogrubione obiekty zawierają obiekty podlegające działaniu operacji. Ponieważ operacja nie spowoduje rozciągnięcia wału za pomocą uchwytów parametru liniowego, ich wartości mogą zostać zmienione na 0. 
: Ustaw pozycję punktu bazowego parametru liniowego jako centrum aby zrealizować funkcję symetrycznego rozciągania.  

3. Dodaj operacje rozciągania prawostronnego dla wpustu 

 

jednocześnie symetryczne rozciąganie zmieniając długość najmniejszej średnicy wału bez zmiany 
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Zaznacz opcję odległości parametru liniowego ina rysunku:  
 
 
 
 
 
Dodaj operację rozciągania lewostronnego dla wpustu. Informacja dodatkowa: Zaznacz opcję odległości dla parametru liniowego aby rozciągnąć lewostronnie zestaw obiektów. Jest to konieczna procedura operacji łańcuchowej.  
 4. Sprawdź blok dynamiczny:  Po przeciągnięciu lewego uchwytu, nastąpi jednocześnie symetryczne rozciągnięcie w dwóch kierunkach wału. Działanie to nazywa się operacją łańcuchową. Do realizacji tej procedury należy wykonać dwie ważne procedury:-Po pierwsze, modyfikacja wartości właściwości powiązanego parametru operacji łańcuchowej z "Nie" na "Tak". -Po drugie, zaznaczyć parametr obiektów, wybranych do powiązania z operacją.     
13.2.13. Akcja skali Operacja skali może zostać dopasowana do parametru liniowego, biegunowego i XY, aby osiągnąć rożne efekty dynamiczne. 
Skala liniowa 
1.Narysuj:  Zakończ rysunek otworu rewizyjnego w przestrzeni modelu i zdefiniuj jako blok.
  2. Dodaj parametr liniowy:  Dodaj parametr liniowy za pomocą edytora bloku. Wstaw punkt początkowy w środku okręgu, określ liczbę uchwytów jako 1.           3. Dodaj akcji:  Kliknij ikonę skali w panelu operacji wybierz parametr dla operacji i zaznacz otwór rewizyjny jako obiekt operacji.
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Zaznacz opcję odległości parametru liniowego i zmodyfikuj opcję operacji łańcuchowej z właściwości z "Nie" na "Tak", tak jak 

Dodaj operację rozciągania lewostronnego dla wpustu.  : Zaznacz opcję odległości dla parametru liniowego zestaw obiektów. Jest to konieczna procedura 

Po przeciągnięciu lewego uchwytu, nastąpi jednocześnie symetryczne rozciągnięcie w dwóch kierunkach wału. Działanie to nazywa się operacją lizacji tej procedury należy wykonać dwie ważne procedury: Po pierwsze, modyfikacja wartości właściwości powiązanego parametru 
Po drugie, zaznaczyć parametr obiektów, wybranych do powiązania z 

Operacja skali może zostać dopasowana do parametru liniowego, biegunowego i XY, aby osiągnąć rożne efekty 

Zakończ rysunek otworu rewizyjnego w przestrzeni modelu i zdefiniuj jako blok. 

Dodaj parametr liniowy za pomocą edytora bloku. Wstaw punkt początkowy w środku okręgu, określ liczbę uchwytów 

Kliknij ikonę skali w panelu operacji wybierz parametr dla operacji i rewizyjny jako obiekt operacji.  

 
zmodyfikuj opcję operacji łańcuchowej z właściwości z "Nie" na "Tak", tak jak 

Operacja skali może zostać dopasowana do parametru liniowego, biegunowego i XY, aby osiągnąć rożne efekty 
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   4. Sprawdź blok dynamiczny:  Opuść edytor bloku i wstaw blok dynamiczny, następnie przeciągnij trójkątny uchwyt. Obiekt zostanie przeskalowany.
 
Skala biegunowa 
Podczas przesuwania uchwytu skali otworu przesunięcia punktu bazowego parametru liniowego na lewo od środka okręgu, możesz zaobserwować, że blok nie otrzymuje odpowiedniej skali.
 
Powoduje to punkt końcowy parametru liniowego, ponieważ nie może on przpunktu bazowego. Aby rozwiązać ten problem należy zmienić parametr z liniowego na biegunowy, pozostałe operacje nie wymagają zmiany.
Opuść edytor bloku i przeciągnij uchwyt otworu rewizyjnego ponownie. Zauważ, że po zmianie parametru na biegunowy,skalę bloku dynamicznego w dowolnym kierunku. 
13.2.14. Skala znaku W tym punkcie, objaśnione zostaną niektóre znaki skali używane w parametrze XY i operacji skali. 
1. Rysowanie grafiki:  Narysuj grafikę, która następnie będzie blokiem 
 
      2. Dodawanie parametru XY:  Otwórz edytor bloku, dodaj parametr XY. Dodawanie parametru odbywa sie podobnie jak w przypadku parametru liniowego. Wybierz pierwszy punkt parametru w lewym dolnym wierzchołku górny wierzchołku i zmień liczbę uchwytów na wartość 1. Następnie dodaj operację skali.
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Opuść edytor bloku i wstaw blok dynamiczny, następnie przeciągnij trójkątny uchwyt. Obiekt zostanie przeskalowany. 

Podczas przesuwania uchwytu skali otworu rewizyjnego na lewo od środka okręgu, czyli przesunięcia punktu bazowego parametru liniowego na lewo od środka okręgu, możesz zaobserwować, że blok nie otrzymuje odpowiedniej skali.  

Powoduje to punkt końcowy parametru liniowego, ponieważ nie może on przekroczyć punktu bazowego. Aby rozwiązać ten problem należy zmienić parametr z liniowego na biegunowy, pozostałe operacje nie wymagają zmiany. 
Opuść edytor bloku i przeciągnij uchwyt otworu rewizyjnego ponownie. Zauważ, że po zmianie parametru na biegunowy, możesz przeciągać skalę bloku dynamicznego w dowolnym kierunku.   

W tym punkcie, objaśnione zostaną niektóre znaki skali używane w 

Narysuj grafikę, która następnie będzie blokiem dynamicznym i zdefiniuj ją jako blok. 

Otwórz edytor bloku, dodaj parametr XY. Dodawanie parametru odbywa sie podobnie jak w przypadku parametru liniowego. Wybierz pierwszy punkt parametru w lewym dolnym wierzchołku prostokąta jako punkt bazowy, drugi punkt określ w prawym górny wierzchołku i zmień liczbę uchwytów na wartość 1. Następnie dodaj operację skali. 

 

Otwórz edytor bloku, dodaj parametr XY. Dodawanie parametru odbywa sie podobnie jak w przypadku parametru liniowego. prostokąta jako punkt bazowy, drugi punkt określ w prawym 
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3. Sprawdzenie bloku dynamicznego:Po opuszczeniu edytora bloku, przeciągnij Możesz zobaczyć, że cały blok dynamiczny jest skalowany wraz z przesunięciem uchwytu. Łatwo zauważyć, że skala okręgu i prostokąta zmienia się wraz z punktem bazowym parametru XY.  
 4. Modyfikacja punktu bazowego akcjiAby zmodyfikować punkt bazowy operacji: przejdź do edytora, zaznacz operację skali i zmień domyślną opcję "Zależny" na "Niezależny". 
 
 
 
 
Określ nową podstawę: Kliknij prawym przyciskiem myszy na pole "Podstawa-X" i "Podstawa-Y", wprowadź ręcznie wartości współrzędnylub kliknij na przycisk z wielokropkiem na prawo od okna i złap punk podstawy.  
 
 
Określ punkt bazowy kursorem celownika w środku okręgu. Następnie opuść edytor bloku i przeskaluj blok dynamiczny. Po modyfikacji typu bazy i jej pozycji, środek skali bloku dynamicznego zmieni się z punktu bazowego parametru XY na nowo określony punkt bazowy (środek okręgu). 
 
 5. Typ skali We właściwościach operacji skali znajduje się opcja typów skali. Domyślna wartość ustawiona jest na "Skala XY". Jeżeli ją wybierzesblok dynamiczny zostanie przeskalowany zawsze, gdy uchwyt zostanie przesunięty wzdłuż osi X lub Y. Jeżeli wybierzesz "Skalę X", skalowanie będzie się odbywało tylko przy ruchu uchwytu wzdłuż osi X, analogicznie w przypadku wartości "Skala Y".  
 
 
 
13.2.15. Obrót W tym dziale, objaśnione zostanie korzystanie z parametru i operacji obrotu. symbolu indeksu widoku (system angielski), jest często używane w rysunkach architektonicznych.
1. Narysuj rysunek:  Narysuj symbol indeksu widoku i określ jako blok, taki jak na rysunku obok. Zdefiniuj numer widoku i narysuj go jako atrybut tekstu, aby moc korygować go w dowolnym momencie.
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3. Sprawdzenie bloku dynamicznego: Po opuszczeniu edytora bloku, przeciągnij uchwyt prawego górnego wierzchołka prostokąta. dynamiczny jest skalowany wraz z przesunięciem uchwytu. skala okręgu i prostokąta zmienia się wraz z punktem bazowym 

akcji kować punkt bazowy operacji: przejdź do edytora, zaznacz operację skali i zmień domyślną opcję "Zależny" na 

Określ nową podstawę: Kliknij prawym przyciskiem myszy na pole Y", wprowadź ręcznie wartości współrzędnych lub kliknij na przycisk z wielokropkiem na prawo od okna i złap punk 

Określ punkt bazowy kursorem celownika w środku okręgu. Następnie opuść edytor bloku i przeskaluj blok dynamiczny. Po modyfikacji typu bazy i jej pozycji, środek skali bloku dynamicznego zmieni się z punktu bazowego parametru XY na nowo określony 

We właściwościach operacji skali znajduje się opcja typów skali. Domyślna wartość ustawiona jest na "Skala XY". Jeżeli ją wybierzesz, blok dynamiczny zostanie przeskalowany zawsze, gdy uchwyt zostanie przesunięty wzdłuż osi X lub Y. Jeżeli wybierzesz "Skalę X", skalowanie będzie się odbywało tylko przy ruchu uchwytu wzdłuż osi X, analogicznie 

W tym dziale, objaśnione zostanie korzystanie z parametru i operacji obrotu. Dodanie funkcji dynamicznego obrotusymbolu indeksu widoku (system angielski), jest często używane w rysunkach architektonicznych. 

symbol indeksu widoku i określ jako blok, taki jak na rysunku obok. Zdefiniuj numer widoku i narysuj go jako atrybut tekstu, aby moc korygować go w dowolnym momencie.  

 

kować punkt bazowy operacji: przejdź do edytora, zaznacz operację skali i zmień domyślną opcję "Zależny" na 

Dodanie funkcji dynamicznego obrotu do 

symbol indeksu widoku i określ jako blok, taki jak na rysunku obok. Zdefiniuj numer widoku i 
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2. Dodaj parametr obrotu:  Wybierz środek okręgu jako pierwszy punkt parametru, prog"przyrost" i zdefiniuj jego miarę na 15 stopni.
           3. Dodaj akcję obrotu:  Kliknij przycisk operacji obrotu w paneparametr, obiekt i pozycję dla operacji i zaznacz całindeksu jako obiekt operacji.  
 
4. Sprawdź blok dynamiczny:  Opuść edytor bloku i wstaw blok, przeciągnij uchwyt obrotu aby sprawdzić efekt obrotu. 
 
 
13.2.16. Rozciąganie biegunowe Funkcję tą można wykorzystać do narysowania symbol
1. Narysuj, zastosuj odbicie lustrzane i zdefiniuj jako blok:Poniższy rysunek zawiera atrybuty tekstu, które mogą być modyfikowane według potrzeb. Utwórz odbicie lustrzane i zdefiniuj lustrzany obiekt jako blok.  
 
   2. Dodaj akcję i parametr dla atrybutu tekstu:Dadaj parametr punktu i operację ruchu do tekstu i zmień opcję operacji łańcuchowej na "Tak". Zostanie użyta w następnym kroku do utworzenia operacji łańcuchowej dla operacji rozciągnięcia biegunowego. 
 
    3. Dodaj parametr biegunowe i akcje:Dodaj parametr biegunowy, którego pierwszym punktem powinien być punkt centralny symbolu przekroju. Punkt ten będzie centrum parametru biegunowego. Wykonaj poniższą instrukcję: 
 

13. Tworzenia i edycja bloków dynamicznych 

144 

Wybierz środek okręgu jako pierwszy punkt parametru, program określi go jako domyślny punkt obrotu, ustaw typ kąta jako "przyrost" i zdefiniuj jego miarę na 15 stopni.  

operacji obrotu w panelu operacji, dopasuj zaznacz cały symbol 

przeciągnij uchwyt obrotu aby 

Funkcję tą można wykorzystać do narysowania symbolu sekcji. 
1. Narysuj, zastosuj odbicie lustrzane i zdefiniuj jako blok: Poniższy rysunek zawiera atrybuty tekstu, które mogą być modyfikowane według potrzeb. Utwórz odbicie lustrzane i zdefiniuj 

i parametr dla atrybutu tekstu: Dadaj parametr punktu i operację ruchu do tekstu i zmień opcję operacji łańcuchowej na "Tak". Zostanie użyta w następnym kroku do utworzenia operacji łańcuchowej dla operacji 

: Dodaj parametr biegunowy, którego pierwszym punktem powinien być punkt centralny symbolu przekroju. Punkt ten będzie centrum parametru biegunowego. 

 

ram określi go jako domyślny punkt obrotu, ustaw typ kąta jako 

Poniższy rysunek zawiera atrybuty tekstu, które mogą być modyfikowane według potrzeb. Utwórz odbicie lustrzane i zdefiniuj 
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1. Wybierz prawy uchwyt parametru biegunowego jako powiązany z parametrem punktowym i określ okno rozciągnięcia (Rys. 3.1). 2.Zaznacz obiekty do rozciągnięcia i pozycję parametru punktu, aby tekst i fragment symbolu mogły być przesuwane razem. (Rys. 3.2). 3. Określ obiekty, które obracają się jedynie przez operację rozciągnięcia4. Określ położenie symbolu operacji. 5. Powtórz powyższe kroki aby dodać taki sam parametr i operację dla lewego symbolu przekroju.          Rys. 3.1            Rys. 3.3   Lepiej, jeżeli uchwyty nie związane z parametrem rozciągania biegunowego zostaną ukryte. Tak jak poniżej:            4. Sprawdź blok dynamiczny: Otwórz grafikę, która wymaga zwymiarowania i wstaw gotowy blok dynamiczny ( Rys. 4.1). Przeciągnij uchwyt bloku dynamicznego, symbol przekroju może zostać rozciągnięta na zewnątrz i obrócona dookoła punktu środkowego (Rys. 4.2).     

13.2.17. Modyfikacja akcji rozciągnięcia biegunowegoZmodyfikuj numery uchwytów parametru biegunowego, bloku dynamicznego symbolu przekroju z poprzedniego przykładu aby wyświetlić obydwa uchwyty parametru biegunowego. Na rysunkach możesz zobaczyć, że środkowy uchwyt został zmieniony. Przed modyfikacją, punkt środkowy był punktem bazow
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biegunowego jako powiązany z parametrem punktowym i określ okno rozciągnięcia 
2.Zaznacz obiekty do rozciągnięcia i pozycję parametru punktu, aby tekst i fragment symbolu mogły być przesuwane razem. 

się jedynie przez operację rozciągnięcia 
5. Powtórz powyższe kroki aby dodać taki sam parametr i operację dla lewego symbolu przekroju.  

 Rys. 3.2 

 Rys. 3.4 

jeżeli uchwyty nie związane z parametrem rozciągania biegunowego zostaną ukryte. Tak jak poniżej:

Otwórz grafikę, która wymaga zwymiarowania i wstaw gotowy blok dynamiczny ( Rys. 4.1). dynamicznego, symbol przekroju może zostać rozciągnięta na zewnątrz i obrócona dookoła punktu 

 Rys 4.1 

13.2.17. Modyfikacja akcji rozciągnięcia biegunowego parametru biegunowego, bloku dynamicznego symbolu przekroju z poprzedniego przykładu aby wyświetlić obydwa uchwyty parametru biegunowego. Na rysunkach możesz zobaczyć, że środkowy uchwyt został zmieniony. Przed modyfikacją, punkt środkowy był punktem bazowym 

 
biegunowego jako powiązany z parametrem punktowym i określ okno rozciągnięcia 

2.Zaznacz obiekty do rozciągnięcia i pozycję parametru punktu, aby tekst i fragment symbolu mogły być przesuwane razem. 

 

 

jeżeli uchwyty nie związane z parametrem rozciągania biegunowego zostaną ukryte. Tak jak poniżej:  

 Rys 4.2 
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bloku i jednocześnie punktem wstawienia. Natomiast po modyfikacji, punkt środkowy bloku jest punktem bazowym parametru biegunowego.  
 Klikając na środkowy uchwyt możesz przesunąć go w dowolnym kierunku. tymczasem, ciemnoniebieski punkt wstawienia bloku pojawi się ponownie, tak jak pokazano na rysunku. Oczywiście, punkt wstawienia jest przykryty punktem bazowym parametru biegunowego. Punkt bazowy może przesuwać się dowolnie ale blok wydaje się nie reagować na zmianę.  
Aby potwierdzić zmiany w bloku lub zaciskach. Możesz zauważyć, że symbol przekroju nie znajduje się w punkcie środkowym na  ciemnoniebieskim punkcie bazowym podczas zmiany ale powiązany jest z punktem bazowym innego parametru biegunowego, takiego jak obrót względem środka.
Otwórz edytor bloku, przesuń parametr i pozostaw pozostałe ustawienia bez zmian. 
 
      Opuść edytor bloków i przesuń prawy uchwyt. Zauważ, że ruch obrotu względem środa odbywa się wzdłuż parametru. Dla przykładów powyżej jest trudno wytłumaczyć, że parametr biegunowy nie może być przesuwany tak jak parametr punktu czy parametr liniowy. Powodem tego jest to, że punkt bazowy parametru biegunowego jest przesuwany odpowiednio z punktem obrotu.       
13.2.18. Szyk Dla funkcji szyku bloku dynamicznego, należy użyć operacji szyku. Służy ona do dopasowania parametru liniowego, biegunowego, XY utworzenia rożnych tablic.
Szyk liniowy 
1. Narysuj: Narysuj tabelę listy części i zdefiniuj ją jako blok.  
2. Dodaj parametr liniowy:  Po dodaniu operacji szyku, możesz przeciągnąć dwa uchwyty parametru aby utworzyć szyk listy. Oczywiście celem jest osiągnięcie górnego szyku pustych kratek a nie szyku dolnego. Aby uniknąć pomyłek należy ukryć uchwyt pod tak jak na rysunku poniżej.   
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bloku i jednocześnie punktem wstawienia. Natomiast po modyfikacji, punkt środkowy bloku jest punktem bazowym 

Klikając na środkowy uchwyt możesz przesunąć go w dowolnym kierunku. tymczasem, ciemnoniebieski punkt wstawienia u pojawi się ponownie, tak jak pokazano na rysunku. Oczywiście, punkt wstawienia jest przykryty punktem bazowym parametru biegunowego. Punkt bazowy może przesuwać się dowolnie ale blok wydaje 

Aby potwierdzić zmiany w bloku lub ich brak, należy przesunąć uchwyty na obu zaciskach. Możesz zauważyć, że symbol przekroju nie znajduje się w punkcie środkowym na  ciemnoniebieskim punkcie bazowym podczas zmiany ale powiązany jest z punktem bazowym innego parametru k obrót względem środka.  
Otwórz edytor bloku, przesuń parametr i pozostaw pozostałe ustawienia 

Opuść edytor bloków i przesuń prawy uchwyt. Zauważ, że ruch obrotu względem środa odbywa się wzdłuż parametru. rudno wytłumaczyć, że parametr biegunowy nie może być przesuwany tak jak parametr punktu czy parametr liniowy. Powodem tego jest to, że punkt bazowy parametru biegunowego jest przesuwany 

dynamicznego, należy użyć operacji szyku. Służy ona do dopasowania parametru liniowego, biegunowego, XY utworzenia rożnych tablic. 

Narysuj tabelę listy części i zdefiniuj ją 

Po dodaniu operacji szyku, możesz przeciągnąć dwa uchwyty parametru aby utworzyć szyk listy. Oczywiście celem jest osiągnięcie górnego szyku pustych kratek a nie szyku dolnego. Aby uniknąć pomyłek należy ukryć uchwyt pod 

 
bloku i jednocześnie punktem wstawienia. Natomiast po modyfikacji, punkt środkowy bloku jest punktem bazowym 

Klikając na środkowy uchwyt możesz przesunąć go w dowolnym kierunku. tymczasem, ciemnoniebieski punkt wstawienia u pojawi się ponownie, tak jak pokazano na rysunku. Oczywiście, punkt wstawienia jest przykryty punktem bazowym 

dynamicznego, należy użyć operacji szyku. Służy ona do dopasowania parametru liniowego, 

Po dodaniu operacji szyku, możesz przeciągnąć dwa uchwyty parametru aby utworzyć szyk listy. Oczywiście celem jest osiągnięcie górnego szyku pustych kratek a nie szyku dolnego. Aby uniknąć pomyłek należy ukryć uchwyt pod parametrem, 
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3. Dodaj operację szyku: Podczas dodawania operacji szyku, program wymaga przestrzeni między kolumnami. Jest to odległość pomiędzy obiektami, które tworzą tabelę. Szerokość linii ustawiona jest na 7 mm, dla linmoże być wybrana. W przykładzie przestrzeń ta wynosi 7mm.
 
  4. Sprawdź blok dynamiczny: Wstaw blok dynamiczny, przeciągnij prawy górny uchwyt w gorę. Spowoduje to automatyczne dodanie liczby komórek tabeli, tak jak na rysunku.                  Szyk XY W porównaniu do szyku liniowego, szyk ten posiada kierunek pionowy.  
 
Szyk biegunowy Jak można było zobaczyć na przykładzie, po przeciągnięciu uchwytu otrzymany efekt będzie wyglądał jak na rysunku obok. Zauważ, że ogrodzenie może być nie tylko rozciągnięte ale i obrócone w przypadkowym kierunku. Jest to wynik połączenia rozciągania biegunowego z szykiem biegunowym.   
  Otwórz edytor bloku. Aby dodać operację szyku tak jak na rysunku, obiekty pogrubione wyrażają wybrane operacje. Parametr biegunowy określa kierunek szyku, sprawia to, że szyk biegunowy przyjmie kierunek parametru biegunowego jako swój kierunek, aby zrealizować funkcję szyku w dowolnym kierunku.
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Podczas dodawania operacji szyku, program wymaga przestrzeni między kolumnami. Jest to odległość pomiędzy obiektami, które tworzą tabelę. Szerokość linii ustawiona jest na 7 mm, dla linmoże być wybrana. W przykładzie przestrzeń ta wynosi 7mm. 

Wstaw blok dynamiczny, przeciągnij prawy górny uchwyt w gorę. Spowoduje to automatyczne dodanie liczby komórek tabeli, tak jak na rysunku. 

Jak można było zobaczyć na przykładzie, po przeciągnięciu uchwytu otrzymany efekt będzie wyglądał jak na rysunku obok. Zauważ, że być nie tylko rozciągnięte ale i obrócone w przypadkowym kierunku. Jest to wynik połączenia rozciągania biegunowego z 

Otwórz edytor bloku. Aby dodać operację szyku tak jak na rysunku, obiekty pogrubione wyrażają wybrane Parametr biegunowy określa kierunek szyku, sprawia to, że szyk biegunowy przyjmie kierunek parametru biegunowego jako swój kierunek, aby zrealizować funkcję szyku w dowolnym kierunku.  
 

 
Podczas dodawania operacji szyku, program wymaga przestrzeni między kolumnami. Jest to odległość pomiędzy obiektami, które tworzą tabelę. Szerokość linii ustawiona jest na 7 mm, dla linii pomiędzy wierszami 

Wstaw blok dynamiczny, przeciągnij prawy górny uchwyt w gorę. Spowoduje to 
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14. Udostępnianie danych pomiędzy aplikacjami 
 
14.1. Wsparcie środowiska .NET Framework 
Środowisko .NET umożliwia programowanie aplikacji, nakładek, bibliotek oraz innych dodatków dostępnych również dla innych języków programowania, takich jak: VB.NET, C#, C++ itp. Użytkownik otrzymuje możliwość do automatyzacji niektórych zadań, takich jak tworzenie i edycja obiektów przechowywanych w bazach danych rysunków, lub zmiany zawartości personalizowanych plików. 
 
14.2. Przechowywanie danych w chmurze 
Współpracę pomiędzy różnymi branżami oraz etapami projektów umożliwia przechowywanie plików rysunków projektu w chmurze, oraz ich synchronizowanie.            Synchronizacja plików rysunkowych Po założeniu konta otrzymasz dostęp do przeglądania i udostępniania danych poprzez chmurę. Masz możliwość przesyłania i pobierania danych za pomocą serwera chmury. Dla zwiększenia czytelności możesz tworzyć kategorie dla różnych plików. Wszystkie niezbędne czynności w zakresie zarządzania danymi w chmurze możesz wykonywać za pomocą komputera stacjonarnego, tabletu lub innego urządzenia mobilnego. 
Personalizacja ustawień synchronizacji Możesz dostosować niektóre ustawienia programu zgodnie z bieżącymi potrzebami. Oprócz przechowywania ich na dysku lokalnym możesz zapisywać je w chmurze, aby szybko pobrać je i użyć na innym urządzeniu. 
 
14.2.1. Ustawienia chmury Za pomocą okna dialogowego opcji, w zakładce Cloud Storage Sync Settings (wer. PL: Ustawienia synchronizacji przechowywania danych w Chmurze) znajdziesz odpowiednie opcje konfiguracji. 
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 W oknie tym możesz wybrać jeden z dostępnych serwerów chmury, oraz zobaczyć informacje o posiadanym koncie. Dodatkowo możesz określić, gdzie mają być pobierane pliki z serwera chmury.  Za pomocą przycisku Authorize (wer. PL: Autoryzacja) możesz zalogować się do wybranego serwera używając danych swojego konta.                      
14.2.2. Wysyłanie rysunków do serwera chmury Aby zamieścić swój rysunek w chmurze kliknij przycisk Upload Drawing (wer. PL: Załaduj rysunek) znajdujący się w zakładce Cloud (wer. PL: Chmura), a następnie wybierz plik rysunku, który chcesz wysłać.             Po wysłaniu pliku pojawi się okno dialogowe, w którym możesz stworzyć nowy folder dla swojego rysunku.               O pomyślnym zapisaniu pliku w chmurze zostaniesz powiadomiony komunikatem wyświetlanym przez ikonę znajdującą się w zasobniku systemu Windows. 
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14.2.3. Pobieranie rysunków z serwera chmury Aby pobrać plik z serwera, kliknij na przycisk Download (wer. PL: Pobierz), znajdujący się w zakładce Cloud (wer. PL: Chmura).             System Windows wyświetli okno dialogowe.                Możesz w nim wybrać plik, który ma zostać pobrany na dysk lokalny. Ponownie po pomyślnym pobraniu pliku zostaniesz powiadomiony komunikatem systemowym. 

 
14.2.4. Wysyłanie bieżącego rysunku do serwera chmury Podczas nanoszenia zmian w bieżącym rysunku możesz zapisywać te zmiany również w kopii tego pliku znajdującego się w chmurze. W tym celu skorzystaj z przycisku Upload Current Drawing (wer. PL: Załąduj bieżący rysunek). 
 
 
Po zakończeniu edycji pliku możesz zaznaczyć opcję Automatically upload a drawing when you save (wer. PL: Prześlij automatycznie po zapisaniu zmian w pliku) znajdującej się w oknie dialogowym opcji chmury.  

 
W nowo wyświetlonym oknie dialogowym wybierz folder, w którym ma zostać zapisany rysunek.  
Po zakończeniu pracy możesz odznaczyć Automatically upload a drawing when you save (wer. PL: Prześlij automatycznie po zapisaniu zmian w pliku) znajdującej się w oknie dialogowym opcji chmury, jeśli nie chcesz aby wszystkie zmiany były automatycznie zapisywane w chmurze. 
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14.2.5. Tworzenie i przywracanie kopii zapasowej konfiguracji Możesz wykonać kopię zapasową ustawień rysunku oraz programu klikając przycisk BackupConfig (wer. PL: Kopia zapasowa konfiguracji), znajdujący się w zakładce Cloud (wer. PL: Chmura).           Wszystkie spersonalizowane ustawienia mogą być przechowywane na dysuku lokalnym lub w chmurze. Zapis w chmurze pozwala na łatwe odzyskanie lub pobranie ustawień na inne urządzenie.                   Możesz również szybko przywrócić ustawienia klikając przycisk Restore Config (wer. PL: Przywracanie konfiguracji). Należy potwierdzić wykonanie operacji klikająć przycisk Yes (wer. PL: Tak).             
14.3. Polecenie Copylink 
Za pomocą polecenia COPYLINK, użytkownik może skopiować bieżący widok rysunku, a następnie wstawić go do innego rysunku jako obiekt OLE. 
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15. Innowacyjne rozwiązania 
15.1. Rozszerzenia funkcji rysowania linii 
Polecenie ANGLE (A) (wer. PL: KĄT(A)) pozwala na szybkie rysowanie linii bez pomocy linii konstrukcyjnych. Wystarczy, że wprowadzisz żądaną wartość kąta, odnoszącą się do osi X. Możesz również określić do jakiej linii na rysunku  ma odnosić się zadany kąt. 
Przykłady: 
Aby narysować figurę jak na rysunku obok, wykonaj: 1. Wprowadź polecenie LINE. 2. Określ punkt początkowy. 3. Określi drugi punkt lub wybierz inną opcję: [Kąt(A)/Długość(L)/Cofnij(U)]: A. 4. Wybierz opcję Kąt [Odniesienie(R)]: R, i wprowadź wartość 35, odpowiadającą mierze kąta. 5. Określ długość linii jako 500.  
 
Aby narysować figurę jak na rysunku obok, wykonaj: 1. Wprowadź polecenie LINE. 2. Określ punkt początkowy. 3. Określi drugi punkt lub wybierz inną opcję: [Kąt(A)/Długość(L)/Cofnij(U)]: A. 4. Wybierz opcję Kąt [Odniesienie(R)]: R. 5. Zaznacz linię na rysunku (będącą nową linią odniesienia dla kąta). 6. Określ wartość miary kąta jako 38 7, a długość linii jako 500.  
 
Aby narysować figurę jak na rysunku obok, wykonaj: 1. Wprowadź polecenie LINE. 2. Określ punkt początkowy. 3. Określi drugi punkt lub wybierz inną opcję: [Kąt(A)/Długość(L)/Cofnij(U)]: L. 4. Określ długość linii jako 300. 5. Określi drugi punkt lub wybierz inną opcję: [Kąt(A)/Długość(L)/Cofnij(U)]: A. 6. Wybierz opcję Kąt [Odniesienie(R)/odniesienie do Poprzedniego(P)]: P (Ten krok pozwala określić poprzednio narysowaną linię jako linię odniesienia dla kąta). 7. Określ wartość miary kąta jako 127. 8. Określ długość linii jako 500. 9. Określi drugi punkt lub wybierz inną opcję: [Kąt(A)/Długość(L)/Cofnij(U)]: A (Aby narysować trzeci bok trójkąta) . 10. Wybierz opcję Kąt [Odniesienie(R)/odniesienie do Poprzedniego/uwzględniony kąt(I)]: I. 11. Określ wartość miary kąta jako 37. 12. Określ długość linii jako 400.  
15.2. Rozszerzenie funkcji rysowania polilinii 
W przypadku rysowania polilinii polecenie ANGLE (A) (wer. PL: KĄT(A)) zachowuje się podobnie, jak w przypadku rysowania zwykłych linii. Możesz wybrać jedną z trzech opcji, lub wprowadzić wartość kąta odnoszącą się do osi X, poprzednio narysowanej polilinii lub kąta zawartego. W programach typu CAD wiele obiektów złożonych jest z polilinii, na przykład: prostokąty czy wieloboki. Opcje pozwalające szybko narysować obiekty złożone z polilinii znajdziesz w menu rozwijalnym narzędzi rysowania.    
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15.3. Rozszerzenia funkcji rysowania prostokątów 
Nowododaną opcją rysowania prostokątów jest OBLIQUE(O) (wer. PL: Pochylenie(O). Opcja ta pozwala określić nachylenie rysowanego prostokąta względem osi X lub innej linii, zadanej jako linia odniesienia. 
Przykłady: 
Aby narysować nachylony prostokąt jak na rysunku obok, wykonaj: 1. Wprowadź polecenie RECTANGLE i wybierz opcję OBLIQUE(O) (wer. PL: Pochylenie(O)), lub kliknij ikonę opcji Przekręć znajdującą się na wstążce. 2. Określ punkt początkowy. 3. Określi drugi punkt lub wybierz inną opcję: [Kąt(A)]: A. 4. Określ wartość miary kąta jako 20. 5. Określ wartość długości prostokąta jako 800. 6. Określ wartość wysokości prostokąta jako 350.  
 
Aby narysować nachylony prostokąt jak na rysunku obok, wykonaj: 1. Wprowadź polecenie RECTANGLE i wybierz opcję OBLIQUE(O) (wer. PL: Pochylenie(O)), lub kliknij ikonę opcji Przekręć znajdującą się na wstążce. 2. Określ punkt początkowy. 3. Określi drugi punkt lub wybierz inną opcję: [Kąt(A)]: A. 4. Wybierz opcję Kąt [Odniesienie(R)]: R. 5. Zaznacz linię na rysunku (będącą nową linią odniesienia dla kąta). 6. Określ wartość miary kąta jako 20. 7. Określ wartość długości prostokąta jako 800. 8. Określ wartość wysokości prostokąta jako 350.  
 
15.4. Rozszerzenie funkcji rysowania okręgów 
Opcja CONCENTRIC(C) (wer. PL: Koncentrycznie(C)), wzbogaca polecenie CIRCLE o możliwość rysowania wielu okręgów o różnych promieniach, i tym samym punkcie środkowym. 
Przykład: 
Aby narysować nachylony okręgi koncentryczne jak na rysunku obok, wykonaj: 1. Wprowadź polecenie CIRCLE i wybierz opcję Koncentrycznie(C), lub kliknij ikonę opcji Koncentrycznie znajdującą się na wstążce. 2. Określ punkt środkowy okręgów. 3. Określ wartość długości promienia okręgu jako 100. 4. Określ wartość długości promienia okręgu jako 200.  5. Określ wartość długości promienia okręgu jako 300. 
 
15.5. Rozszerzenie funkcji kopiowania 
Do funkcji COPY dodano opcje: miara(E), podział(I), ścieżka(P). Opcje te pozwalają na łatwe wykonanie czynności związanych z wykańczaniem rysunku. 
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1. Miara(E), pozwala na skopiowanie obiektów przesuniętych o tą samą odległość i w tym samym kierunku.  
               2. Podział(I), możesz kopiować obiekty w określonej odległości.            3. Ścieżka(I), po wybraniu tej opcji możesz ponownie skorzystać z podziału lub miary, aby rozmieścić wybrane obiekty.              
15.6. Rozszerzenie funkcji obrotu 
Opcja Wiele(M) pozwala na skopiowanie kliku obiektów o różnych kątach obrotu, lub stworzenie szyku okręgów. Podczas wykonywania polecenia ROTATE opcja Wiele(M) pozwala na określenie kilku wartości miary kąta obrotu dla obracanych i kopiowanych obiektów. 
Przykłady: 
Aby uzyskać efekt jak na rysunku obok, wykonaj: 1. Wykonaj polecenie ROTATE. 2. Wybierz obiekt. 3. Określ punkt bazowy (wybierz punkt środkowy okręgów koncentrycznych). 4. Wybierz kąt obrotu, lub opcję: [Kopiuj(C)/Wiele(M)/Odniesienie(R)]: M. 5. Określ wartość miary kąta obrotu jako 45. 6. Określ wartość miary kąta obrotu jako 90. 7. Określ wartość miary kąta obrotu jako 135.  
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Aby uzyskać efekt jak na rysunku obok, wykonaj: 1. Wykonaj polecenie ROTATE. 2. Wybierz obiekt (wybierz punkt środkowy okręgów koncentrycznych). 3.Określ punkt bazowy. 4. Wybierz kąt obrotu, lub opcję: [Kopiuj(C)/Wiele(M)/Odniesienie(R)]: M. 5. Wybierz kąt obrotu, lub opcję: [Pomiędzy(B)/Wypełnij(F))]: B. 6. Określ wartość miary kąta obrotu jako 60. 7. Określ całkowitą liczbę elementów jako 4.  
 
 
Aby uzyskać efekt jak na rysunku obok, wykonaj: 1. Wykonaj polecenie ROTATE. 2. Określ punkt bazowy (wybierz punkt środkowy okręgów koncentrycznych). 3. Wybierz kąt obrotu, lub opcję: [Kopiuj(C)/Wiele(M)/Odniesienie(R)]: M. 4. Wybierz kąt obrotu, lub opcję: [Pomiędzy(B)/Wypełnij(F))]: F. 5. Określ wartość miary kąta dla wypełnienia jako 360. 6. Określ całkowitą liczbę elementów jako 1.  
 
  
15.7. Lupa 
Polecenie MAGNIFER pozwala na powiększanie określonego  obszaru rysunku w czasie rzeczywistym, korzystając z punktów skoku, bez konieczności wywoływania polecenia ZOOM. Lupa pomaga zaoszczędzić czas podczas przeglądania detali dużych rysunków. 
1.- Zanim wykonasz polecenie MAGNIFER możesz określić stosowne opcjie. W tym celu kliknij prawym przyciskiem myszy na ikonę lupy znajdującej się na pasku stanu i z menu kontekstowego wybierze Settings (wer. PL: Ustawienia). 
 
     2.- W okonie dialogowym ustawień znajduję się klika opcji do wyboru.                  
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Enable Magnifer by Scroll button (wer. PL: Włącz Magnifer za pomocą przycisku przewijania): Jeżeli opcja ta jest zaznaczona polecenie MAGNIFER jest wywoływane za pomocą przycisku przewijania myszy, lub za pomocą skrótu Ctrl+E. 
Magnifer Style (wer. PL: Styl powiększania):  Region (wer. PL: Region): Kursor myszy może poruszać się wyłącznie w obszarze powiększenia. Window (wer. PL: Okno): Kursor myszy może przemieszczać się w obszarze całego rysunku, pełni również rolę obszaru powiększenia. 
Magnifer Shape (wer. PL: Kształt powiększenia): Square (wer. PL: Kwadrat): Obszar powiększania ma kształt prostokątny. Circle (wer. PL: Okrąg): Obszar powiększania ma kształt okręgu. 
Magnifer Size (wer. PL: Rozmiar powiększenia): Pozwala na wybór rozmiaru obszaru powiększenia. 
Magnifer Factor (wer. PL: Kontrola wygaszenia): Pozwala na określenie współczynnika wygaszenia obszaru znajdującego się poza obszarem powiększenia. 
Magnifer Factor (wer. PL: Współczynnik powiększenia): Pozwala na określenie współczynnika powiększenia. 
 
15.8. Kody QR 
Kody QR (ang. Quick response code), to rodzaj kodu kreskowego, używany do łatwego zamieszczania dodatkowych informacji, które mogą zostać odczytane za pomocą urządzeń mobilnych. W porównaniu do tradycyjnego kodu kreskowego, kod QR może przechowywać dużo więcej informacji.  
Parametry tworzenia kodu QR: 
Input (wer. PL: Wprowadź tekst): Pozwala na wprowadzenie tekstu, który ma zostać zakodowany za pomocą kodu (długość tekstu jest ograniczona do 500 znaków). Pick Object (wer. PL: Wybierz obiekt): Pozwala na wybranie z obszaru rysunku obiektu, kótry ma zostać zakodowany za pomocą kodu. Preset data (wer. PL: Dane domyślne): Możesz określić domyślne dane, które zostanąautomatycznie dodane w polu wprowadzanie tekstu. 
Parametry personalizacji pól kodów QR: 
Name>Add/Edit (wer. PL: Nazwa>Dodaj/Edytuj): Możesz skorzystać z często używanych pól, gdy zajdzie potrzeba wstawienai jednego z pól skorzystaj z okna dialogowego. 
No (wer. PL: Nr): Wyświetla kolejny numer pola. Name (wer. PL: Nazwa): Wyświetla nazwę pola. Value (wer. PL: Wartość): Wprowadza wartość pola. Add (wer. PL: Dodaj): Pozwala na dodanie nowego pola. Delete (wer. PL: Usuń): Pozwala na usunięcie pola. Image (wer. PL: Obraz): Pozwala na dodanie do kodu QR pliku obrazu w formacie JPG/BMP/PNG/TIF/TGA itp. Delete (wer. PL: Usuń): Pozwala na usunięcie wybranego obrazu.  
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Parametry kodu QR: Możesz określić parametry generowania kodu QR, takie jak: 
Version (wer. PL: Wersja): Określ wersje kodu, od najmniejszej do największej, zgodnie z przyrostem ilości tekstu. Error Level (wer. PL: Poziom błędu): Określ dokładność generowanego kodu QR. Code (wer. PL:  Kod): Wybierz rodzaj kodu, bieżąco program GstarCAD wspiera kod: Code93. Scale (wer. PL: Skala): Określ skalę drukowania kodu. Możesz dostosować skalę za pomocą skal dostępnych na liście, lub powiązać skalę kodu QR z bieżącą skalą wydruku. Dodatkowo jeśli wygenerujesz kod QR w postaci bloku, jego skala będzie skalą bloku pozwalając wydrukować kod QR zapewniając odpowiednią skalę, w różnych skalach wydruku.         Copy Barcode (wer. PL:  Kopiuj kod kreskowy): Kopiuje kod kreskowy z bieżącego rysunku. Save Image (wer. PL: Zapisz obraz): Zapisuje kodu QR jako obraz, co pozwala na wklejenie wygenerowanego kodu do innego dokumentu. Insert (wer. PL: Wstaw): Wstawia wygenerowany kod QR do rysuknku, jako blok. Cancel (wer. PL: Anuluj): Anuluje wprowadzone zmiany.  

 
15.9. Kody kreskowe 
Kody kreskowe są powszechnie stosowaną metodą zapisywania i przekazywania informacji. Mogą być również stosowane do zapisywania dodatkowych informacji w projekcie typu CAD. Pozwalają na zapisywanie informacji na temat stworzonego obiektu, rysunku czy projektu.                Parametry tworzenia kodu kreskowego: 
Width (wer. PL: Szerokość): Określa szerokość generowanego kodu. Height (wer. PL: Wysokość): Określa wysokość generowanego kodu. Scale (wer. PL: Skala): Określ skalę drukowania kodu. Możesz dostosować skalę za pomocą skal dostępnych na liście, lub powiązać skalę kodu kreskowego z bieżącą skalą wydruku. Dodatkowo jeśli wygenerujesz kod kreskowego w postaci bloku, jego skala będzie skalą bloku pozwalając wydrukować kod kreskowego zapewniając odpowiednią skalę, w różnych skalach wydruku. Display Data (wer. PL: Wyświetlane dane): Określa czy dane mają być wyświetlne pod wygenerowanym kodem kreskowym. Size (wer. PL: Wielkość): Określa wysokość wyświetlanego tekstu, gdy opcja wyświetlania danych jest zaznaczona). Preview (wer. PL; Podgląd): Wyświetla podgląd generowanego kodu kreskowego. Seed (wer. PL: Ziarno): Pozwala na wygenerowanie kodu za pomocą algorytmu losowego. Lenght (wer. PL: Długość): Określa długość generowanego kodu kreskowego. 
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Pick (wer. PL: Wybierz): Pozwala na wybranie tekstu lub kodu kreskwego. Save Image (wer. PL: Zapisz obraz): Zapisuje kodu kreskowy jako obraz, co pozwala na wklejenie wygenerowanego kodu do innego dokumentu. Insert (wer. PL: Wstaw): Wstawia wygenerowany kod kreskowy do rysuknku, jako blok. Cancel (wer. PL: Anuluj): Anuluje wprowadzone zmiany.  
Uwaga: Informacje o innych nowych rozwiązaniach znajdziesz w objaśnieniach działania narzędzi zakładki Express. 


